Dell Latitude E7270/E7470 System BIOS 1.15.4, Bitlocker fails - General Hardware - Laptop - Dell Community

Dell Latitude E7270/E7470 System BIOS 1.15.4, Bitlocker fails


Laptop computer Forums (Audio, General Hardware, Video)

Dell Latitude E7270/E7470 System BIOS 1.15.4, Bitlocker fails

This question has been answered by Allen Madding

E7470 laptop was running fine on BIOS 1.12.3 but received security advisory concerning AMT vulnerability.

BIOS 1.15.4 was just released to address concerns for security advisory CVE-2017-5689 / INTEL-SA-00075.  Applied BIOS revision to the E7470, but after applying it continued to prompt for Bitlocker code after each restart.  Unable to successfully leave Bitlocker protectors on without being prompted for code after each reboot so opted for reimage.

Ran through process of reimaging computer via MDT, but now receive error in smsts logs:

'ProtectKeyWithTPM' failed (2150694914)

Failed to enable key protectors (0x80310002)

Failed to run the action: Enable BitLocker.
The BIOS did not correctly communicate with the Trusted Platform Module (TPM). Contact the computer manufacturer for BIOS upgrade instructions. (Error: 80310002; Source: Windows)

Can someone please confirm issue with this latest BIOS and will need Dell to re-evaluate.



Verified Answer
  • Dell has posted BIOS Version 1.16.4

    with the following notes:

    Fixes & Enhancements

    - Fixed sometimes boot loop issue when Trusted Execution is enabled in the BIOS setup.
    - Fixed USB keyboard and mouse not working when Bitlocker enabled.
    - Fixed internal LCD hexagonal grid issue.
    - Fixed system show blue screen after resume from sleep with HDD password set and AHCI SATA mode.
    - Fixed Bitlocker can't be enabled on TPM 1.2 systems with Windows 7 OS.

    - Updated Intel processor microcode.
    - Updated Intel Trusted Execution Technology ACM.


    just downloaded and will be testing to see if this resolves our issues

All Replies
  • So far, I have seen two threads (Latitude E7470 & Latitude 5280) who went to the latest BIOS and now TPM is not available. Attempting to downgrade a BIOS is always risky as it could "brick" the motherboard CMOS if it fails. Makes sense that the image failed because the image was made when TPM was enabled. For now, all we can do on the Forum is gather the system models, BIOS number, and usernames and track it.

  • I'm having same issue on mine after upgrading my BIOS with the latest version.  

    Good to see another user with same issue! 

    [UPDATED to include model number of my laptop] I have Latitude E7470.

  • Also running the same issue. E7470. Bios upgraded to 1.15.4.

  • Ran into the same issue. E7470.

  • We are seeing this same issue with our 7470s. We upgrade the bios due to a screen flickering issue while in the docking station.

    On the laptop that had been bitlocked it request a key on every reboot (yes the proper process for upgrading was followed).

    On new laptop that have yet to be bitlocked it same issue as above.

    We are running Windows 7 with tpm version 1.2.

  • Hi Chris,

    Thanks for paying attention to this thread.  A corporate reimaging process was applied to the system in question and all done from scratch even resetting the TPM beforehand.  Although this has patched the AMT vulnerability, use of both AMT and TPM is a requirement for our environment.  Since this has now affect use of TPM, we would be unable to apply this BIOS to our E7470 and E7270 equipment, so I would appreciate any push of attention to this to BIOS engineering as I can see I am not the only one affected.



  • Hi Chris, I have an E7470 with BIOS 1.15.4, and when I tried to configure Bitlocker, it would not recognize the TPM, so I have the same problem as these other users.

  • I am not really sure what this response from Client Technical Support means. Please comment on it =

    That is not one of the errors that we have seen being the result of the previous BIOS updates. Usually this one would be the result of Bitlocker simply not being disabled prior to updating the BIOS. Resetting the TPM now that the BIOS is installed will resolve.

  • I am getting the same issue just trying to setup BitLocker.  I get..

    "The Trusted Platform Module (TPM) on this computer does not work with the current BIOS.  Contact the computer manufacture for the BIOS upgrade instructions.”

    I have:

    - Windows 7 x64

    - Legacy boot

    - TPM 1.2

    Ive tried (either single or with combinations of the following) clearing the Clearing the TPM, rebooting many times, initialize the TPM many times.  

    I was able to successfully setup BitLocker with BIOS 1.13.4 last week or 2. So i tried to install 1.13.4 on this laptop having the issue and bitlocker did not work still.

  • AdamBRCRI I have done exactly what you have done and have the same problem.

  • I am running also in this issue when upgrading to Bios Version 1.5.4

    We are using E7270 with Windows 7 x64, TPM 1.2, Legacy Boot

    So we tried to downgrade to Version 1.3.4 an there everything is working fine.

  • Same issue here, Latitude E7470 upgraded to the latest BIOS 1.15.4. BitLocker suspended prior the upgrade. Since that time, after each reboot, I have to enter the recovery key. And in Windows 7, BitLocker says it is not compatible with the current BIOS.

  • Chris M, any news from Dell?

  • What's the story here...E7470 and E7270 running the latest BIOS are requesting Bitlocker Keys at every boot! These are freshly imaged, all windows updates installed, and all Dell Command updates installed. The drives were encrypted post-imaging/updating successfully, but are asking for the key every boot. Super annoying having to type the keys in a dozen times to troubleshoot/test. Get a fix out Dell!!

  • I don't know if this is coincidental but I'm experiencing increased cooling fan noise since I updated the BIOS.   I also have issue with viewing content of My Computer.  For example, it does not show C:\ drive, as well as my network shared drives.

    Are you guys experiencing the same also?