DELL WD15 Type-C Docking Not working with XPS 15 9550 after failed firmware update - General Hardware - Laptop - Dell Community

DELL WD15 Type-C Docking Not working with XPS 15 9550 after failed firmware update

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

DELL WD15 Type-C Docking Not working with XPS 15 9550 after failed firmware update

This question is not answered

I've been using my Dell XPS 15 9550 for a couple of months now and everything was fine, i decided to connect it to an external monitor P2715Q through a Dell WD15 Type-C docking station, which working fine except for having the Monitor at 30Hz versus 60Hz. i've been facing alot of Blue Screen Errors, and one day found there was a firmware update for the Docking Station, the Monitor went blank and found the firmware was updating usually when i startup my laptop and it's connected to the docking station it gives me a warning message about the power being less than 60W so i unplugged the Type C cable connecting the dock to  the Laptop mid installation, it rolled back and i then figured i shouldn't have disconnected it. This morning i connected my dock as usual but it wasn't being recognized it's as if the Type C wasn't reading the Dock, i connected a Type C to Display port cable direct to the monitor to check if it was the port but that worked instantly, please help what should i do? 

All Replies
  • Unplugging mid firmware update is a no no. Try the firmware update once or twice or so again, with nothing else connected to the dock. If that fails, try Dell service. Mine updated the second time but said failed at the end, then third time reported to be updated, and now seems to work just the way it did before.

    I've had horrible issues with the WD15 initially, all sorts of devices disconnecting and not working properly, including plain wired USB mouse and keyboard. After tens of driver and BIOS updates, things eventually stabilized (although the screen developed a flicker meanwhile). Now it seems to work stably, as long as the laptop is in airplane mode, otherwise I still get temporary freezes. Many people blame it on some sort of the Dell Wireless 1830 adapter with USB - some say wifi power should be reduced to 75% in driver settings, but that replacement with the Intel 8260 is a better solution. Please report back if the airplane mode helps with stability (wired Ethernet now stable here, if you're on wifi regularly and worried about withdrawal symptoms during a possibly prolonged airplane mode testing period).  

    30 Hz is max for a 4K display on the WD15, there's not enough bandwidth for more via the USB protocol. Recently a revised version of the Thunderbolt 3 dock, the TB16, has been released, and perhaps even works finally with a fan built in, supporting even two external 4K displays @60Hz. 3rd-party TB3 docks have started appearing too, but make sure you buy only after reading others' success reports with the 9550. TB3 sounds advanced and is supposed to be cross-compatible, but in the real life it appears to be almost functional, with most vendors having major issues making docks work.