Dell XPS 15 9530 and Windows 10 Anniversary Update problems. - General Hardware - Laptop - Dell Community

Dell XPS 15 9530 and Windows 10 Anniversary Update problems.

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Dell XPS 15 9530 and Windows 10 Anniversary Update problems.

This question is not answered

Hi all,

   Just installed the Windows 10 anniversary update yesterday.
Most things seem to work, however I got the following issues:

- USB 2.0 ports don't seem to work anymore (3.0 do however);
- Audio card is not detected anymore (no sound)

I was wondering if others experienced the same issues and if any of you have found a solution for this. If I may believe the Dell website we might not expect an update for this? This € 2000+ laptop is not even 1,5 year old!

Thank you for your time!

Best regards

All Replies
  • I have the Dell XPS 15 9550 model, 6 months old, and I installed the anniversary update and now my computer blue screens a few times a day.

    I'm assuming there's a bad driver.

  • anniversary update has been terrible with a whole host of issues not just with Dell machines - especially driver issues. Mostly the fix has been just to uninstall the driver and reinstall it. I think it was mostly known with printer drivers.

    it also turns off system restore without notice which is terrible if you rely on it.

    surprisingly I had zero driver issues on my top spec XPS 15 9550.

  • No problem so far with mine (9530).

  • For me works perfectly! I installed fresh copy of new version Win10 anniversary update 1607 (you can download the "media creation tool" from windows's website and copy or burn the new offical version of this OS). I suggest the same, good luck!

  • I don't have blue screens, but since upgrading directly to Anniversary Update from a factory image restore and before installing any programs (in an effort to see whether this problem repeated itself, which it does), the "Devices and Printers" window in the control panel takes at least two minutes to populate, sometimes even requiring two tries (with the green progress bar inching towards the right).  This didn't happen with my laptop with Win10 version 1511, and appeared when I upgraded my machine to the Anniversary Update (and the problem reappeared when I went back to the factory image and then jumped directly to Anniversary Update using the Windows Media Creation Tool).  It happened when I had several printers installed when I upgraded my Version 1511 system, and it happens now that I've done the upgrade from factory state with nothing but the MS XPS viewer, MS OneNote, and MS Fax default devices installed.  I've read all the forums about switching all bluetooth devices on, and uninstalling the RealTek audio driver and installing the default MS HD Audio Device driver instead, and nothing works.  BTW, the Windows 8-style "control panel" from the settings menu pops up right away, even though the Win7-style "Devices and Printers" window takes forever.  Any ideas?

    Please don't lecture me on starting new threads and forum etiquette.  I'm new to this!

  • Try to perform clean installation of windows 10.. this might help you to troubleshoot the issue.

  • I've the same problem with only USB 2.0 but the problem is DELL...especially XPS 9530. Orrible DELL, ORRIBLE

  • I bought two XPS 15 9550s - one touch screen, one not - and they both have defective Support Assiist programs, flakey BIOS (especially interfacing with the dell Docking station), non-installing "updates" that loop endlessly to "install" again and again ... and worst of all, a defective touchscreen that requires a downgrade to stop severe flicker. This downgrade also impacts Dell Support Assist on one machine evern further. I regret buying these machines; should have bought HP. I've worked with Dell Hyderabad tech support for months, am an electronic systems and software engineer, myself, and finally gave up in frustration when they simply closed and archived my tickets. So much for delighting the customer.

  • Same experiences here... touchscreen still works. But USB is ***... when I connect my iPhone it keeps connecting/reconnecting, no problem with other PCs. I can't even start my laptop when there are USB items or the power cord plugged in (remove them all, start, and put them back in).

    And all that could be coincidence, but I also have a ongoing problem with my motherboard. I was called by Dell (!) to replace my motherboard because the original version had a flaw which prevented Windows from coming back out of sleep mode.

    So I agreed and a service guy shows up. 3 times because every time the replacement was ***** up. New motherboard was not functioning, or already registered with other user etc. After the 3rd time I've seen nobody anymore and here I was with a laptop that was opened 3 times for nothing.

    Now my XPS 15 does no boot without unpluggin the USB anymore and one fan is starting to make noise, just because it is not put back in correctly.

    Dell: Run diagnostics! (default answer)

    Me: Why? That's not even close to an answer of my questions. It's a hardware problem that originates from your own service guy!

    Dell: You no longer have warrenty!

    Me: The orginal replacement was initiated BY Dell WITHIN warrenty, but you *** up 3 times! And now my laptop is even more broken then it was before you did anything.

    Dell: You are to late, see our terms.

    Me: I've looked into it, but can't find anything that would prevent me from getting my specific problem solved. Where can I find this in the terms? Otherwise I'll have to get a legal advisor to take a look into this.

    Dell: No response uptill now.

    So I guess I know what I should do...

    When working, the XPS 15 is a great machine... when you have problems > You're stucked with Dell Customer "Support".

    I WILL take legal steps however, this ain't over yet.

    Next one will be a Microsoft Surface Book for sure (not that I'm a big believer of the fact that the support would be much better over there).

  • Ps. I'm a developer with 17+ years experience in the business. It's not because I don't know what I'm talking about.