Plugged in, Charging but not Charging - General Hardware - Laptop - Dell Community

Plugged in, Charging but not Charging

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Plugged in, Charging but not Charging

This question is not answered

My dell Inspiron 3420 bios version A09 suddenly stopped charging battery , and the power icon show this message(Plugged in and charging) but my battery does not charge.

I tested another charger and another battery but did not help.

Thinking that changing bios might  help,I am trying to change the bios but can't downgrade even i tried /forceit command. 

I can access logic board if for troubleshooting someone could educate me about  voltages of sda, scl and dc jack connector to the board.

Kindly help me.

All Replies
  • This is a hardware issue - not a BIOS problem.  If you've already tried another Dell OEM power adapter to no effect, the next thing to replace is the DC power jack:

    www.ebay.com/.../371633721900

    If that does not solve the problem, the mainboard needs to be replaced.

  • Kindly tell me about voltages at the pins of dc power jack where it connects to the main board.It would be much better to check the voltages at the dc power jack terminal, before buying it.

    If voltage doesn't match the specified one, I will buy a new one.

  • The voltage isn't the issue.  Unless the adapter isn't powering the system, the voltage and current supply is fine.

    There's a logic circuit that runs through the center pin on the jack which completes a circuit that senses the AC adapter.  If that circuit is open or faulty, the adapter isn't sensed and the battery won't charge. 

    If you've already tired a new Dell adapter, the next most likely cause is a bad DC jack.  If it's not that, it's the chip itself that's bad - which isn't replaceable short of replacing the mainboard.

  • OK, Thanks ,would be much better if changing dc jack solve my problem.