Dell E5570 Booting issues, Windows Crashes, Bios Firmware - General Hardware - Laptop - Dell Community

Dell E5570 Booting issues, Windows Crashes, Bios Firmware

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Dell E5570 Booting issues, Windows Crashes, Bios Firmware

  • 20160201_140016_resized_1.jpg

    I ran into an issue recently with 3 Dell E5570 with I7 6600U CPU and dedicated graphics card. The entire system stops responding randomly and gets worse after some time. The fix I found was to update the Bios firmware from dells drivers website. Released Jan 29th. When attempting to upgrade the bios, 1 of the processes will fail. A second update to the bios firmware will complete one of the steps needed to update all areas of the bios. So update the bios twice, back to back. After this attempt to boot into windows. It will likely still not work. What I found was to shut down, unplug the power cord, then wait 30 seconds, then plug back in. This should restore the OS to working condition. This happened to me on 2 brand new machines.


    I attached some pictures that will show the weird issues that were occurring. If you have similar issues, then its likely the bios. You will need another machine to download the bios exe file onto a flash drive. Insert flash drive, then when you boot up the computer and see the dell logo, push delete a few times until you see the text on the upper right, then push f12 several times until you get in. Then go to bios firmware update. Select browse, then click on the bios exe file you downloaded. Takes a few minutes to install the firmware that will fail to complete the first time. DO NOT SHUT OFF THE COMPUTER DURING BIOS UPDATE PROCESS!!!!


    Btw, these machines were only a few hours old when this started. Track pad would not respond properly, random windows freezing, SSD would not load OS, random firmware update failure with no attempt to update the firmware, screen turning purple, flickering screen etc.

    Good luck.

  • this just happened to me after doing the a07 bios update.  it failed on the firmware and then crashed on reboot.  it is now trying to do a repair and that is not working either

  • Try to finish the Bios Update. After its finished, reboot. Enter bios, check and confirm the hard drive is set as primary boot device. Then shut it down, Remove the charger and battery if possible, Wait a minute and then plug everything back in and attempt a boot. It should work.

  • I'm also having the same issues with Dell E5570.  I've upgraded the BIOS to Version 1.7.3.  We've re-imaged twice, with 2 different images and we're getting BSOD a lot.  We are using Windows 7 Enterprise 64 bit.  Has anyone gotten this problem resolved, i'm a bit nervous because we've made an order for more and these laptops will be assigned to top level personnel.