Dell M4800 Touchpad keeps turning itself back on

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Dell M4800 Touchpad keeps turning itself back on

This question is not answered

Having a strange issue with the Touchpad on my Dell Precision M4800. When I disable it using the Dell software or using the Fn+F5 hotkey, it has a tendency to come back on after a random interval of time. I want it to stay turned off permanently, as I prefer to use the Pointstick exclusively.

When using the Fn hotkey, I get a notification onscreen as well as a popup in the system tray saying "Touchpad notification: Your touchpad has been disabled." If I manually disable it through the Dell Pointing Devices software, I get the same effect, but without the notification. In either case, this works great... for awhile.

But then the Touchpad inevitably turns back on. I often don't notice until suddenly my mouse cursor is behaving erratically, at which point I try to swipe my finger on the touchpad and sure enough, it's become enabled again.

However after some further experimenting it turns out the "random" aspect of this is not totally random and I can reproduce the issue quite reliably by furiously scanning my finger back and forth across the Touchpad for a few seconds. Inevitably, the touchpad will turn back on, and I will get the notification "Your touchpad has been enabled." No buttons or hotkeys are pressed, all I have to do is move my finger on the touchpad surface rapidly and within seconds of starting to do that, it will re-enable itself. Again, there is also a notification that it has been re-enabled when this happens, so the software is detecting my finger movements somehow, perhaps I am accidentally performing some "magic gesture" that compels it to re-enable the touchpad.

If I don't intentionally try to cause this, it still turns on eventually, but can take a long time, half an hour or more before it becomes enabled again. I assume it's the activity of my palms resting on it that will accidentally turn it on again in the same way as swiping my finger intentionally across the disabled touchpad. It makes no difference whether the Dell Pointing Device software is open or closed and this will happen when any application is open.

All I want is for the touchpad to be truly disabled permanently and not accidentally turn on in the middle of my work. But at the same time I'd prefer to leave the pointing stick enabled, so I can't simply remove the driver. So far I've been using an external mouse and disabling all internal pointing devices, which works ok, but like I said I am fond of the pointing stick, I'd prefer to be able to leave it on with JUST the touchpad disabled.

System specs: Dell Precision M4800 with qHD screen

CPU: Core i7 4800MQ @ 2.70Ghz

Graphics: nVidia Quadro K2100M

OS: Factory-installed Windows 7 Pro 64-bit

Dell Pointing Devices software version v.8.1200.101.134

All Replies
  • I had the same problem.   I believe this is a "feature" in that it allows a person who, let's say forgot their travel mouse, to turn the touchpad on again.   The problem is that its too sensitive.   Here's the solution.

    (I found the part of the solution here:  http://geekswithblogs.net/dbutscher/archive/2009/09/14/dell-touchpad--enablingdisabling.aspx)

    1. Locate the Program Files\DellTpad directory
    2. Double click on DellTPad.exe
    3. Click TOUCH PAD SETTINGS
    4. On the bottom, adjust "Touch Check" so that it desensitizes the touchpad to you accidental touches
    5. With this setting all the way Minimum, the touch pad never accidently turns back on, but I can still turn it on by swiping furiously

    Hope this helps!

  • Thanks, this answer has helped a lot. I haven't had enough time to confirm that doing this has completely resolved the accidental re-enable issue, but it seems so far like it's working. Very odd feature, and very odd solution... I'm just glad I'm not the only one experiencing it!

    To anyone from Dell, please consider adding an actual setting for this. Mouse or no mouse, I will never have any interest in re-enabling the touchpad by swiping on it when I have a perfectly functional pointing stick just inches away. And thanks to this "feature" I've become intimately familiar with using Fn+F5 to switch pointing devices on and off on a regular basis now so I think I could figure it out even with both of them disabled.

  • I've had this same problem for some time. I have applied the same solution and will see if it works.

    To any Dell people reading this: how about  fixing this "helpful" feature. Ignoring a user setting is bordering on the moronic and makes the product seem broken.

  • The above solution ultimately did not work for me. I am continuing to hope this gets fixed or made optional in future updates. I agree it makes it seem broken -- I was worried I had received a defective laptop at first.

    Thanks for your comment though I'm glad to hear at least I'm not the only one continuing to have this problem.

  • The fix doesn't work for me either. It also seems to have gotten worse with the latest BIOS upgrade.

  • This is driving crazy!! I am a writer and web designer and I cannot have this pad turning on all the time. It ruins my work. I do not use it and the point stick. Nothing seems to keep it turned off.

    How can they make this so hard to turn off. I have done the bios, and all the suggestions and it is not working!

  • Well it is at least good to know we're not alone! I too am still having this problem. I have just gotten used to hitting Fn+F5 every five minutes or so, but it is silly and it shouldn't have to be that way. It certainly is a disappointing distraction in an otherwise wonderful laptop.


    Hopefully we can get this fixed in a driver or BIOS update someday.

  • Dell does not know why it does this, and I had a two very helpful CS tech reps try to fix this and they could not. It is something Dell needs to fix. In the meantime I am so happy that I found something I can use until Dell adds the ability to permanently turn off the touchpad and stick It is called touchpad blocker.

     I have not had any words and sentences jump since I installed it.
    When you are typing it stops the touchpad, and it seems like it blocking the stick to from being activated. Only while you are using the the keyboard.
    At least I am able to work right now and not wasting time having to keep using "undo" when my words jump and sentences get ruined.
    This should have a permanent solution though. It is crazy that we cannot turn this off.
    Dell please fix this.

  • I learned of a ridiculously SIMPLE fix for this very annoying problem! Go to "Show hidden icons" at the bottom right corner of the tray on your desktop and click on the icon for "Touchpad properties." At the top of the "Dell Pointing Devices" window that opens, you will see a picture of a touchpad and a mouse. Counter-intuitively, the fix for this touchpad problem is found by clicking on the MOUSE picture! Then at the bottom of the window, make sure that the box is checked to the left of "Disable Touchpad when USB Mouse is present." Then click "Save" at the top of the same window. Problem solved :) To use the touchpad, simply remove the mouse from the USB port. To disable the touchpad, re-insert the mouse!
  • Good advice when using an external USB mouse, but unfortunately doesn't help if you just want to use the pointing stick only and NOT the touchpad.

  • I have the same issue with my touchpad. It activates all by itself even though I have it turned off. Interestingly enough - the hot button function to turn it on or off DOES NOT work at all. I put a shortcut for the touchpad controls on my desktop so I can deactivate it faster as this problem happens very frequently and drives me nuts because it messes up whatever I'm working on by relocating the pointer. I prefer to use the external mouse. Also - when I open the touchpad software - the settings actually show my touchpad is set to "off". I have to enable it, hit save, then disable it, and hit save again. There is obviously a problem with the touchpad - anyone have a solution to my issue?