Laptop computer Forums (Audio, General Hardware, Video)

Mouse Trackpad not working properly after upgrade to Windows 8.1 on XPS12

This question is not answered

Since I upgraded from Windows 8 to Windows 8.1 I have been needing to re-tune many settings (e.g. chrome text being blurry).

One thing that seems completely gone is my ability to right-click from my trackpad. I have so far been using an extended touch on the screen to right click, but this is an annoying and incomplete work around.

I thought maybe I needed to change some mouse settings, but when I went to the mouse settings from the control panel the Cypress TrackPad tab is gone!

I then realized that all the other functionality such as gestures and multi-touch were gone!

Anyone else have this happen to them or have a solution? 

All Replies
  • Hi SeraphyaB,

    I would suggest you to install the touchpad driver. Please share the exact system model you are using. The ‘Cypress Touchpad’ is shipped with XPS 13 and not XPS 12. Also there are two variants for both XPS 12 (9Q23 & 9Q33) and XPS 13 (L321x & L322x).

    To download the drivers, you may refer to the link:

    On the link, enter the system Service Tag and click on ‘Continue’. Select your operating system and it will display a list of available downloads. Click ‘Mouse, Keyboard and Input Devices’ and click ‘Cypress Touchpad’. Download and follow the on screen instructions.

    Hope this helps. Feel free to reply for any further assistance.

    Thanks & Regards
    Amogh G
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here

  • I have the exact same problem. I updated the touchpad driver to latest version but I still does not have right-click working.

  • I am having the EXACT same problems and I literally JUST bought this laptop 3 months ago so don't tell me I need to update my drivers as I've been using this laptop 20 hours a day for undergrad and work and as soon as I update to Windows 8.1, my computer is suddenly handicapped and I am getting pissed. Right-click doesn't work, mouse gestures don't work, wi-fi is disconnecting and connecting, chrome text is blurry, windows interface is magnified way too much but everything else is smaller. Playing around with screen resolution doesn't do anything, just make the text larger or smaller. The text is still blurry. Like I said, pissed. I need this EVERY SINGLE DAY or I am going to fail my senior year in college. SOMEBODY HELPPPPPPPP. Is there anyway I can go back to Windows 8.0 and continue my stable life with my old stable Windows that is reliable????

  • I had the same problem with the touchpad not working properly after upgrading to w8.1.

    I reinstalled the Cypress Driver and all seems ok now.

  • Hi Opersian,

    I had the same problem with chrome, however it is readily sorted by following the following steps:
    1. Go to Control Panel\All Control Panel Items\Display
    2. Check the option "Let me choose one scaling level for all displays"
    3. Select the option Smaller and may need to logout if the system asks
    4. Repeat the steps 1 to 3 but now select 125%
    5. Rock On!! Windows 8.1 is awesome
    As for the touch pad I am having the same problem. I have reinstalled the Cypress trackpad drivers but it isn't helping... Would be glad for help



  • Oh yeah...reinstalling the Cypress touchpad driver does the trick....the changes take effect after a restart

  • Still trying to fix this mousepad issue (i.e. gestures & right-click). Installed the Synaptics TouchPad Driver for the XPS 12 that I have and restarted with no effect...

    Meanwhile, my Windows 8.1 interface has been magnified really large since I upgraded and finally found a solution. Look at the post by Kingblingdong on this forum as it worked for me:

    Currently installing the Cypress TouchPad driver for XPS 13 (even though I have XPS 12) to see if it'll work *fingers crossed*.

  • Well my dell xps12 came with cypress touchpad drivers and that is what I re-installed. It worked perfectly for me so it should probably work for you too.

  • I got the same problem, no right clicking after Upgrade to Windows8.1. Reinstalling the driver didn't work for me. When I reinstall the driver I am able to use the gestures again, but right click doesn't work. 

  • Open this, and download the first driver (size 38 MB):


    I installed that I my touchpad works as it used to work before update.

    I recommend updating to Windows 8.1 from Store to everyone, because everything works great for me.

    Just one thing, when I swipe from the right edge and Charms bar appears, it is too thick, and icons are bigger than in Windows 8. Is it any way to make it thinner?

  • It works for me now, after installing above driver and right configuration. My problem was, that in the cypress trackpad config application the right button was assigned to click instead of contextmenue...

  • I downloaded the driver for my trackpad based on my service tag, but then I noticed that I had a driver that was very similar in a  file under drivers under my computer. They are similar but not exactly the same

    The one I just downloaded has C:\DELL\Drivers\0VV1J\Cypress\x64\apps has the same things as C:\Drivers\input\377DM\Cypress\x64\apps

    but it also has a file named



    The newly downloaded driver also has an x86 folder, which I assume I am supposed to ignore. I ran the setup.exe , should I leave the old drivers on my system, or should I delete them, or does it not really matter as the setup told windows to point to the new files as drivers?

  • I have an Inspiron 15 3521, what do I do to get the touchpad right click working for my laptop?

  • Hi all,

    The drivers for Windows 8.1 are now available on dell support website for most of the systems. Please refer to the link: On the link, enter the system Service Tag and click on ‘Continue’. Select the operating system as Windows 8.1 and it will display a list of available downloads. From the list download and install the latest ‘Wireless’ drivers.

    Hope this helps. Please feel free to reply for any further questions.

    Thanks & Regards
    Amogh G
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here

  • I had exactly the same problem on my XPS12 Ultrabook after upgrading to 8.1. Any help would be appreciated.