Dell Inspiron 1545. how to enable processor Virtualization in bios setup. - General Hardware - Laptop - Dell Community

Dell Inspiron 1545. how to enable processor Virtualization in bios setup.


Laptop computer Forums (Audio, General Hardware, Video)

Dell Inspiron 1545. how to enable processor Virtualization in bios setup.

This question is not answered

Hi Team,

I have Dell Inspiron 1545, Processor: Intel(R) Core(TM)2 Duo CPU T6500 @2.10Ghz 2.10Ghz.

How do i enable processor Virtualization in bios setup. i don't see any option for that. please let me know how do i that.

I have installed windows7 64bit. which is working fine. I have installed vmware player 64bit. trying to bring up the red hat Linux 64bit on vm. but unable to start it. it says host doesn't support.

Please let me know.

All Replies
  • Hi Sathya755,

    I am afraid this option is not available for this system.

    Thanks and regards,
    Senthil S
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US / India . For Dell support videos click here.

  • Could you tell me how do i get this option? is there any patch for bios?



  • The BIOS isn't the problem - your CPU doesn't support VT.

    You can replace the CPU with one that does support VT-x if that's the VT support you need. One that will work is the T7250

  • Googling for ideas I found out that you should check your BIOS settings to see if it is actually enabled but upon opening the BIOS I could not find anything even remotely close to virtualization settings (on Dell laptops, you should find it under the Performance tab). After another quick search round it appears that it is not uncommon for Laptop and System manufacturers to actually hide this functionality and disable it by default.

    During my quest for answers i came across a person asking for a way to deploy BIOS settings changes on hundreds of PC’s at the same time and apparently Dell has a handy CLI-utility just for this purpose called CCTK. Figuring it couldn’t hurt trying I downloaded and installed it and lo and behold, I could switch the virtualization setting on and off! After shutting down my PC and turning it back on after 10 seconds (recommended way in the many, many related topics) I could finally enjoy full hardware virtualization.

    The short and the long of it

    • Download CCTK from here. At the time of writing, there was actually a newer version available through the Older versions link
    • Install it
    • cmd prompt
    • cd "Program FilesDellCCTKX86" (or X86_64 if it applies to you)
    • C:Program Files>Dell>CCTKX86>cctk --virtualization

      C:Program FilesDellCCTKX86>cctk --virtualization=enable

  • My CPU is i686 so what should i do. Mine is a dual core processor will that work for it?

  • Some will, some won't -- we need the exact model CPU (T7200, etc.) to determine.

    If you don't see the enable option for VT in your BIOS setup, chances are your CPU does not support VT.

  • i enabled through cmd prompt as you mentioned above. Still now i am not able to open 64bit Operating Systems. Please give suitable suggestion for this situation.

  • What model CPU do you have (NOT i686, etc. - we need the exact model such as T7200, T5650, etc.)?

    If you do not know, enter BIOS setup (F2 at powerup) and check there - the CPU model will show up.

  • Hi,

    My Model is T4200/Inspiron 1545 with windows vista running on it. I dont see virtualization seeting in bios. I installed cctk and ran the command cctk --virtualization=enable but it is not setting it.

    Does my laptop does not support virtualization?



  • Try this

  • I faced this issue and tried a lot of solutions but finally I had to get my CPU replaced with T7100 1.8 Gz while T6500 is 2.1 Ghz.  I would suggest anyone to look for other 2.1 Ghz processor. T7100 supports VT-x functionality so my system is working now.