Unable to boot from USB in Inspiron 1545


Laptop computer Forums (Audio, General Hardware, Video)

Unable to boot from USB in Inspiron 1545

This question is not answered

I need to reinstall rhel5  on my Dell Inspiron 1545. 

the weird thing is that the laptop won't boot from anything but the HD.

i tried using boot selector menu (F12) and selecting usb - nothing happanes.

it is start showing older version boot menu  and not able to reboot from usb. 

also tried changing boot sequence in BIOS - no affect.

i thought my usb  maybe is bad - but i checked in other laptop and it boots great,

you have any ideas how to make it boot?


All Replies
  • Ensure USB legacy Support is enabled in BIOS (Boot to F12)


  • yes i boot to F12 but agin same old screen is coming

  • sorry boot to F2 (BIOS)....it's late


  • Hi amar4367,

    Please update the BIOS to latest Version A14. Here are the steps:

    • Click on the link http://dell.to/14vNPwF
    • Download and save the BIOS on the desktop.
    • Right click on it and select 'Run as administrator'.
    • Follow the prompts on screen and restart your computer.

    Boot to BIOS by pressing the F2 key on the startup. Select USB Storage Device as first boot device. Save and exit the BIOS setup. Plug in the USB drive and power on the system, check if you are able to boot from it.

    If the BIOS is already running at Version A14, load BIOS to defaults and then try booting from USB drive following the above mentioned steps. Also, you may try plugging the USB drive to another port to check if the USB ports are working or not.

    Hope this helps. Please reply if you have any questions.

    Thanks & Regards
    Saharsh K
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USA; India. For helpful Dell Support Videos, you may click Here.
  • Hi Paul,

    thank you.

    I tried but not working.. :(

  • Is the USB device you're trying to boot from formatted to FAT32

    Are you able to boot to Windows still from the HDD?

    If so, goto Device Manager and check that your USB controllers / ports are installed correctly.

    Alternatively, Boot to F12 and choose Diagnostics..post back with results


  • Hi Saharsh,

    thanks for the suggestion.

    I am not able to log into my o.s  so i can update the bios now.

    i have tried to change the boot setting with f2 and f12 but its not working.

    please find the attched image for your help.

    image 1>f12--booting with usb

    image 2>default sceen is coming in place of linux installation

    image 3>selecting current os then showing error

    image 3

    image 1

    Please suggest to proceed further.

    Thanks & Regards,

    Amardeep Kumar

  • Hi Paul,

    Thanks for your quick reply!

    yes USB device was formatted to FAT32

    oracle linux was instaLLED on my system and that is also not able to boot.Please find the attached screenshot for your reference(in prev reply).

    Thank &  Regards,

    Amardeep Kumar

  • What is installed on your current laptop hard drive and whether it is able to boot is completely irrelevant to whether you are able to boot from the USB device.

    You apparently do not have a bootable USB device.

    Read h10025.www1.hp.com/.../document to learn how to create one for REHL

    my Dells:
    Precision M6300 - Windows 7 / Ubuntu 12.04
    Latitude D620 - XP Pro SP3
    Precision M6300 - Windows 7 Pro 64-bit / Windows 8.1 Pro 64-bit

  • Hi Amardeep,

    Boot to BIOS (F2). Check for these settings...

    Switch off USB keyboard support

    Turn off Fast Boot

    Disable USB 2.0 support (last resort, this will default to USB 1.1)

    The USB Storage Device is showing as second in the Boot list. It should be the first one. Use the arrow keys to move it up. Save settings and exit BIOS.

    Other tips...

    Unplug USB hubs and extensions

    Try using a different USB port.

    Unplug additional USB devices.

    Sometimes a USB drive may go undetected at startup. If your USB drive has an LED, ensure that it either flashes or remains solid during system post. If the drive does not respond, remove the drive, then power the system completely down for 15 seconds, reinsert the drive and try again.