Latitude E5430 USB 3 ports don't work

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Latitude E5430 USB 3 ports don't work

This question is answered

Hi Dell Community,

I have a new Latitude E5430 with Win7 Prof 64bit. It has 2 USB 3.0 ports. The USB 2 ports are working well but the USB 3 aren't. If I plug any usb device into USB 3 port (I have USB 2 and 1 devices only: keyboard, USB-Serial converter, Flash Drive, Phone etc...) Windows doesn't detect it and there isn't any power provided to the device. Only the mouse is working well.

I have already installed the latest chipset driver and USB 3 driver, the device manager shows:

Intel USB 3.0 eXtensible Host Controller (ver 1.0.8.251)

Intel USB 3.0 Root Hub

Please help!

Verified Answer
  • Hi Krisztián,

    It seems that this is a hardware issue. the ports are not working and system board might be needed to replace. If the system is covered under warranty, you may provide me the Service Tag and the name as it appears on the account via private message (click my username and then click Start Conversation) so I may access your records and check for further course of action.

    If you are residing in US, you may contact Dell Out of Warranty Repairs (OWR) department at 1- 800-288-4410 to check the time and cost involved for repairs. If you are comfortable in replacing the system board on your own, you may contact Dell spares at 1-800-372-3355. For Owner’s Manual, please refer to the link: http://bit.ly/14jE3MP.

    Keep me posted with the information. I will be glad to assist you.

    Thanks & Regards
    Amogh G
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here

All Replies
  • Hi hkrisz,

    it seems that you have installed the drivers directly from Intel website. i would suggest you to install Dell OEM drivers and then try you may refer to the link: http://dell.to/11vtyUK.

    Keep me posted with the results. I will be glad to assist further.                

    Thanks & Regards
    Amogh G
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here

  • Hi Amogh,

    I have uninstalled the Intel USB 3.0 eXtensible Host Controller driver and then both installer say the same:"This computer doesn't meet the minimum requirements for installing the software"

    The end of the log:

    "!   Didn't find any INF's that match active hardware

    IIF will NOT initiate reboot

    Exit code = 0xA005

    ResultCode = 40965

    <<< 6/18/2013 15:50:02:472

    [06/18/13 15:50:02]

    --- End of Vendor Software Log ---

    [06/18/13 15:50:02] Vendor Software Return Code: 5

    [06/18/13 15:50:02] logo.png

    [06/18/13 15:50:02] Name of Exit Code: DEP_HARD_ERROR

    [06/18/13 15:50:02] Exit Code set to: 4 (0x4)

    [06/18/13 15:50:02] Result: FAILURE

    [06/18/13 15:50:06] Open file: C:\ProgramData\Dell\UpdatePackage\Log\Chipset_Driver_P20D9_WN_1.0.7.248_A04.txt

    "

    Thanks,

    Krisztián

  • update:

    after reboot I could install both driver exe. But the behavior is same the windows doesn't detect the connected devices.

    The USB 3 eXtensible Host and Root Hub driver version is 1.0.7.248 now.

  • update #2:

    If I entered into the bios menu the keyboard + mouse doesn't work if they are plugged into the usb 3 port.

    If I use an old KVM switch (Aten), the mouse is working but the keyboard isn't in bios menu.

  • Hi Krisztián,

    You may try to uninstall all USB root hubs from ‘Device Manager’. Then restart the system. You may update the system BIOS. Please refer to the link: http://dell.to/19Roh1z.

    Note: Before updating BIOS please ensure that:
    *Battery is 10%> or >10% charged
    *Battery charger should be connected
    *No external devices (flash drives, printers, external hard drives) should be connected.
    *All other programs should be closed and documents saved

    Keep me posted with the results. I will be glad to assist you.

    Thanks & Regards
    Amogh G
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here

  • Hi Amogh,

    Unfortunately my bios is non-vPro and this is why the update says: "Error: Unsupported System ID Found. Cannot update a Latitude E5430 non-vPro with a BIOS for latitude E5430 vPro"

    My BIOS version is A09.

    If I filters with my service tag in the download area there is no BIOS update available.

    King regards,

    Krisztián

  • Hi Krisztián,

    Thank you for the information. For non-vPRO BIOS A10, you may refer to the link: http://dell.to/12Onxrd.

    Hope this helps. Keep me posted with the results. I will be glad to assist you.

    Thanks & Regards
    Amogh G
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here

  • Hi Amogh,

    Unfortunately it didn't help (I have installed the OEM drivers too).

    Thanks,

    Krisztián

  • Hi Krisztián,

    You may try to connect any USB 3.0 device with the system, if possible. Please let me know if it is getting detected.

    Keep me posted with the information. I will be glad to assist further.

    Thanks & Regards
    Amogh G
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here

  • Hi Amogh,

    sorry for late reply, but I was busy. I updated the BIOS to non-vPRO BIOS A11 and I bought an USB 3 pendrive (Kingston DataTraveler 111). Unfortunately the result is same: the USB 3 ports doesn't work. The BIOS doesn't see the connected device, it is not listed in the legacy boot menu (if I press F12 during boot). If I plug it into USB 2 port I see it on the boot menu. And Windows also doesn't detect the plugged stick if I use USB 3 port.

  • Hi Krisztián,

    Thank you for the response. You may uninstall the ‘USB Root Hubs’ from ‘Device manager’. Please follow the steps below:

    • Press ‘Windows’ key + R on ‘Desktop’ screen
    • Type ‘devmgmt.msc’ in run box and press ‘Enter’
    • Expand ‘Universal Serial Bus controllers’
    • From the list, look for ‘USB Root Hub’
    • Right click and click ‘Uninstall’, click ‘Ok’
    • Uninstall all ‘USB Root Hub’ listed
    • Wait for all the drivers to get uninstalled
    • Restart the computer
    • Restarting the computer will install ‘USB Root Hub’s automatically on the computer

    Keep me posted with the results. I will be glad to assist further. 

    Thanks & Regards
    Amogh G
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here

  • Hi Amogh,

    unfortunately the result is same, the USB 3 doesn't works.

  • Hi Krisztián,

    It seems that this is a hardware issue. the ports are not working and system board might be needed to replace. If the system is covered under warranty, you may provide me the Service Tag and the name as it appears on the account via private message (click my username and then click Start Conversation) so I may access your records and check for further course of action.

    If you are residing in US, you may contact Dell Out of Warranty Repairs (OWR) department at 1- 800-288-4410 to check the time and cost involved for repairs. If you are comfortable in replacing the system board on your own, you may contact Dell spares at 1-800-372-3355. For Owner’s Manual, please refer to the link: http://bit.ly/14jE3MP.

    Keep me posted with the information. I will be glad to assist you.

    Thanks & Regards
    Amogh G
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here

  • Hi Amogh,

    the mainboard replace solved the problem.

    Thank you!

  • Hi Krisztián,

    Thank you for the response. I am glad that the issue has been resolved.

    Please feel free to reply for any other questions. I will be glad to assist further. 

    Thanks & Regards
    Amogh G
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USAIndia. For helpful Dell Support Videos, you may click Here