Latitude E5430 looses WiFi connection

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Latitude E5430 looses WiFi connection

This question is not answered

Hi,

I have just received a new Latitude E5430 with Windows 7 64bit.

It  worked fine for a day, and I was just getting to the phase were I'd be installing  all the different the software , when after doing a windows update the wifi connection was lost.

Whatever I did, it would not work again, it was trying to use the 169.254.xxxx.xxxx IP address instead of 192.168.xxx.xxx..

Deleted all network settings, rebooted the router/modem and finally I got back to a proper IP address but the system is still not connecting.. claiming the signal is poor, even from 2 feet away from the Router.

Deleted MacAfee but to no avail.

Is this just a faulty network card? Any other suggestions?

Thanks a lot

Jeroen

All Replies
  • Hi Jeropotje,

    Please download the latest Wi-Fi driver from the below link and check if it resolves the issue.

    http://dell.to/QjjZDA

    (Key in the service tag and the right operating system for the selection of drivers)

    You can also run an online diagnostics for the Wi-Fi card. Connect through a wired connection and please follow the steps below to run the diagnostics.

    1.       Open the link http://dell.to/11MXNII
    2.       Select ‘Hardware’.
    3.       Select ‘Network card’ under ‘Diagnostic Selector’.
    4.       Click on ‘Run Diagnostics’ button.
    5.       Let me know the results.

    Thanks and Regards
    Harish M
    #iworkfordell

    To learn more about Dell Products, Services, and Drivers, click Here