start>shutdown>restart, is taking forever, very slow. Why? Dell 520 Latitude laptop 2007 model

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

start>shutdown>restart, is taking forever, very slow. Why? Dell 520 Latitude laptop 2007 model

This question is answered

My problem is

I click START >Shutdown and have to wait and wait forever (3-5minutes) for the final prompt to either restart/shutdown/log off.Its is real annoying.

I am using a 2007(bios) Latitude Dell 520 laptop (purchased second hand).  I've had this problem from day one (the laptop was actually on when the seller handed the laptop to me).

Wondering why its so slow between shutdown and the next step (final prompt to either restart/shutdown/log off). What is the problem and how to solve it?

Verified Answer
  • Can't hurt to run chkdsk command from Command Prompt; when it's finished if it suggests to run a fix on it run this command:

    chkdsk /r (choose Y and Enter, close prompt and restart.)

    I would also disable your wireless card in the Device Manager\Network Adapters (right-click on it and select Disable). re-start twice.

    Use the Run command msconfig to prevent your AV program from running at startup and restart twice (I trust you have only one anti-virus program installed).

    Not sure if this has any relevance to problem but at some point might want to re-set your services back to their defaults. More on this later; will have to find the file fix for this.

    Also, you could run this command: eventvwr

    Check today's Administrative Events and Applicatiions and Services (if you have restarted or shutdown computer at least once today) to see if there appears to be anything that might be related to the delay.

    I would also uninstall any programs you know you don't need or know you can re-install, and restart-I always use the program's uninstaller in Programs\?\Uninstall;  if you have Office on it, without cd, you could attempt to Uninstall\Repair the Office suite if that option is available

    Run a full defrag using the Windows defrag or my favoriite, download.cnet.com/.../3000-2094_4-10567503.html

    You could also re-set your BIOS to its Defaults but that effort is probably meaningless.

    PS There are more advanced programs you could run that might be helpful in detecting the delay but I haven't use them enough to walk you thru them.

All Replies
  • Hi jon_dell,

    Try to do a clean boot which can resolve the issue.

    Below steps would help you clean boot:

    Click Start, type msconfig in the Start Search box, and then press ENTER.

    If you are prompted for an administrator password or for a confirmation, type the password, or provide confirmation.

    Configure Selective Startup options:

    1. In the System Configuration Utility dialog box, click Selective Startup on the General tab.
    2. Click to clear the Load Startup Items check box.
      1. Note The Use Original Boot.ini check box is unavailable.
    3. Click the Services tab.
    4. Click to select the Hide All Microsoft Services check box.
    5. Click Disable All, and then click OK.
    6. When you are prompted, click Restart.

    Run SFC scan Now:

    1. Open an elevated command prompt. To do this, click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are  

    prompted for an administrator password or for a confirmation, type the password, or click Allow.

    2. At the command prompt, type the following command, and then press ENTER: sfc /scannow

    The sfc /scannow command scans all protected system files and replaces incorrect versions with correct Microsoft versions.

    Also, check if the issue persists in safe mode with networking. Restart the computer and tap F8 on Dell logo and select Safe mode with networking. Now try to shutdown the computer and check if it takes same time to shut down.

    Awaiting your response!

    Thanks & Regards
    Rajesh R
    #iworkfordell
    To know  more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US ; UK; India. For Dell support videos click Here.
    If a post answers your question, please click "
    Yes".

  • For SFC scan  to work you need Windows XP discs which I don't have since I purchased this dell second hand without Windows XP discs.

    However msconfig>System Configuration Utility solved the problem with slight variation at the end. That was a very quick answer by Dell team. Thank you Rajesh.

  • I spoke to soon. I am still having the same problem.

    I followed your instructions using msconfig>System Configuration Utility, but what I found was that the Intel PROset wireless beam icon at the lower far right of the desktop (near the time) was nowhere to be seen if I had Selective Startup checked. I had to select Normal setup again from System Configuration Utility, with Load Systems checked to get back my Intel PROset wireless beam icon. Start>shutdown>shutdown/restart in fact worked fine and solved the problem but about an hour later I decided to check it again (Start>shutdown>shutdown/restart) and I realised I still had the same problem.

  • Given the age of the system, a thorough hard drive diagnostic is in order:  F12 at powerup - run the extended, not just quick, test.

    If it passes, purchase a copy of Windows and do a fresh install.

  • Given it's a business machine perhaps the pagefile is being cleared at shutdown.

  • How do I stop the pagefile from being shutdown ? How do I access the pagefile ?

  • If you have run the diagnostics as suggested you can see if a registry edit will fix your problem. Realize that you can 'kill' your notebook setup if something goes wrong since you don't have a Windows cd to do a 'clean install' of the operating system. If you stick exactly to the following steps there is only a small risk of that but *there is* a risk.


    1.Go to Start|Run and enter this command: regedit

    2.When Registry Editor pops up highlight (click on) "Computer" (at top of page). 

    3. In menu click Edit and then Find.

    4. Type in this (exactly): ClearPagefileAtShutdown

    5. Check the boxes "Values" and "Match whole string only".

    6. Click the "Find Next" button and wait til it's found.

    7. Right-click on the highlighted value and select "Modify".

    8. If the "Value Data" number is 1 then change it to 0 and clik OK. (If alreay set to 0 then this is not your problem so click "Cancel" and close the editor).

    9. Close the Registry Editor.

    10. Close all programs and shut down computer to see if fix worked.

  • Hi jon_dell,

    Unfortunately we have not received feedback from you on this topic. If you need continued support, please write back. Other community members who need assistance please start your own topic in a new thread.

    Awaiting your response!

    Thanks & Regards
    Rajesh R
    #iworkfordell
    To know  more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US ; UK; India. For Dell support videos click Here.
    If a post answers your question, please click "
    Yes".

  • I don't want to risk using registry edit to fix my problem because I do not have the Windows CD with me if it so happens that registry edit 'kills'  my notebook setup if something goes wrong. Which is why I have not replied, since I am afraid to follow up on the suggestion to use registry edit.

  • Go to Start\Run and enter this command:

    gpedit.msc

    If the Group Policy Editor comes up then you can follow the directions (in link) for viewing and possibly changing the ClearPagefileAtShutdown setting without manually using the Registry Editor; it's a much safer way to accomplish the same thing.

    http://www.computercare.ca/forum/showthread.php?t=5148

  • Sorry. From the top of the page, look at Number 4 under Shutdown Works, But it's Real Slow.

  • I followed the instructions on:  http://www.computercare.ca/forum/showthread.php?t=5148

    under "Shutdown works, but it's real slow"  (point 4).

    This is what I found when I arrived there,

    Group Policy > computer configuration>windows setting>security settings>local policies>security options> shutdown: clear virtual memory pagefile disabled

     I found out that 'shutdown: clear virtual memory pagefile' was already disabled when I got there.

    If I enable 'clear virtual memory pagefile', it would go contrary to point 4's instructions, since the author was suggesting that  shutdown: clear virtual memory pagefile enable was the reason for the shutdown being so slow.

    What now?

  • It shouldn't hurt your system to do the thorough scan as suggested so I would do that first. If it passes then go to Start|Run and eneter this command:

    devmgmt.msc

    When Device Manager comes up, click View\Show Hidden Devices.

    If there are any devices with corrupt drivers you will see a yellow or red mark. Right them down and post them back.

    Also in Start|Run you could enter this defrag c: -b and see if that has any effect on speed.  You could also do security scans of av and malware but later. Hopefully someone can jump in with a more decisive answer. Tomorrow.

  • Device Manager> View\Show Hidden Devices.

    No devices appeared with yellow or red marks against them.

    As for defrag c: -b, I 'll try that a later; update forthcoming.

  • defrag c:-b works in the beginning but lets  you down later.

    defrag c: -b worked and solved the problem straight away

    Noted zero lag between start>shutdown and  final shutdown prompt (i.e. shutdown/log-ff/start by/restart etc).

    Problem solved at that point. (note I didn't actually proceed with shutting down my Dell after

    defrag c: -b).

    But a few hours later when I was finished using my Dell for the day, I realized the problem was not solved by

    'defrag c: -b'. It answered my question initially only.

    What now?