fresco logic xhci (usb3) root hub - Code 31


Laptop computer Forums (Audio, General Hardware, Video)

fresco logic xhci (usb3) root hub - Code 31

This question has suggested answer(s)


I have Dell XPS 13 ultra book.

1. My USB 3 doesn't function, I see under device manager: 

fresco logic xhci (usb3) root hub: This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

I already download the neewest drivers from Dell website, and resolve the problem but after a few days the problem come back, What can I do ?

2. When I shutdown the computer, after turning on the bios sutck sometinems on Dell logo screen (bar on half progress), I have to turn on and off.

Why does it happen ?

My BIOS is the most updated



All Replies
  • I have the same problem - all of a sudden the USB 3 port stopped working.  Device manager shows the exclamation on the Fresco Logic USB3 Root Hub.  I have updated all my drivers & BIOS.

    What gives?  DELL - Can we have an answer?  We all bought these (overly) expensive machines.

  • I have an XPS 13 Ultrabook and have exactly the same problem.

    Fresco Logic xHCI (USB3) Root Hub - code 31 - the device is not working.

    I have tried previous driver versions and have all the updates but no luck.



  • I also am now having a problem - when I put the XPS 13 into "sleep" and pack it away over night, the next morning I get the "Windows has shut down unexpectedly" message.  Anybody else seeing this?  Related to the USB3 driver issue?

  • I am also experiencing this. BIOS - L321XA08.exe, release date 2/04/2012. USB Driver - XPS-L321X_Chipset_Driver_R9WKR_WN_3.5.46.0_A02.exe, release date  22/08/2012

  • I also had this same problem -- the USB3 port suddenly stopped working on Mar 1. It was soon, but not immediately, after I updated my BIOS so it may or may not have had anything to do with that.

    I just fixed it though by downloading and installing the most recent Fresco Logic xHCI Controller driver provided by Dell, under the Chipset category. This is version, dated 8/22/2012. Somehow the version I had installed was (if I remember correctly), dated 11/2012. Although this was "newer" it also was not working. I have no idea how it got there since Dell doesn't provide that version, but installing did fix it! Hope this helps other people.

  • I tried that but still not fixed.

    This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

    Come on dell, supply a fix so we can use the USB port.


  • Well - I did a lot of futzing around & got this <ADMIN NOTE: Substitute character removed as per TOU> working again.  I'm not sure I would recommend this to everyone, but here's what i found.

    The Fresco Logic USB3 Hub was using a driver.  I uninstalled that multiple times & it kept re-installing itself.  I went into the Windows/System32/drivers folder and found 2 versions of the FLxHCI.sys driver.  Go to the properties & look at the Details Tab. My 2 versions were &   I deleted the .93 version.  Restarted the machine a couple of times & it took the .46 version & seems to be working fine.

    I had no option to roll back to, nor did un-installing the .93 version ever work.

    No promises for anybody else.  Try at your own risk.  Good luck.

  • This worked for me with a slight tweak. I also had the two drivers but on moving the .93 version out of the drivers folder and rebooting a couple of times the port was still inactive. What worked for me was to go to the device manager, select the Fresco ... Root Hub driver under the USB controller and manually update the driver from there. Going to Update Driver, and Browsing my computer to select the .46 driver caused the port to activate immediately. 

    Thanks to Murlap for pointing out how to get this sorted.

  • Thank you for this suggestion. With Internet disabled, I uninstalled the driver -- asking Windows to delete the driver file. Windows  then re-detected the USB hub, and installed the old driver for me. Without disabling Internet, Windows kept downloading the updated driver -- that does not work.

  • Thank you for the suggestion.

    I got my usb3 back up doing as you suggested - much appreciated.

    Windows Update posted a driver update that came across today, breaking the usb 3.0 port.


    Going back to the older driver fixed it.

    I keep a drivers category on my c: drive with original drivers for this sort of issue.



  • Thanks guys, this has worked for me too. Also just to let you know, Dell has been onsite (under warranty) trying to fix this issue on my Ultrabook. Dell replaced the motherboard and a few other bits and pieces, which of course did not work. The techy said I would have to reinstall the system software.

    Thank goodness you guys know what you are doing.

  • Also if the suggested answer did not work, try this  At least works for me. My laptop model is inspiron N7110 using Fresco Logic xHCL (USB3) Controller FL1009 Series.

    Good luck

  • One thing that you need to be very aware of when it comes to device drivers.  Keep tabs on what your Microsoft Update is doing, it may and will download OEM drivers which it thinks are newer and better then what your Vendor is supplying.

    Here's an option for Windows 7/Vista users ( I have to check how to do this under Windows 8 because the way Microsoft changed access to "Group Policies" there's no more gpedit.msc on some version of Windows 8 :( which stinks in my opinion.

    For Windows 7/Vista to prevent Microsoft Update from automatically installing what it thinks may be better/newer/updated drivers.

    WARNING in regards to the next steps. 



    •Go to Start–>Search and type in gpedit.msc.

    •Click the file found to open up the Local Group Policy Editor.

    •Navigate to Computer Configuration->Administrative Templates->System->Device Installation and  Click on the subfolder Device Installation on the left, on the right side you will see a list of possible restrictions.

    •Right Click on Prevent Installation of Devices not described by other policy to edit this option. Set it to ENABLED.

    •ENABLE Allow Administrators to override Device Installation Restriction policies at the top of the list as well.

    Now, Windows won't automatically install drivers via Windows Update, but you can now manually install them yourself. Once you have the chance to google around and see if the drivers break anything of course. ;)

    Windows 8 -- good question on how to set Group Policies on Windows 8 Home editions.  Professional has GPEDIT, Home editions do not.



    EDIT: Forgot Windows 7 as well had restrictions on what versions come with GPEDIT - Only Windows 7 Professional, Enterprise and ultimate editions come with Group Policy Editor installed. But Google around on how to activate it in Home Premium, Home Basic, or Starter"

  • Fresco provided an optional update through WINDOWS UPDATE.  This is what caused the problem on these devices.  Don't blame DELL (this time).  Instead, download the Fresco Logic xHCI Controller driver listed above from Dell support and install it.

    THEN, go into Windows, have the Windows Update check for new updates, locate the optional Fresco USB driver, right click, and select "hide" so it won't show up anymore.

  • Thanks everyone, disabling internet was the key for me also.