Dell Inspiron 1525 - Windows 8 - Disable TouchPad

Laptop

Laptop
Laptop computer Hardware and Software discussion

Dell Inspiron 1525 - Windows 8 - Disable TouchPad

This question is not answered

Hello,

I have tried a few searches but couldn't find a thread with an identical problem to mine, but I have pulled some of the information that I found. I just thought I would ask about my specific problem, rather than trying something that might make the problem worse.

My parents Dell Inspiron 1525's TouchPad and buttons are playing up. The left button seems to have no "spring" to it and is stuck in a "click" position... well, it's hovering in a click position. Any vibration or movement to the laptop can cause it to click. Also, the TouchPad seems a bit erratic.

They now have a wireless mouse and were hoping this would resolve, or avoid, the problem. Sadly, when they use the keyboard to type, the TouchPad and buttons keep causing the same problems. The hope was that plugging in the mouse would override the TouchPad and buttons.

This leads to my question... Is there a way to disable the TouchPad and buttons on the Dell Inspiron 1525, running Windows 8?

I've checked the Control Panel/Settings and couldn't see a way to do so, and upon searching this forum for similar problems, I think I need to update or install new drivers. Is this correct and could you point me to the correct and most up-to-date versions?

From other people's posts I have links to the following drivers:

1. Synaptics Website: TouchPad v.16.3.8.8

2. Dell Website: R286709.exe (Dell Touchpad / Pointing Stick v.7.1007.115.102)

3. Dell Website: R242713.exe (Synaptics TouchPad v.14.0.0.0)

Once I know what driver to download and install, I think the next stage should be easy, i.e. find the TouchPad settings and disable.

Any help or advice would be appreciated.

Many thanks,

PsychoCenobite

All Replies
  • Hi PsychoCenobite,

     

    The 'Dell Product Group' team has not tested this system with Windows 8. The drivers will not be available for this system. You can refer to the link for a compatible system tested by Dell with Windows 8 bitly.com/RnDAFu . 

    You may try to install the Touchpad driver in compatibility mode.

    Steps to uninstall the Touchpad driver:

    • Press and hold the Windows key and press 'R' key. This will open the run window.
    • Type 'devmgmt.msc' without the parenthesis, click 'Ok'.
    • Expand ‘Mice and other pointing devices’.
    • From the list, look for ‘Dell Touchpad’.
    • Right click, choose ‘Uninstall’.
    • Check the ‘Delete the driver software for this device’, Click ‘Ok’.
    • Restart the computer.

     

    Steps to install the Touchpad driver:

    • Click on the link: http://dell.to/XREMnE
    • Click ‘Download File’.
    • Check on the radio box ‘Single-file download’.
    • Click ‘Continue’.
    • Click ‘Save’.
    • Choose the location as desktop, save the file on the desktop.
    • Right Click the driver installation file and select Properties -- > Compatibility Tab.
    • Select Windows 7 from the list in the following image:

           

    • Click Apply --> OK
    • Right Click the file and select 'Run as Administrator' to install the driver.
    • Restart the computer.

     

    Steps to disable touchpad:

    • Open Control Panel --> Mouse --> Dell Touchpad.
    • Click ‘Device Select’.

            

    • Check ‘Disable Touch pad/Pointing Stick when external USB mouse is present’

            

    • Click ’Apply’ --> ‘Ok’.
    • Restart the system.

     

    Please let me know for any further assistance.

    Thanks & Regards,
    Tanvi C
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to http://dell.to/YBlak6 
  • PsychoCenobite,

    I have found a way to get the touchpad driver (R286709.exe) to work on my Dell inspiron 1525 running Windows 8 64 bit system.

    The problem I had was the drive installation update would not run correctly in any mode and gave me an error message.  I tried in Run as Administrator and also with other compatibility settings.  No luck with this process.

    The work around I found is this:

    First download the R286709.exe file from the Dell website and take note where you placed it. Let it run and it will say there is an error installing the driver. Get out of the installation utility driver program.

    Next you need to go into the control panel and open the device manager.  In the device manager find the "PS/2 Compatible Mouse" under "Mice and other pointing devices". Right click on the "PS/2 Compatible Mouse" then choose "update driver software".  In the next screen click on "Browse my computer for drivers". In the second screen either use the browse button or enter the directory and path location in the space provided pointing to where the R286709.exe file was placed.  You should have noted this location above.  For example this is where I placed my R286709.exe file and ran it manually. (C:\Users\me\Downloads\Dell\dell\drivers\R286709).  Place a check mark in the box for "include subdirectories" then click on the "Next" button.

    The driver will hopefully load without any issues and ask that you reboot the computer.  Once you reboot your computer there will be a Dell Touchpad icon in the tray at the bottom right of your screen .  You can right click on the icon to change the settings of the touchpad.

    This worked for me and no more aggravation of the cursor switching locations on the document as I typed.

    Good luck

    tazcrazy