Dell Studio 1558 won't boot

Laptop

Laptop
Laptop computer Hardware and Software discussion

Dell Studio 1558 won't boot

This question has suggested answer(s)

Hi everyone!

Since yesterday my laptop crashed while I was watching a movie via HDMI (image froze, sound played on (sound via HDMI)). It didn't respond to anything so I turned it down and wanted to power it up to proceed the film. 

This however, wasn’t going to happen. The screen stayed blank (didn't even see the Dell logo). I tried different things, without HDD, other RAM bank, without battery, without AC charger and a fresh CMOS battery. All without success.. 

I also tried the trick with the AC charger disconnected and without battery, holding the power button for 30 seconds or so and try again afterwards. Didn't helped as well.. 

I've read about a hardware check that could be done by holding Fn and powering it up. First I heard a sort of melody, then 3 beeps, pause, 2 beeps, pause and 1 beep (3-2-1). Unfortunately I couldn’t find this beep-code anywhere on the web.. 

Is there any way to rescue my laptop? My warranty is just expired, the laptop is 2.5 years old and I really want to use it for a bit longer!

Hardware specs:
Intel i7 720 QM
6 GB of DDR 3 RAM
ATI Mobility Radeon 5470 

Thanx in advance!!

All Replies
  • Hi Arjannv,

    What is the status of the power light? Do you hear anything from the system when you try to power it on?

    You can try running LCD BIST (LCD diagnostics) on your system:

    • Turn off the system.
    • Press and hold 'D' and press the power button at the same time; make sure you do not release 'D' until the diagnostics initiates.
    • Please let me know if you see the color bars.

    Alternatively, you may also connect an external monitor and see if you get the display.

    Keep me posted. Please reply for any further questions.

    Thanks and Regards,
    Vikram M
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to 
    http://dell.to/YBlak6

  • Hi Vikram, thank you for your quick respons.

    When I power it up I can hear my fan and HDD spinning like normal. When I wait for a few moments, I even can't turn it down by pressing the button, then I need to hold it like the laptop is in Windows instead of in the bios.

    The LCD BIST doesn't work for me.. The screen stays blank. But, when I release the "D" after 10 seconds or so and press it again it starts to beep almost continuously.

    EDIT:

    Also nothing via HDMI. Don't know for VGA since I don't have a cable for that. Might test it tomorrow. 

    Arjannv

  • Hi Arjannv,

    Thank you for the reply. It appears to be an issue with the LCD from your response. Please connect the external monitor via HDMI and let me know if you get the display.

    Note: Make sure you press <Fn><F1> to switch the display to an external monitor.

    Please reply with the findings.

    Thanks and Regards,
    Vikram M
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to 
    http://dell.to/YBlak6

  • Hi Vikram M

    I'd tried for a few times, but everytime it boots into the hardware checker where I get the 3-2-1 beepcode. Also both screens stay blank.

    Am I doing something wrong?

    Btw, even the backlight of the laptop screen doesn't turn on in both ways (normal and with <Fn><F1>).

    Thanks!

    Arjannv

  • Hi Arjannv,

    It appears to be an issue with the LCD. You may try re-seating the inverter cable (LCD cable) in case you are comfortable. Here is the link for your reference: http://dell.to/kXGA2i

    In case the issue stil persists, you may consider replacing the inverter cable first to see if that fixes the issue. If not, you may consider replacing the LCD.

    Please reply for any clarifications.

    Thanks and Regards,
    Vikram M
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to 
    http://dell.to/YBlak6

  • Hi Vikram M

    Thanks again for your help. But, unfortunately it didn't work. I reconnected the display cable (the big one right? since I didn't see a inverter cable because of my LED screen) but it didn't help. The connector looked fine.

    Btw, when I tested the laptop without the display cable it beeped right at the start.

    How can I be sure it is the cable or the LCD? Isn't it possible that the graphics chip is dead?

    For instance, aren't all display connectors (and with that, the protocol for the screen) the same so I can test my screen/laptop with a different laptop/screen from another brand?

    Thanks!

    Arjannv

  • Hi Arjannv,

    From the symptoms, it appears to be an issue with the LCD or the inverter cable. The screen of any other system make or may not work, however, you can try it. I will recommend you to replace the inverter cable first and post the results.

    Please reply for any further questions.

    Thanks and Regards,
    Vikram M
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to 
    http://dell.to/YBlak6

  • Hi Arjan,

    I am sorry to hear that. I just got my studio1558 laptop repaired for the same problem. I was watching IPL on youtube when all this happened. The display chip on the motherboard had gone. Either you can go for a part replacement from dell for the entire motherboard or you can look in the open market for the display chip.

    This chip is generally of AMD.

    I hope this helps you in resolving your issue.

    Regards

  • Hi!

    I've experiencing issues similar to those described by Arjannv on my Studio 1558. I've tried the actions he described too without success.

    Basically, when I press the button to turn the laptop on, the button light turns on, blu-ray drive starts to make some working noise as there is a disc inside it and fan starts to work and runs faster as processor heats. But the display stays blank and there is no sign of booting process.

    The display was one of my suspects, but thanks to Vikram M suggestion, I believe it is fine. I turned the laptop on at the same time I was holding the 'D' key and the display started to cycle through some colors, so I assume it is fine. Also, as the components are powered and the 'D' key was recognized, I assume (not sure if I should) the motherboard is fine as well.

    Well, I just want to ask a couple of questions to make sure I give up on this laptop or not.

    1. One of my current suspects is the processor. Based on the described above, is it possible that the processor is dead?

    2. I also suspect my video card may be dead. It's because when I connect a monitor to the vga output, it does not detect any signal. The fact that I could test the monitor by pressing 'D' may contradict this, but I'm not sure if this feature relies on the video card to work. Is it reasonable to assume the video card is dead, based on this description? If the video card is dead, it means I will have to replace the whole motherboard to make my laptop work once again, right?

    Thanks in advance. Any help is welcome.

    Dennis

    Dell Studio 1558

    Intel Core i5 430M

    ATI Mobility Radeon 5470

  • Hi Dennis,

    Did you try pressing the Fn + F1 key after connecting the external monitor? This switches the video image to the external screen.

    If the external monitor does not shows any display, it might be an issue with the video card and the motherboard might have to be replaced.

    Please reply if you have any questions.

    Thanks & Regards,
    Appu S
    #iworkfordell
    To know more about Dell’s Product Support, Drivers & Downloads, Orders & Dispatch status -> choose your region USA, India. For Dell Support Videos, click Here.

  • Hi Appu S,

    Thanks for your reply. Yes, I have already tried this key combination with an external monitor connected.

    It really seems that the video card is facing some problem. OK, I will see what I can do about it.

    Thanks a lot for the help.

    Dennis,

  • Hi everyone!

    It seems that I'm not the only one with this problem..

    I found out that I had to press <Fn><D> for the LCD test..

    Then it showed Red, Blue, Green and white.

    Does this meen that the GPU or CPU is defect?

    Connecting it to an external screen still doesn't work..

    Greetings, Arjan

  • Hi Dennis,

    Thank you for the response. Since you have tried all the possible steps, mostly likely, the issue is with the video card. As laptops have video card embedded on the motherboard, so the entire motherboard might have to be replaced.

    Let me know if you need any further assistance.

    Thanks & Regards,
    Appu S
    #iworkfordell
    To know more about Dell’s Product Support, Drivers & Downloads, Orders & Dispatch status -> choose your region USA, India. For Dell Support Videos, click Here.

  • Hi Arjan,

    If connecting an external monitor does not display anything on the screen, it indicates a possible video card failure and the motherboard might have to be replaced.

    Please reply if you have any questions.

    Thanks & Regards,
    Appu S
    #iworkfordell
    To know more about Dell’s Product Support, Drivers & Downloads, Orders & Dispatch status -> choose your region USA, India. For Dell Support Videos, click Here.

  • Hi Appu,

    Thank you for your fast response.

    How much would it cost me to replace that part?

    Arjan