Dell Xps Lx702 Battery won't charge - General Hardware - Laptop - Dell Community

Dell Xps Lx702 Battery won't charge


Laptop computer Forums (Audio, General Hardware, Video)

Dell Xps Lx702 Battery won't charge

This question is not answered



I've recently run into a problem with my battery on my XPS 17, the battery refuses to charge. I had a few weeks where windows would note that the battery was around 94% constantly and continued to say it was charging. So I attempted to let the battery run flag in order to give it a fill charge. Problem is now the battery seems to be stuck at 0% and still refuses to charge.


All of the battery lights are on when the ac adapter is plugged in, and windows shows that its charging i.e it doesn't note a problem. The battery health is also fine I've tried to hold the button on the battery for 3 seconds and this results in no lights showing up. If pressed for a short while one light appears although not for long.


I've also tried charging the battery with the laptop off for extended periods with no luck.


Thanks in advance  for any information you can provide on the topic.

All Replies
  • Hi opdude,

    Battery has a life of approximately 1-2 years depending upon the usage of the laptop.

    I would suggest you to click the link mentioned below to access Dell Article 266588:

    Select 2nd option "AC Adapter Power or Battery Charging issues".

    Perform the steps mentioned which may help you fix the issue.

    Hope it helps.

    Thanks & Regards
    Manshu S

  • Hi Manshu,

    I have tried all the mentioned tips however none of them has made any difference to the battery, given the information would you expect the problem lies in the battery or the AC adapter? Windows still claims it's charging (although it stays on 0% and previously stayed on 94%).

    I tried the PC Diagnosis and it returned the following information

    Your battery life may be operating outside of normal parameters. Batteries normally degrade over time due to normal usage. Dell warrants all laptop batteries for 1 year from the data of purchase.

    So it does seem to be more of a battery thing, but as my warranty has run out, literally only about a month ago, I'd rather not have to purchase something if the problem lies elsewhere.

    Thanks in advance,


  • Hi Opdude,

    Thank you for the reply.

    Please update the BIOS using the link mentioned below:

    Note: Ensure battery is charged more than 30% and the AC Adapter is connected. 

    Also, I would suggest you to charge the laptop with any other  good known adapter to isolate the issue further. In case the issue persists, battery needs to be replaced.

    Thanks & Regards
    Manshu S