Dell XPS 15 L502x 'plugged in, not charging' and orange/white flashing battery light? And FAILED HARD DRIVE!


Laptop computer Forums (Audio, General Hardware, Video)

Dell XPS 15 L502x 'plugged in, not charging' and orange/white flashing battery light? And FAILED HARD DRIVE!

This question is not answered

I've owned my Dell XPS 15 L502x for just over a year (thus, I am out of my warranty period) and recently it has stopped being able to charge. I am completely tethered to the AC power adapter to use it as I'm on 0% battery and have an inability to charge it.

As well as my inability to charge the laptop, I have noticed the following things:

  • The computer states that 'No battery is detected' when the battery is inserted
  • 4 orange and 1 white lights are flashing on the battery indicator above my charging port and above my keyboard
Furthermore, a couple of days ago my computer completely failed to boot and I discovered that my 500GB hard drive had crashed. Thankfully I managed to get all my stuff back, but I now need to get a replacement hard drive. I am currently using an old 150GB one that we had in the house.
What is wrong with my laptop, and what is it trying to tell me with these messages?
Is the problem with my hard drive linked to the problems I detailed above?
Thank you
All Replies
  • Hey, I'd got the same problem today, and already fixed it.

    For me the problem started because I use my laptop only plugged without the battery. I don't know if this would fix it each time but you can try the following.

    In the "Dell Battery Meter" options you need to disable the battery charge and then enable it again, you can reach those options 2 ways.

    1.- Right click on Battery icon (task bar). In the context menu hit Dell Battery Meter

    2.- Open Start Menu and type Battery, select "Change battery config.", in the left panel hit Dell Battery Meter

    So disable battery charge, enable it again, and see if it gets fixed.

    I repeat, this worked for me, i'm not sure it would work 100% of the times

  • D-U-D-E!

    Thanks to your post I just reset my battery charging capability.  I was shopping for a new battery when i cam across your post.  Did precisely as you said, and voila, after restart....."plugged in battery CHARGING!"  whew!  It was down to 8% when I clicked on the battery meter and was surprised to find that battery  charging was disabled.  I disabled it manually as prompted, restarted, and all is well.

    Bless you brother!