Inspiron 15r SE catalyst control center 'Host application has stopped working' - FIXED

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Inspiron 15r SE catalyst control center 'Host application has stopped working' - FIXED

This question is not answered

Hi All,

Since receiving my new Inspiron 15r SE for Christmas running windows 8. I immediately installed some games to see what it was capable of, however discovered the Catalyst Control Center (CCC) kept crashing when selecting 'Graphics Properties' or 'Configure Switchable Graphics'. I could play games fine but the  CCC software just kept crashing. I tried uninstalling and re-installing every version available through the dell support website with no success.

The Fix: It turns out that some of my user specific files for CCC were causing the error and uninstalling does not remove them. To resolve the issue follow these steps:

  • Open Control Panel (from shortcut menu windows key + x)
  • I uninstalled all components of 'AMD Catalyst Install Manager'
  • Restart computer
  • Open 'C:\Users\<username>\AppData\Local\' (replace username with your local username)
  • Delete the ATI folder
  • Download latest graphics drivers
  • Install drivers
  • Restart
  • All should be good in the world and CCC should be working
Technical Explanation (Dell pass this on to your developers): Looking in event view I found the following error logged by the .NET framework detailing the error raised by CCC.
Application: CCC.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Reflection.TargetInvocationException
Stack:
at System.RuntimeMethodHandle.InvokeMethod(System.Object, System.Object[], System.Signature, Boolean)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(System.Object, System.Object[], System.Object[])
at System.Reflection.RuntimeMethodInfo.Invoke(System.Object, System.Reflection.BindingFlags, System.Reflection.Binder, System.Object[], System.Globalization.CultureInfo)
at System.RuntimeType.InvokeMember(System.String, System.Reflection.BindingFlags, System.Reflection.Binder, System.Object, System.Object[], System.Reflection.ParameterModifier[], System.Globalization.CultureInfo, System.String[])
at ATI.ACE.CLI.Component.Runtime.Shared.Private.BaseCaste.LoadAspectsAndInvokeCheck(ATI.ACE.CLI.Foundation.HAdapter)
at ATI.ACE.CLI.Component.Runtime.Shared.Private.BaseCaste.CreateAspects(ATI.ACE.CLI.Foundation.HAdapter)
at ATI.ACE.CLI.Component.Runtime.Shared.Private.BaseCaste.ProcessAspects(Int32)
at ATI.ACE.CLI.Component.Runtime.Shared.Private.BaseCaste.Create(ATI.ACE.CLI.Foundation.XAspectsBase)
at ATI.ACE.CLI.Component.Runtime.Shared.Private.RTComponent.Initialize(ATI.ACE.CLI.Foundation.XCastesBase)
at ATI.ACE.CCC.Implementation.CCC_Main.CCCNewThreadBegin(System.Object)
at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object)
at System.Threading.ThreadHelper.ThreadStart(System.Object)

The error is a reflection issue, more specifically a deserialisation issue in method LoadAspectsAndInvokeCheck. This normally occurs when attempting to deserialise an object which is either invalid or null. Looking at the stack trace you can see CCC was attempting to load some aspect settings. I believe these are stored in C:\Users\<username>\AppData\Local\ATI\ACE\Manifest.xml. Some how these must have got into an error state one that could not be resolved by a normal user so probably should have some error handling.

I hope this helps anyone experiencing the same issue.
All Replies
  • Hi

    I am also facing this problem with my Dell inspiron 15R(5521). So i tried out to update my graphics drivers from the dell support which doesn't help me to get rid of this problem  however the above post suggested me to uninstall all components of 'AMD Catalyst Install Manager'. So i want to try this.But I dont know what all the programs and drivers to be uninstalled that comes under "'AMD Catalyst Install Manager'" so kinldy let me know the program names that i need to uninstall to overcome this problem.

    Thank you.

  • Hi i had the same problem.

    Try deleting this folder: C:\Users\<user_name>\AppData\Local\ATI.

    It worked for me.

    Hope this helps.

  • Hi I also had the same problem after I added Internet Explorer to High Performance mode.

    I tried uninstalling and re-installing the drivers but nothing worked.

    I just remove the ATI folder from appdata in users folder and it worked.

    Great

  • I have the same problem. I have had problems with my inspiron 15 SE from the start. I am getting this message when the computer boots that the ATI "Catalyst control center has stopped working". The controls for the display never worked and it appeared that the drivers did not work. I have let it go for months now but its popping up every time I start the computer. I also get a message saying my adapter for the battery is not the right watts and the battery will be damaged from it. I also have a message that crashes the computer that says " the driver did something in the stack. I wonted to give this computer back when I first got it, but Dell told me I waited a day over the limit that you can get a refund. Dell is nothing like the way they you to be.