17R 7720 SE: Lost BIOS Access


Laptop computer Forums (Audio, General Hardware, Video)

17R 7720 SE: Lost BIOS Access

This question is not answered

I have a new 17R 7720 SE and can not access either F2 (Does not show up) for BIOS access and when I hit F12 Boot Options it shows but will not do anything it goes right to my Windows 8 Log in. How can I reset my BIOS to factory defaults ? I did do the latest FLASH upgrade and am wondering if it has anything to do with it.

I have attempted to contact Dell Tech support but they had no answer and told me they would call back in 1 hour...nothing... I have attempted Fn +Tapping F2 upon power up and nothing... Have attempted Fn+F12 tapping while power up and nothing.

If I remove the top of the case and then disconnect the BIOS battery will this take me to default settings ? I am a Electrionic Engineseer and I stayed at a Holiday Inn last night, I can handle it! Surprise



All Replies
  • Same here new 17R 7720 SE Bios A11 exact same issue F2 or F12 does nothing and the laptop just boots to the OS.  Wish to install an mSATA cache using the Intel SRT features but I can't even get into the bios to make the changes necessary to complete the task.


    Anyone from Dell Tech going to respond to this thread and I've noted that there are other threads stating same issue with the 17R SE (7720) models.




  • HAPPY NEW YEAR! I hope some DELL tech chimes in soon...

    Seeing a LOT of 7720 'grief' threads today - I ordered a 7720  two days ago, and might not have jumped on it if I had spent a little more time cruising these forums. I can only hope that I won't get a lemon - I've had remarkable luck in the past

  • Anyone from Dell going to chime in here? Few of us are locked out from our 7720 Bios settings. I would like to add an mSATA drive but I can not complete the work since I can't even get into the BIOS to change settings.  Advice Please.

  • Would be nice to hear some news SOON, yes!

    I have a 256G msata card on its way from Crucial, and it should arrive here about the same time as the brand-spanking-new 7720 does...  (end of this week).

  • In another post someone suggested to pull the Physical HDD to see if the system will then allow you to boot into the BIOS.  

    This worked for me, not sure if the Physical HDD needs to be in place to setup the BIOS for it to work with an mSATA card though. Need to order one myself.

    Hopefully DELL will sort out the ability to press F2 during bootup to access the BIOS without having to pull the Physical HDD to do it.


  • I tried all possible keys combinations for BIOS access and still no effects. I also removed HDD and still nothing. Maybe it is the reason that I upgraded BIOS to A11. Is it possible?

  • Never tried it before having installed A11 when I noticed the problem to begin with.  With that said, Dell has now release A12 as of Jan 14th 2013 and after installing that it still has the same issue.


    No matter what Key Combination I try I can't access the Bios nor the Boot Options Menu.
    Only way I can access the Bios for now is to simply remove the Drive.


    Would someone from DELL be kind enough to jump in here and tell us what's going on and or what we need to do to correct this.


  • Pull the HDD and then power it up using F12.  It worked for me and I was locked up. I know you tried it once but I am not sure you used F12?  Keep tapping F12 on the power-up  and  then chose setup  to get in BIOS or boot options for using  legacy CD/DVD's.


  • @Bill Alsip,  Yes Pulling the HDD did work for me I was able to access the BIOS then, it's the only way I can do it for now.... just wondering though I want to put in an mSATA cache drive and I know in order to use the Intel Smart Response Technology I need to set it in the BIOS what I don't know... do  you need to set this up in the BIOS with the HDD being visible I would assume that the HDD would need to be in place to select the drive and set for SRT so that it can be paired with the mSATA no?

    And HELLO DELL SUPPORT are you alive?

    Will anyone from there respond to this and other posts on here regarding this issue?

    I see your other post and noted that yes indeed the user manuals are now GONE! what gives on that.  I checked via the Web under my service tag and there are no available manuals now.  As well as using the DELL support  the one Powered by "PC Doctor" application under windows 8 and it to can not link to the manuals.

    I'm like you 25+ years working for a Major insurance company as a Technical Engineer doing nothing but Research and Development in regards to new equipment this would have been a nice desktop/field tech travel unit. But, as it stands now, if this unit came across my desk and this is what I saw after my usual 90 day trial.  It would have been thrown under the scrap heap as a "Nice Try, check on it later, MAYBE unit"

    Not all to pleased with the technical aspect of this unit so far? Lets see what kind of answer and hoops I'll have to jump thru when I get technical support on the line.  This should be fun, can't wait to see what their going to say when I tell them I went to download the manual using their application and there is none. And for that matter I know they where there so don't tell me that it's a new unit and they haven't been posted or when I ask them how do I go about putting in an mSATA and they instruct me to access the BIOS by pressing F2.  This should be a bunch of LOLZ on my part :D

  • Things are so bad I may have to resort to this:

     link deleted for now

  • Hopefully this will work... would you be kind enough to either post back here success or not.  I'll also try to follow your thread. Marked it already because who knows probably someone from Dell Support will see it and remove it.  GOD forbid if a user finds out how to access the BIOS.

    I can't believe dell decided to lock out the whole BIOS.. now I'm just going to question them on exactly what are the procedures to add an mSATA cache to the unit.  I can't wait until they tell me to hit F2 to get into the BIOS..

    Earth to DELL support come in DELL support.


    I see A08 is still posted under older versions of the BIOS - is it possible to load an older version over the newer one?  I'm pretty sure A08 worked for me and I was able to get into the BIOS prior to going to A11 and now A12

  • Call Dell with proof of ownership and they will help unlock the BIOS. If out of warranty, there will be a fee. The password is not stored in CMOS memory - it is stored in nonvolatile, flash EEPROM memory.






    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • The word unlocked was used, so that was my first post.


    If using Windows 8 tap F2 quickly to get into the bios. You have to be fast on the new Windows 8 systems.





    What is a Dell Service Tag and how do I locate it? 



    Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

    Welcome to Dell Community!

  • This is not a password issue.  Dell has locked out all users from adding boot devices etc.  to the BIOS. I can still get in there to modify parameters but only a small subset of what used to be configurable. The problem is that since I can not enter the BIOS with a simple F2 or F12 I have to pull the HDD to force the Phoenix BIOS to ask me what the boot device is,  as it's last resort! I have to do this every time I want to boot hard drive cloning software that requires "Legacy, Secure off". Thanks for the reply though RockStar! I have been in several time before A12 and know to hit F2 / F12 quickly. It suddenly did not work when I flashed A12.

    CyberMaxX360:  I put it in as a test to see if any of my posts ever get looked at by Dell! I think the solution is months off in the future but I would like a reply saying it is being worked on.

  • You know what's ironic about the statement "Proof of Ownership" ok yes I can prove I own it but as stated "Ownership" I own it so why am I locked out of the BIOS to begin with.  Just plain stupid on DELLS part.