Latitude D610 Laptop will not turn on

Laptop

Laptop
Laptop computer Hardware and Software discussion

Latitude D610 Laptop will not turn on

This question is not answered

I have a Dell Latitude D610 Laptop and when i open it up and press the on button the green on light on the keyboard comes on and then it blinks exactly (8) eight times and then it shuts itself off I tried this several times but it dose the same thing each and every time. Could anybody please tell me what i can do to fix this so i can get back my computer? I am using my desktop right now but would rather be on the laptop instead in my easy chair if i could.

All Replies
  • Hello Jimmy,

    To assist you further, please help me understand which LED are you taking about. The system has quite a few LEDs as shown in the picture below. 



    1. Turns on when you turn on the computer and blinks when the computer is in a power management mode.
    2. Turns on when the computer reads or writes data.
    3. Turns on steadily or blinks to indicate battery charge status.


     

    1. Turns on when the numeric keypad is enabled.
    2. Turns on when wireless devices are enabled.
    3. Turns on when the uppercase letter function is enabled.
    4. Turns on when Mini PCI® functionality and Bluetooth® wireless technology are enabled. To enable or disable Mini PCI functionality and Bluetooth wireless technology, press <Fn><F2>. 
    5. Turns on when the scroll lock function is enabled.

    Please write back with the details, would be glad to assist you further.  

    Thanks & Regards
    Allan D
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USIndia. For Dell support videos click Here.

    If a post answers your question, please click "Yes".

  • I belive it is either led #1 or 2 it blinks just (8)eight times and then it shuts right back off. I hear the evet familuar click when it goes off just like a normal shut down. I have tried to start this a dosen or so times and again just a short time ago and it is still the same. I realy need this up and running asap.

  • Hi Jimmy,

    Is it the LED# 1 or 2 of the first image or the second image. I would also request you to specify if it is LED # 1 or LED# 2.

    However there are few steps that can be tried to resolve the issue.

    1. 1. Releasing the flea power.
    Disconnect all the peripherals from the computer including the battery and the ac adapter and release the flea power by pressing and holding the power button for 5 to 10 seconds and check.

    2. Try to boot only with the AC adapter connected to the computer and check the functionality. 

    Please write back to us with the details, would be glad to assist further. 

    Thanks & Regards
    Allan D
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USIndia. For Dell support videos click Here.

    If a post answers your question, please click "Yes".

  • Hi ,  

    Unfortunately we have not received feedback from you on this topic. If you need continued support, please write back. Other community members who need assistance please start your own topic in a new thread.

    Thanks & Regards
    Allan D
    #iworkfordell
    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region USIndia. For Dell support videos click Here.

    If a post answers your question, please click "Yes".

  • It's the 3rd Led in image no. 2

    The CapsLock led that flashes 9 or 10x  after which the system powers off. 

    Any ideas?