Inspiron 1545 Battery not charging - General Hardware - Laptop - Dell Community

Inspiron 1545 Battery not charging


Laptop computer Forums (Audio, General Hardware, Video)

Inspiron 1545 Battery not charging

This question is not answered


A few days ago, on my Inspiron 1545, my power adapter stopped working.

I started using an identical Dell adapter (exact same model PA-3E) to supply power to the laptop, power was working fine, but the battery would not charge.  The battery is at 0%.

In BIOS the adapter is recognised as the correct 90W adapter  but the battery is marked as "IDLE".

I have run Dell diagnostics and that says the battery is healthy, how can that be if it wont charge?

What are the likely faults and how do I find a solution?

Many thanks

All Replies
  • Hi drumon,

    I would suggest you to try the below steps to see if it works.

    1: Update Bios: below is the link to download Bios.

    2: Release flee power:  Switch off the system; remove the battery, ac adapter and the power cable. Press and hold down the power button for thirty seconds to drain any excess flea power 

    Please do get back to us for further assistance or information.


    Thanks and Regards,
    Nikhil M

  • Thanks

    I've tried "releasing flea power" many times, with no change to the present situation.

    I cannot update bios without minimum 10% battery.  I have 0% battery and cannot charge it at the moment - how do I get round this in order to try your BIOS suggestion?

  • Hello again

    I now have managed to download the updated BIOS (BIOS A14) according to your link.

    Still the battery is not charging.....  What else can you suggest?

  • Hi drumon,

    The problem might be with the battery or the motherboard.

    I would suggest you to try with a known good battery if you have and see if it works.

    If it works the issue is with the battery or else the motherboard is faulty.

    Please do get back to us for further assistance or information.


    Thanks and Regards,
    Nikhil M

  • Hi

    I tried a Dell battery, which is same shape and voltage, (though different model number).  That did charge up.

    So do you think its normal that an adapter could fail and a battery fail at the same time?  

  • Hi drumon,

    In very rare circumstances the battery and Ac adapter would go faulty at the same time. Since the Ac adapter is getting determined in Bios the problem might be with the motherboard.

    I do request you to provide the service tag number on a private chat and I will get back to you on the warranty status.

    Below details will help you on how to send me a private chat.

    I have added you as a friend.

    Please accept my friend request by clicking on my name ‘NIKHIL M ’highlighted in blue and then click on “Friends” tab at the top and then click on “Request to Review” and finally click on “Accept” button.

    I am sending you a private message as well.

    Click on “Inbox” to respond to the message and provide the service tag and contact details so I may access your system records and check for further course of action.

    You could also click on Start Conversation to send a private message. Please let me know if this helps.


    Thanks and Regards,
    Nikhil M

  • I've been looking at a Dell 1545 with battery charging issues also, and have not yet solved it.

    It is not my own, so I don't know the full details, but the original battery apparently recently stopped charging.  A new (non-Dell) battery also fails to charge.  

    Symptoms: Viewed in BIOS, the battery shows 0%, and alternates every few seconds between Charging and Idle.  The AC Adapter is recognised as a 65W device, which is correct.

    On the Vista system tray icon, the pattern of charging/not charging seen in the BIOS is repeated.

    Removing the AC adaptor causes the PC to die immediately.

    Connecting the AC adaptor leads to the Standby LED turning on after a few seconds, where it remains a steady white illumination until power is removed (turning off instantly), or until the unit is put into standby, where it modulates the brightness.

    WIth the PC Off, Battery removed, AC adapter turned on and plugged in, a switched mode power supply can be heard inside the PC when the battery is slotted in.

    I have tried clearing the "flea power" as suggested above, but this makes no difference.

    I updated the BIOS from A05 to A14 by downloading from

    and then created a shortcut to the downloaded file, edited the shortcut properties so that the Target field was appended to read

    "C:\Users\Owner\Downloads\BIOS\DOS Only Exe\1545_A14.EXE" /forceit

    and on the Advanced options, selected "Run as Administrator".  This installed A14 OK, but made no difference to the problem.

    A multimeter shows the battery terminals at 0V (measured removed from PC).  The PC battery terminals (battery removed) only shows 1.3V when the AC Adapter is fitted.

    Without another reference system to evaluate battery behaviour with, I'm a bit stuck for ideas.  Supposedly, the problems with the battery may have happened around the time that the hard disk was changed, but that isn't clear.

    So, summarising, the battery status seems good, but is failing to charge, and an internal SM power supply alters behaviour in the presence of the battery.

    Any insight is most welcome.

  • Make sure that the power adapter is ALWAYS properly recognized in the BIOS.A loose connection could easily cause communication problems between the BIOS and the adapter.