E6400 Latitude display problem

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

E6400 Latitude display problem

This question is not answered

Hello,

I have a problem with my E6400 Latitude and I hope anybody can help me:

when I turned on the laptop, the display have got a little line working correct on the top of the screen. The rest of the screen are fade to gray and is diffuse.

Here is a short video of the problem: http://www.youtube.com/watch?v=3pex9-DlfBY

Can anybody tell me what the problem is (LED display, graphic board..)?

Thank you to all and have a nice day

Pat

All Replies
  • Hi happyCroud,

    I suggest that you check if the display is the same in the BIOS screen. To go to the BIOS screen, restart the system and tap the F2 key every two second.
    Also run a test on the LCD screen. To run the test shut the system down and press FN and D key on the keyboard which will launch a test on the LCD screen.

    Please connect an external monitor and check for the display on the external monitor. In case the display is fine on the external monitor I suspect the screen is faulty. You may consider replacing it.

    Please revert for further assistance.

    Thanks and Regards,
    Sujatha Krishnappa
    Dell Social Media and Community Professional
    Order Status: http://dell.to/1fgKSTr
    Download Drivers: http://dell.to/1hcxG98

  • Hello,

    thank you for the fast reply.

    The display problem appears everytime the laptop is on, that means iat the BIOS screen, at booting the OS and in the OS itself. A external monitor (connected to the D-SUB or to the display-port) works fine.

    You think the screen is faulty and not the Nvidia graphic board?

    Thanks a lot.

    Pat

  • Hi happyCroud

    I suspect that screen is faulty; you may consider replacing the screen,

    Please send me a private message with the system service tag to check the warranty details.

    I have added you as a friend. Please accept my friend request by clicking on my name highlighted in blue and then click on “Friends” tab at the top and then click on “Request to Review” and finally click on “Accept” button.

    I am sending you a private message as well. Click on “Inbox” to respond to the message and provide system’s Service Tag and contact details so I may access your system records and check for further course of action. You could also click on Start Conversation to send a private message.

    Thanks and Regards,
    Sujatha Krishnappa
    Dell Social Media and Community Professional
    Order Status: http://dell.to/1fgKSTr
    Download Drivers: http://dell.to/1hcxG98