dell E5520 Bios Update

Laptop

Laptop
Laptop computer Hardware and Software discussion

dell E5520 Bios Update

This question has suggested answer(s)
Dear All,

i have Dell E5520 with Current BIOS Version A01. Whenever i try to update my BIOS it stops working and give me a BLUE screen until unless i revert my BIOS back to A01 using the DOS boootable USB.

i have tried every way ..updating from Windows 7 (64 Bit), from DOS, try to update from A01 to A02, from A01 to A03 etc

but nothing works. I am just sick of this. If anyone knows anything about this problem please let me know.

thanks

itsmeshu
All Replies
  • Hi itsmeshu,

    Are you facing any issues with your system for which you are trying to update the BIOS? Please share the exact error that you get on the blue screen. Also, please let me know from where are you trying to update BIOS.

    Keep me updated. Please reply for any further questions.

    Thanks and Regards,
    Vikram M
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to 
    http://dell.to/YBlak6

  • Dear Vikram,

    I have Dell E5520 Model. Core i5/ 2.2 Ghz/ 6 GB RAM/ 500 GB HD. Current BIOS version (which was preinstalled when i bought this laptop in Sep 2011. I have downloaded all the BIOS version from Dell Website. 

    As recommended by Dell i first update my BIOS to A02 so that i can update it to later version i.e. A09 etc. But once i update this it shows me that the "BIOS UPDATED SUCCESSFULLY" but when computer reboot itself it gives a blink of a BLUE SCREEN which appears just for a fraction of a second and computer goes to boot options. No matter how many times you restart it gives the same error. I tried updating BIOS from WIndows 7(64 Bit) environment and from DOS BOOTABLE USB as well. Even i updated my BIOS to A02 and then from DOS updated it to All available version of BIOS update till A09 just to see that any of them works with my laptop, but no luck. Now i dont know what to do and how to do .... just making me sick. At the end to get my system back i need to get back to BIOS version A01 to get rid of this error. IT WORKS FINE with A01 Only.

    hope to hear from you soon.

  • Hi itsmeshu,

    I will recommend you to update the BIOS again and once it is updated, check the boot options; there is a possibility that the first boot device is changed from hard drive to some other device after BIOS update:

    • Update the BIOS.
    • Restart the system and keep tapping 'F2' as soon as the Dell logo appears.
    • Highlight 'General' and then 'Boot Sequence' using the arrow keys and press enter.
    • Make sure 'Internal HDD' is set to the first boot device.
    Keep me posted. Please reply for any further questions.

    Thanks and Regards,
    Vikram M
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to 
    http://dell.to/YBlak6

  • Dear Vikram,

    thanks for the reply. But honestly speaking i have tried this as well. Even i have tried to boot my PC (after updating BIOS) in Safe Mode, Last Known Good Configuration, Safe Mode Command Prompt Only etc. But nothing works and it gives me a Blink of a blue screen and again go to Reboot.

  • Hi itsmeshu,

    Thank you for the reply. Please do a BIOS default and disconnect all the external peripherals connected to the system. Once done, try updating the BIOS again.

    Keep me posted. Please reply for any further questions.

    Thanks and Regards,
    Vikram M
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to 
    http://dell.to/YBlak6

  • dear vikram,

    although i had also done this but as you said i did this again. NO LUCK. its same. Its a standalone laptop nothing external connects to it, not a part of any homegroup or network etc. i really dont understand that why everything works PERFECTLY with BIOS VERSION A01 and except rest with every BIOS this machine becomes a trash. 

  • Hi itsmeshu,

    Update the BIOS and restart your system and keep tapping 'F8' as soon as the Dell logo appears. Highlight 'Disable automatic restart on system failure' and press enter. Using this option, the system should not restart on the blue screen. Please share the exact error message that appears on the blue screen.

    Also, I understand the system works fine with A01 BIOS, I will recommend you to run the diagnostics on your system to check the hardware functionality:

    • Restart the system and keep tapping 'F12' as soon as the Dell logo appears.
    • Highlight 'Boot to utility partition' using up and down arrow keys and press enter.
    • When the Dell Diagnostics main menu appears, select 'Express Test' and press enter.

    Keep me posted. Please reply for any further questions.

    Thanks and Regards,
    Vikram M
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to 
    http://dell.to/YBlak6

  • Hi vikram,

    well regarding the Dell Diagnostics i have run this utility many times and it does pass all the hardware tests etc. Yes now i'll follow your advise to get that BLUE SCREEN ERROR to pass you on for FNA. thanks 

  • Hi itsmeshu,

    Thank you for sharing the results of the hardware diagnostics. Please share the Blue Screen error by highlighting 'Disable automatic restart on system failure'.

    Please reply for any further questions.

    Thanks and Regards,
    Vikram M
    #iworkfordell
    To know more about Dell’s products, services and drivers & downloads, please go to 
    http://dell.to/YBlak6

  • This thread has been locked due to inactivity. For assistance, with the same or a different issue, please click New Post on the top right to start a New Thread.