Dell Studio 1747 does not charge battery - General Hardware - Laptop - Dell Community

Dell Studio 1747 does not charge battery


Laptop computer Forums (Audio, General Hardware, Video)

Dell Studio 1747 does not charge battery

This question is not answered

I have looked at the post here:  and while similar, those resolutions do not fix my problem.  It has been an issue since I first purchased the laptop, and I have had support remote in and look at things on multiple occasions, but because it only charges sometimes, was never able to replicate when it was plugged in and would not charge.  At that time, it was a backup laptop so was not used frequently.  I am now using it more often, and this issue is becoming extremely annoying...

Having used it for a while now, I have been able to identify exactly what is happening, can replicate it consistently, and am looking for some resolution.

  1. When the battery is dead, it will charge.
  2. It will charge until 100%, then disconnect the A/C adapter and subsequently discharge the battery.  Plugging and unplugging the A/C adapter does not force the laptop to detect the A/C adapter and keep it charged, it will always discharge once it reaches 100%
  3. Shutting down and rebooting does not start it charging.  Shut down while it is currently charging then booting back up and it continues to charge.  Shut down while it is discharging then booting and it continues to discharge.
  4. The latest BIOS is installed.  Windows 7 Ultimate 64-bit is installed and patches kept up to date.
  5. I have tested alternate A/C adapters, and all result in the same actions.
  6. I can force it to start recharging by putting it in hibernate mode.  Once fully hibernating, it will start charging again, and will continue to charge when brought back out of hibernation.
  7. In fact, when it fully discharges and reaches 5%, it goes into hibernation, then the charging LED comes on.

There has got to be some setting somewhere, maybe BIOS, or something, that causes it to stop charging when it reaches 100%.  I haven't found that yet, can anyone help?

All Replies
  • Does the BIOS (F2 at powerup) properly sense the AC adapter, or is it listed as "unknown"?

  • The BIOS does correctly identify my A/C adapter.  I have not checked if it does when it is in the discharge state though.  I will check and post that result.

  • Update - When it switched over to discharging, I shut it down, rebooted and checked the BIOS.  That still correctly identified the A/C adapter.  When escaping out and booting into Windows, at first while Windows was still starting up, the charging icon came up for a few seconds.  By the time I could actually do something, it had switched back and shows it discharging.

    I shut it down into hibernate mode, booted back up and it was back to charging.  So this confirms what I have been seeing.  Hibernate mode will magically switch it to charge the battery...  

  • bump

  • bump again.

    Am I pretty much stuck with dealing on my own?  I'm still looking but having no luck finding....

  • I have a similar problem, if not the same. My 1747 charges with charging LED on. After some time the LED goed black, still Windows says battery is charging and the percentage rises. If I disconnect the charger, the screen backlight brightness changes as expected and the "charging" status disappears. If I reconnect the charger, the LED blinks like expected but tsay black after that, with again Windows saying taht the battery is charging and the level rises. At 100% charging ends and the battery starts discharging, even with the charger connected. In this state the charger won't be recognized anymore, no changing brightness on disconnect/reconnect, no blinking of the white charging LED. The use of battery instead of power supplied by the charger will continue until the orange LED comes on, battery is depleted, system suspends to disk, orange LED stays on, and still no charging. If I restart the system then, it will start charging, again until the battery is fully charged, the game begins again. I've tried this with three different chargers (all original Dell) and three different batteries (also all original Dell, I own a 1745 too).

    Another symptom: If I remove the battery with the charger connected, even charging the battery, the system will shut down like it would when the battery is removed while no charger is attached.

    The charger with correct type is always recognized in the BIOS. Even if I tell Windows to restart and go into the BIOS in the state where the battery discharges even with charger connected, the charger and its type is still recognized! Disconnect it in BIOS --> none, reconnect it ---> changes to "130W" like it should. But still, no blinking of the white charge LED and no change in brightness, and no charging.

    I don't know what to do anymore. I need help with that as there is no reliable way to use the notebook over a longer period of time.

  • Also, I noticed just now that the notebook will only run about two to three minutes without the battery, only on charger. It just shuts off...

  • Hi Jens1977,

    Thank you for all the trouble shooting steps done and the detailed description of the issue. I request you try these two steps to determine the issue.

    If the system turns and works fine for a while with both battery and Ac adapter connected, I suggest that you flash BIOS to the latest version as this step needs uninterrupted power supply.  Please find the link below:

    Do not use the system till it restarts and comes up to the desktop.
    In case the issue persists after flashing BIOS or if you are unable to flash BIOS,  please run diagnostics on the hardware components of the system. Follow the steps given in the link below for the same:

    Reply with the status of the test to assist you further.

    Thanks and Regards,
    DELL-Sujatha K
    Dell Social Media and Community Professional
    Order Status
    Download Drivers

  • Hi! Thanks for your reply. The BIOS is already version A14, so it's the newest. I even reflashed this version in case something went wrong the first time, no change. The diagnostics run without any error at all, I tried that already too.

  • Hi Jens1977,

    I suspect the mother board is faulty. I request you to send me a private message with the system service tag to check the warranty and assist you further. 

    I have added you as a friend. Please accept my friend request by clicking on my name highlighted in blue and then click on “Friends” tab at the top and then click on “Request to Review” and finally click on “Accept” button.

    I am sending you a private message as well. Click on “Inbox” to respond to the message and provide system’s Service Tag and contact details so I may access your system records and check for further course of action. You could also click on Start Conversation to send a private message.

    Thanks and Regards,
    DELL-Sujatha K
    Dell Social Media and Community Professional
    Order Status
    Download Drivers

  • Hi,

    Can you tell me if you ever got this problem resolved?

    I, along with many other people, have the same problem. Unfortunately my studio 1747 is out of warrenty so even though this is clearly a design issue with this range I doubt Dell will do anything to help.

    At least if I knew yours was fixed with a new motherboard I would know the appropriate action to take.



  • I, too, have been having problems with my battery charging. It would not charge at all. The AC adapter LED would be yellow/orange with the AC adapter plugged in and my laptop (Studio 1747) would only run with the AC adapter connected. I have done a lot of work trying to troubleshoot this issue. I see from all that I have read that this is a very common issue...My AC adapter is good, my battery is good, it simply would not charge the battery. I tried all the fixes I could find. Checking the bios, it was the latest version. I checked the AC Adapter indication in the bios and it showed "unknown". I reset all the defaults just in case, but this was not the issue. What I did find and this has fixed my charging issue, is the dotnetFramework had been mistakenly removed. During the troubleshooting I found that after I reloaded the newest (in my case) any Microsoft net Framework (it happened to be version 4.5). After installation of the version 4.5 net Framework, all of my charging issues disappeared....Now my AC adapter LED is showing white as it used to a while back. I didn't go through the additional cost of buying a new battery or an AC adapter as a lot of other users had. I just knew that mine were fine...The battery and the AC adapter were good one day and the battery stopped charging another.....It didn't make sense that the hardware was at fault....I hope this helps some of you out there.....Just make sure that the Microsoft  .net Framework is installed. Even if it is installed, right click on the software in "programs and features" and choose "repair" when the option comes up to remove it, repair it. Good luck......

  • See my post on 0626/2013. I have the same laptop.....same issue.....and found what I needed to do to permanently fix the issue with my lack of charging the battery. All of my hardware was good...battery and AC adapter. Re-install the Microsoft .net Framework. The newest is version 4.5.....It fixed mine, works fine now, charges fine now.....try it.

  • Same thing for my Studio 1747.  It had a working battery and charger, runs ok on charger, but three months ago, the battery stopped charging.  I only ran it on the battery alone when I absolutely had to for a couple of weeks, but each time the battery just discharged and would not recharge. 

    I have done all the diagnostics, and they all say everything is fine.  There's one in the F12 set I can't do, because it has to be done with charger disconnected.  My battery has stayed at 0%, so the computer cuts out if I unplug the (Dell 19.5V 4.62A WK890) charger.  I've tried all the remedies I can find (new bios, disconnecting, running on 'hibernate', etc.).  I hadn't tried this, so got excited when i found it yesterday.  But now I have brand new 4.5.x Microsoft Net Framework files loaded, and the problem is unchanged.

    Please does anyone have any ideas?  Where is the software that manages the charging?  Is there a way I can reload that?  (I have checked all drivers are up-to-date, of course).  Many thanks!

  • Hi. I have, same laptop, same problem. Net framework 4.5 installed and 'repaired'. All to no avail. Am I right in thinking that if it is charging then the white light flashes and when not charging the yellow light is on continuous? When I plugin the charger I get a brief 3 white flashes and then steady yellow. Says it is connected and charging but clearly it is not charging. Bought a new battery and now that one is also flat!!

    How frustrating. Is it a software issue or could maybe a small cable be disconnected? I've had this laptop completely dissassembled to do some repairs since buying it a couple of months ago. Working fine now except for this problem of inability to charge the battery - even though it says it is charging.

    Anybody any ideas? Please!!