DELL INSPIRON 15R 5520 - SOME KEYS NOT WORKING PROPERLY

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

DELL INSPIRON 15R 5520 - SOME KEYS NOT WORKING PROPERLY

This question is not answered

HELLO, i have a dell inspiron 15r 5520 laptop... some of the keys like quote( " ) key, negation( ~ ) key  are not working properly.

- I have to press them twice to  print these symbols and they are printed twice.

- BUT these keys are working properly in ubuntu os in VMware virtual machine...is this a problem in windows 7 HB os??

- Also, i m having problems in installing Games...its showing some dll file of directx9 is not available...but i checked, its installed in my system.

Thanks

All Replies
  • Hi sor09,

    You can try the following steps to have the issue fixed:

    Go to Start menu, Right click on Computer/My Computer and select properties. Select Device manager from the Properties box. Once the Device manager box opens, locate Keyboard and uninstall by right clicking on it. Restart the system and check if that has fixed the issue.

    I hope this helps.

    Please let me know in case of any other queries.

    Thanks and regards
    Harish R
    #iworkfordell

    Thanks and Regards,
    Harish R
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • I have exactly the same problem on my new Inspiron 7520.  I tried the suggestion to uninstall the keyboard drive and it still doesn't work.  I also got a new keyboard from Dell and the problem is still there.  Other suggestions?

  • Just found the answer in a Windows 7 Forum - AFTER Dell went to the trouble to replace my keyboard which didn't work. The problem is the system defaulted to a US - International keyboard layout.  Click on the Language Bar down by the System Tray on your screen and change it to plain "US" without the "international".  PROBLEM SOLVED!

  • I'm having that same issue!!  I tried did as you suggested, removed the US International, but I'm still having the same issue!  It's so frustrating!   Is anyone else still having the issue?  Also, when I get frustrated with it and keep trying to type the quotations, the cursor will jump to a different part of the screen or delete what I just typed or put a letter with 2 dots over it. 

    Help!!!! 

  • Hmmm...Go into Control Panel / Region and Language / Keyboards and Languages Tab.  Make sure the English (United States) - US is the Default input language.  Then in the box below, make sure English / Keyboard / US is the only one defined.  Remove the International one.  That worked for me at least...

  • Thanks.  I did that and I think the quotation key is working now.  But did you have any issues with, as you are typing, the cursor moves to someone in the text randomly?  Sometimes it will delete a letter or two, sometimes a word, and in one instance today it deleted an entire paragraph of an email I was composing.  Steam came out of my ears!  LOL!

  • On mine, I've noticed the touch pad is VERY sensitive.  I've tried to dial it back using the option in the control panel but it just doesn't seem to work quite as well as my old Inspiron.  I actually think the problem is on the new Inspiron the touchpad is considerably larger so my thumb/palm area of my hand hits it and the cursor jumps.  It is indeed frustrating.  I usually have an external keyboard plugged in while in the office, but on the road I fight it and have had to learn to keep my palms up.  Definitely not handy.

  • I was just about to call Dell on this issue when I found this post. Your suggestion worked like a charm. To anyone reading this, make sure to close and reopen the program that you are using for the change to take effect. Thanks, Joe

  • Awesome - glad it worked!

  • Yep...I finally got things working by both changing the US setting AND decreasing the sensitivity of the touchpad...it was picking up every little movement of my wrists!  

    Thanks everyone!  

  • Work fine. thank you. Big Smile

  • Thank you so much for this. It drove me to the point of insanity before I finally saw this! Everything is working fine now.

  • Glad that solved it.  Yeah, it was fairly maddening before!  I still think the touchpad is still a little too sensitive but I can't seem to adjust the sensitivity enough.  It's either too sensitive or not enough. :(

  • One more note of appreciation for your posting.  I experienced all the problems listed above and was wits end until I came across your suggestion. Made the changes and now my laptop is working just fine.

  • Glad to hear it worked!