E5500 Not charging battery

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

E5500 Not charging battery

This question is answered

I have a Dell Lat E 5500 - It has been running great for 3 years. Suddenly it says the adapter cord is plugged in, but it is not charging. I have tested this with 2 diferent batteries I got and get the same thing. It just is out of the blue

I also get a warning when I boot up about not being able to recognize the AC Adapter. Not sure what is causing this. Really frustrating.

Please help!!

Brian

Verified Answer
  • Try another Dell adapter - if that doesn't solve the problem, the system needs an internal repair (power jack or mainboard).

All Replies
  • Hi Brian,

    I would advise you to update the system BIOS to resolve this issue.Before flashing the BIOS please check the following:

    • Battery should have 10% charge
    • Adapter should be connected
    • No external devices should be connected.
    • All other programs should be closed and documents saved

     You can download the latest BIOS from the following link: http://dell.to/NEjTnH
    Once the BIOS is updated, the system would restart. Check the status of the battery to see if it is getting recognized.
    If you are still facing issues. Please check in BIOS if the AC adapter is getting recognized. Follow the steps below to check AC adapter in BIOS, you will have to use the up and down arrow keys on the keyboard as the mouse won't work in BIOS:

    1.         Switch on the system and tap on F2 on the Dell logo.
    2.         Under Settings go into the Battery information tab
    3.         Check the battery health and also check whether it is detecting the AC adapter as 65W or 90W.

    If the adapter is not getting recognised you will find a load defaults tab on the bottom right corner use it to load BIOS to defaults.

    Hope this helps.Please reply if you have any questions.

     

    Thanks & Regards,
    Dell_Abhishek_B
    #IworkforDell
    To learn more about Dell Products, Services, and Drivers, click Here

     

  • I did the BIOS update, which it needed anyway, however it did not do the trick. When I went into the BIOS settings it said it did not recongize the AC Adapter.   I tried unplugging it and replugging it back in and no luck

    HELP!!

  • Try another Dell adapter - if that doesn't solve the problem, the system needs an internal repair (power jack or mainboard).

  • I am hoping to have a Dell Adapter tonight to try out. Will let you know

  • Got an another Dell AC Adapter and it worked perfectly. Ordered a new one for me from Dell just a few minutes ago.

    Thanks for the help!!

  • Hi i to have a dell latitude E5500 

    It stopped charging the battery recently so i tried another as i taught my one was dead but it wouldn't charge this one either but both would charge in my friends laptop. I then noticed it wasn't recognising the power adapter so i tried four different dell adapters all of which work in other dell laptops but mine would not recognising them. I then bought a new power jack board as i taught the DC jack plug looked a bit worn but this still made no difference.

    Now i have 0% on my battery and power adapters that cant be recognised the only thing i didn't try was as you said a Bios update. But is this possible with less then 10% charge on my battery ? And unfortunately the only person i know that has the same laptop has moved out off the country

    Please Help I don't know what to do next

    Thanks James

  • If you've already tried multiple Dell adapters and replaced the DC jack, all that's left is the mainboard -- that is faulty;  replace the mainboard.

  • Would it be worth trying to get another battery 1st to try a bios update?

    and is there anyway of testing the mainboard no?

  • The presence or absence of a battery won't affect the detection of the AC adapter - if it's not sensed, and you've tried a new Dell adapter and replaced the power jack, you've done all the testing  you need to -- the mainboard has to be the faulty part.

  • Great Thanks

    Im kind of new to all this but if i swap the main board will i lose files or programs ? and is it just a straight swap and it works or do i need to reinstall or setup anything ? sorry to be a nonsense