Studio 1558 won't power on


Laptop computer Forums (Audio, General Hardware, Video)

Studio 1558 won't power on

This question has suggested answer(s)

With battery or without, with power cord or without, changed power cord to one I know works.  Battery tester meter shows battery is fully charged (all 5 lights light).  Nothing happens when I press power button.  When I plug in charger, the white light glows for a second and then goes out.  I can't remember if this is what it does when the battery is fully charged.  The laptop is two years old this month.  Of course it's no longer under warranty.  Something else lately--not sure if this is related or not--system time and date were wrong when I was able to use the computer. 



All Replies
  • Hi,

    Welcome to the Community.

    The laptop is not powering on even when you use the battery or use it with the ac adapter. I would suggest you do a flee power first by removing the ac adapter and battery, then hold the power button down for 1min to release off any static power in the motherboard. Once this is done try to plug in the ac adapter and turn on the laptop. If the laptop turns on, go to BIOS and check the battery status.

    Please reply if anymore queries.

    Thanks and Regards


    Dell Social Media Responder  


  • Thanks for your suggestion, but even after doing this, it won't respond.  Do you have any other ideas?

  • Hi,

    If the laptop is still not powering on,i would suggest you to try using a different ac adpter in a different power plug.And this time when you do it,try to take the battery out and use the laptop only with the ac adapter plugged in.Try also to wiggle at the point the adapter is plugged in.

    Please reply if anymore queries.

    Thanks and Regards


    Dell Social Media Responder

  • Hi, Is there a resoultion to your problem? for last 3 days, I have the same problem with my Studio 1558.. Its not turning ON.. :( Any help would be highly appreicated. Thanks

  • I have tried both of your suggestions, and neither one of them has worked.  I left the computer on at 5:30pm.  I tried to turn it back on at 8:30 and it wouldn't come on.  I let it charge for an hour, and it still didn't come on.  Then the charging light went out.  Please provide some guidance as to how to proceed.

  • Hi cshulte,

    You can drain out the residual power by following the steps below:

    • Power off your computer.
    • Please remove the AC adaptor and battery of your computer.
    • Press and hold the power button of your computer for 10-15 seconds to drain out the residual power.
    • Release the power button.
    • Insert the battery in and connect the AC adaptor.
    • Then try powering on the computer.  

    If the issue still persists, check the status of light on the system and the AC adapter. You can also try is to try using an alternate AC adapter and see if system powers on. Another step you can try is to remove the battery and connect the AC adapter and try powering on the computer. See if it works.

    Please share the findings. 

    Thanks and regards,
    DELL-Chinmay S
    To know more about Dell’s products, services and drivers & downloads, please go here

  • Hi there,

    as of yesterday I am experiencing the same problem. searched google for some tips but no suggestions with positive results. there is a quite a few people around trying to wake up their dell notebooks. staff from dell seems to turn a blind eye on this issue. dear mr. dell, could you please look after your existing customers or you will start losing them quickly.


  • After trying everything on this message board, the Dell website, Google, etc., I opened up my Studio 1558 and popped out the coin cell battery.  I found a replacement at CVS for about $3.99, inserted it, closed up the computer, and it hasn't done it since.  I don't know if this will help you, but it's worth a shot.  BTW I am no expert at disassembling a laptop, but I was desperate! 

  • I had the same issue with my daughter's Studio 1558 after it was 2 years 2 months old. I replaced the coin battery as someone suggested but nothing changed. My symptom was that I'd insert the power adapter cable into the laptop and the charge light would glow for about 1 second and then turn off - probably because the battery was fully charged. i could verify the status of the battery by  pressing the button on the battery - all 5 lights glowed indicating a full charge.

    Her laptop has a lighted keyboard which clued me into what the problem was. I noticed that both hindges for the monitor were cracked on the rounded part, so I wondered if there was something lose or wrong with the connection to the power button. I slowly moved the monitor up/down while holding in the power button and noticed the keyboard flash on very briefly. I then tried to find that spot where the keyboard lit up. Once I did, the computer booted up.

    So in general, there is a lose connection that causes the power button not to be recognized. Once we find the sweet spot, the button works and it powers up and the computer keeps running no matter what position the monitor is in. So it only seems to affect use of the power button and once it's running, things are fine. I'm not sure if I'll take it apart and see if I can fix that lose connection. Perhaps I'll do that once it dies for good.

    She said the cracks appeared within the 1st year, and the boot problem just started happening at about the 2 year mark. I'd say that's kind of a weak point with this laptop - poor craftsmanship. I have several Dell laptops for work that I've used for 4 or 5 years (some are Latitude 830's). I've traveled all over the world with one for 5 years - it took a beating, has a cracked case, a hole in one corner from when I dropped it, yet it still runs fine. So I suspect this issue with my daughters Studio 1558 is a design flaw in that computer - not necessarily every Dell.

    My company has since switched to Lenovo for some reason. Those computers seem fine and I've traveled with them. Not sure about durability yet. I just hate where they placed the Function key - non-standard compared to everyone else in the world. Extremely frustrating for someone who works with both Lenovo and other brands at the same time. If I only used Lenovo I guess I'd get used to it, but it drives me crazy!!!!!!!

    Hope that helps some of you... good luck!

  • I have had the same problem as stated above with my Dell Studio 1558; the laptop would not turn on whether the battery was in place or not. Plugging the power adaptor in resulted in the little white LED above the socket flashing on for about a second and then nothing. There was also a barely audible squeal from the under-side of the laptop. Having read that a loose connection may be the cause, I stripped my laptop apart (using a good YouTube video guide) and found no obvious issues, cleaned everything, re-assembled and hey presto it worked. For the record, my coin cell battery was dud at the time (the laptop would lose the date and time settings if the main battery was allowed to run flat) and my main battery was on its last legs too. Sorry it’s not a definitive solution but it does go to show that it might not be the motherboard as many people seem to advise.

  • Hi ,

    I have had my Dell studio fixed since I last posted and yes, it was the motherboard. Now is my baby up and running again!!!!!!!!!!!!!!!!  

  • First post on Dell! I just bought a Dell 1558 on ebay "For parts or not working" the seller saying that he sold it working but the buyer returned it because it didn't work. I received it and found that it had the same problem a previous poster mentioned - charge light comes on one second and a slight squeal from underneath. I tried everything here including the CMOS battery and then it occurred to me that the squeal sounded like the disc drive so I stuck the utility DVD in. Nothing happened so i went for a smoke and when I came back to my surprise the screen lit up! It quickly went to a BSOD (Blue Screen Of Death) but at least I knew something was working. When it restarted I hit F12 repeatedly and "BINGO!" I am in. So I now have a nice laptop, but one question - the WWAN module is missing. Is this important to have or at least worth having?

    "Knowledge is cheap at any price"