SpeedStep on Inspiron N4050 (bios A07)

Laptop

Laptop
Laptop computer Hardware and Software discussion

SpeedStep on Inspiron N4050 (bios A07)

This question is not answered

Hello. I have Dell Inspiron N4050 (i3-2330M, Radeon HD6470M, 4Gb RAM, 320Gb HDD) and it seems that changing Intel SpeedStep option in BIOS  does not really change anything for CPU. By default this option in BIOS is Enabled and as i can see in CPU-Z processor's multiplier changes dinamically.

But if i set IntelSpeed step to disabled it does not take affect on CPU and CPU's multiplier continues to change the same way.  

I would like to know how to disable Intel speedstep and have constant high multiplier but now this option does not take an effect (Maybe it is BIOS's fault, since i updated it to A07). Thanks

All Replies
  • Disabling SpeedStep will cause the system to run at its lowest speed.  It's turboboost that raises the clock speed.

    Before you try the following, realize that it WILL appreciably shorten the lifespan of the system - which is not designed to handle the heat produced by running the CPU at high speed all the time:

    Try setting the performance profile (in power management) to high performance.  That should let the CPU run at top speed (before Turboboost) all the time.

    As above, it WILL reduce the life of the system board and hard drive drastically to run the system this way, and the heat produced may cause stability problems.

  • >It's turboboost that raises the clock speed.

    Turboboost is not supported on i3 processors, so i cant try it:) . i3-2330m High performance profile also does not fix multiplier

    Anyway thankyou :)