XPS 13 wifi won't connect automatically

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

XPS 13 wifi won't connect automatically

This question is not answered

XPS 13

This is a new problem. I am using an Apple Time Capsule/Airport as router, but it happens with all wi-fi connections. I have not changed any settings, and the network is saved and set to auto-connect.  It does not though.  I have to manually select and click connect, then it eventually does.

Could it have to do with the drivers for my ethernet dongle? 


Help?

All Replies
  • Hi pdan,

    Welcome to the Community,

    It could be an issue with the driver.However first try deleting all the wireless profiles,under Network and Sharing Center,Manage Wireless Networks.After deleting all the wireless profiles,reconnect the system to your wireless network manually,after it is connected,reboot your system and check if the system connects to your network automatically.

    If it still does not connect automatically,uninstall and reinstall the wireless card driver.

    Use the link below to download and reinstall the wireless card driver :

    www.dell.com/.../DriverFileFormats

    Hope this helps,

    Thank You

    Dell | Social Media Outreach | Global Social Media & Community




  • I have tried all of that.   Nothing works.  I am at the point where I will probably just return my Dell XPS 13 and get a MacBook air, which connects the instant you lift the lid.

  • Hi  pdan,

    Sorry to know you're still having issues with the wireless connection.To help you further please access Device Manager(Control Panel,System,Hardware),expand Network Adapters,right click on the wireless card,click properties,click on Driver tab.

    Post back the type of wireless card(Example Intel Centrino Advanced-N 6230 ),driver date and driver version listed.

    Dell | Social Media Outreach | Global Social Media & Community




  • I have 3...

    Microsoft Virtual WiFi Miniport Adapter

    and

    Microsoft Virtual WiFi Miniport Adapter #2

    Also

    Intel Centrino Advanced-N 6230

  • Hi pdan,

    Since you have not mentioned the driver date and driver version I would suggest to follow the steps below to uninstall the current driver and than reinstall the latest available driver :

    Before uninstalling download and save the driver from the link below :

    For XPS L321X(Release Date: 9/4/2012 ) : www.dell.com/.../xps-13-l321x

    To uninstall go to Device Manager,expand Network adapters,right click on Intel Centrino wireless card,click uninstall,put check mark for delete driver software,click OK.

    Reboot the system,go to the location where you had saved the driver and reinstall it.

    After reinstalling the driver try the Intel Recommended settings for 802.11n connectivity :

    Start, control panel, device manager. Click on Network and then right click on your wireless adapter, left click properties, power management. Uncheck the box, allow computer to turn off this device to save power.

     

    Than as suggested by one of our forum Rockstar RICK, go to power options, and change the Wireless Adapter Setting, from Maximum Power Setting to Maximum Performance.

    Let me know how it goes.

    Thank You

    Dell | Social Media Outreach | Global Social Media & Community




  • None of this helped.  I still have the same issue.  It takes the laptop up to 2 minutes to connect on its own, if at all.  Even when I view the wireless networks, and force connect to one of them, it takes up to 1 minute to connect.

    It seems tons of people are having this problem online, with no solution.  Dell really needs to get their act together on this and provide a proper solution.  I am about to get rid of this ultrabook and buy a mac, which connects instantly within a second.

  • 1/25/14

    Did you ever get this problem resolved?

    I've had the same problem....and hoped that perhaps the upgrade to W8.1 might help....not so.

    Quite frankly I get so angry and punch so many buttons...I don't know how I get connected eventually..

    I think my power setting is set so that the HD never goes to sleep..