Forums

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Problem with dell inspiron n5050 trackpad

This question has suggested answer(s)

The track pad is soo annoying with tis laptop .....the cursor keeps on jumping from one place to other couldnt click on the exact place where v want to.........soo irritated with the trackpad.........

All Replies
  • Hi Danny Samuel,

    Welcome to Dell community.

    The issue seems to be with the touchpad driver.

    Please download and update the touchpad driver from the below link :

    http://dell.to/sCpz1d

    The touchpad driver would be located under Input devices as Alps touchpad driver

    Please restart the system after the update and then check.

    Please let us know if it helps.

    Glad to help.

    Thank you.

    DELL_Ritesh G

    Dell |Social Outreach Professional | Global Social Media Community

  • Hi Danny Samuel,

    Welcome to the Dell Community.

    I would request you to follow the steps mentioned below:

    Step 1: Update the touchpad driver and the system BIOS. The Links are as follows:

    www.dell.com/.../19

    Kindly choose the system model and Operating System and download the latest Touchpad driver and BIOS on your system.

    Kindly reboot the system after updating the above drivers and check for the normal system functionality.

    Step 2: Kindly change the touchpad sensitivity according to your requirement. The steps are:

    Kindly change the touchpad sensitivity according to your requirement. The steps are:

    1.      Turn on the computer and log into Windows as normal. Open the "Start" menu and click on the option labeled "Control Panel."

    2.      Double-click on the icon labeled "Mouse.". The "Mouse Properties" window will open and it will have a touchpad option. Open the touchpad option and navigate to the tab labeled "Device Settings." Click on the button labeled “Settings." A window labeled "Properties" will appear.

    3.      Examine the left panel of the "Properties" window and expand the option labeled "Sensitivity." Click on the option labeled "Touch Sensitivity."

    4.      Reduce the touch sensitivity setting by moving the slider to the right, towards the "Heavy Touch" label. Experiment with different levels of sensitivity until you find one suited to your needs.

    5.      Click on the button labeled "OK" to close the "Properties" window; repeat with the "Mouse" control panel. Your new touchpad sensitivity settings are now saved.

    6.     Kindly reboot the system and check if the mouse works fine.

    Thanks and Regards

    DELL_Abhishek_ B

    Dell Social Media Responder

    You can reach us at: www.en.community.dell.com

    Thanks & Regards,
    Dell_Abhishek_B
    #IworkforDell
    To learn more about Dell Products, Services, and Drivers, click Here

     

  • A benefactor supplied my educational institution with five Dell Inspiron N5050 laptops. Every one of them has a terrible touchpad. The either do not sense movement or jump erratically around the screen. This problem was evident from the first use out of the box. The advice presented above makes absolutely no difference to the erratic and poor nature of the control offered by the touchpad. Do you have any other solutions to the paucity of the touchpad?

    Thanks,

    Munky

  • Hi munkyennui,

    I understand that you have tried the above steps, please help me understand the issue. I will research for more options to work on this.

    1. Have you updated the BIOS?

    2. Did you install the touchpad drivers?

    4. Was the operating system installed/reinstalled for the same issue?

    4. Did you run diagnostics on the touchpad and if so please provide the error?

    Thanks & Regards,
    Nikhil D
    #iworkfordell

    To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; India Customers. For Dell Support videos click Here

  • Hi.

    I've exactly the same problem here! This is very annoying, I'm so sick of this touchpad!! It keeps jumping and jumping arround the screen. I can't use it with the keyboard simultaneously!

    I have to turn off the Touch Check in order to use it with the keyboard and I've to do it because I'm playing Minecraft!

     

    This is a driver issue, I had it in an Acer Laptop and I called Acer and the driver update works perfectly!

     

    I've installed the Touchpad driver from Dell Website and my System BIOS is A05! Please help me, I'm so sick of this laptop, I should bough an HP Computer... Dell never again!

  • Received mine 2 weesk ago and have exactly the same problem. 

    In addition the touchpad will "right click" all on its own and the mouse pointer just stops on the screen abd won't move agai n even after a reboot.  I have to re-install the driver to get it to work again.

    I have raised a ticket with Dell and plan to phone technical tonight but I don't hold out much hope.

    Is there really no solution except to use a normal mouse which works fine.

    If it is a recognised problem then I may be demanding my money back.

  • This won't work, I have the same issues with my 5050, I went through all of this with "Tech Support" and i'm still having issues with my laptop.  Updating the BIOS does nothing as well in fact everything that they suggest doesn't work.  What they'll do is remotely take control of your laptop and make it seem like they're doing something, don't be fooled they have absolutely no idea.  

  • Hey, I know this was posted a while ago but for anybody else who is having similar problems... You will see lots of posts about driver updates and flashing your BIOS but that won't solve the problem, it is much simpler than that (however I still recommend keeping your drivers and everything up to date) it is simply a matter of changing one setting. The laptop comes with this interesting and potentially useful feature that destroys all hopes of playing games using the trackpad called TouchCheck. This feature disables the touchpad while you are typing to prevent the occasional accident of bumping the touchpad while typing. You simply have to disable this feature and your problems will be solved! To access this setting go to "Control Panel"  go to the "Mouse" settings and click "Dell Touchpad Settings" In these settings go to "Touchpad Settings" and uncheck the "Enable" box below "TouchCheck" Click OK and enjoy your games!

  • hi 

    i am facing a issue on my laptop and its quite wired like every time i restart my laptop i do not get display but there is no problem with my display or my laptop i figured out that in order to get display i have to put my laptop on sleep mode after restarting the after that when i wake it up i get display ... or i have to close the lid n then open it again to get display why am i facing this kind of issue with my laptop i am using inspiron n5050

  • I have the same issue. Try to not shut down your unit with the brightness low... Keep it in max and you wouldn't have that problem again...

  • Thank you!! Worked perfectly. Turned off all of the other features too, like pinch to zoom, three finger scrolling, etc., just in case, but this solved my problem. 

    the.m3ddl3r

    Hey, I know this was posted a while ago but for anybody else who is having similar problems... You will see lots of posts about driver updates and flashing your BIOS but that won't solve the problem, it is much simpler than that (however I still recommend keeping your drivers and everything up to date) it is simply a matter of changing one setting. The laptop comes with this interesting and potentially useful feature that destroys all hopes of playing games using the trackpad called TouchCheck. This feature disables the touchpad while you are typing to prevent the occasional accident of bumping the touchpad while typing. You simply have to disable this feature and your problems will be solved! To access this setting go to "Control Panel"  go to the "Mouse" settings and click "Dell Touchpad Settings" In these settings go to "Touchpad Settings" and uncheck the "Enable" box below "TouchCheck" Click OK and enjoy your games!