Dell Vostro 3550, All USB ports non-functional - General Hardware - Laptop - Dell Community

Dell Vostro 3550, All USB ports non-functional


Laptop computer Forums (Audio, General Hardware, Video)

Dell Vostro 3550, All USB ports non-functional

This question is not answered

I currently own a Dell Vostro 3550, and have done for just over a month, but I noticed a few days ago that all of the USB ports, even the eSata port which supports USB, had stopped working completely, I have checked the device drivers in device manager and it says that everything is working fine, and USB ports are also activated within the BIOS setup.

All Replies
  • Hi Connor2524,

    Welcome to the Dell Community.

    In response to the above issue which you have brought to our notice, we do apologize for the inconvenience, Please try the following steps

    Disable and re-enable the USB controller

    Use Device Manager to disable and re-enable all the USB controllers. This lets the controllers recover the USB port from its unresponsive condition. The USB controllers represent the USB ports in Device Manager.

    To disable and re-enable the USB controllers, follow these steps:

    Click Start, and then click Run.

    Note If you are running Windows Vista, Windows 7, click Start, and then use the Start Search box.

    Type devmgmt.msc, and then click OK. Device Manager opens.

    Expand Universal Serial Bus controllers.

    Note You might have to scroll down the list to find this item.

    Right-click the first USB controller under Universal Serial Bus controllers, and then click Uninstall to remove it.

    Repeat the step mentioned above for each USB controller that is listed under Universal Serial Bus controllers.

    Restart the computer. After the computer starts, Windows will automatically scan for hardware changes and reinstall all the USB controllers that you uninstalled.

    Check the USB device to see whether it is working.

    Adding to the above steps you can also try downloading chipset drivers, find below the link to download the same which is specific to your system model.

    Please try the above steps & revert if you have any questions.

    Thank you,

    Hari R

    Certified Dell Community Professional

  • I have a client that is experiencing similar. USB keeps blue screening machine.

    I have done a lot of testing on the machine and it does not matter what is conected, camera, printer, mouse. Irt keeps blue screening.


    Is there a known issue with this model?

    We win a few, we loose a few

    But we enjoy the battle.

  • I think there may be a known fault, as there are a lot of people with the same or similar problems, luckily I got mine working again, I advise that you uninstall ALL of the USB drivers from the device manager, and restart the computer, the PC will then detect the ports as new devices, but it may keep blue-screening for one or two days afterwards, just ask the client to use the PC as normal during this period


  • I just got another one. They replaced the board and still getting RAM error after changing 4 different new RAM sticks. It also only works with 1 usb port. If you connect a second port it won't install anything. Getting USB controller error. I did update the chipset and Bios. Still no go. Dell is replacing the board again. I have 4 more of these machines hope they will not all be like that.

    We win a few, we loose a few

    But we enjoy the battle.

  • I currently own a Dell Vostro 3500, which worked fine for the first 6 months, but recently all of the USB ports have stopped working, they will charge my mobile if I connect. I have followed all of the requests to remove the USB controllers, then power up the laptop to re install the drivers etc, but all fail to bring the USB's to life.

    If I plug in a memory stick windows 7 does not recognise anything. When I first owned the laptop, if I plugged in a memory stick or camera it immediately opened a dialog box to import or view files.

    Does anyone have any ideas

  • Do they work outside of the OS.   If so, that rules out hardware.

    Inside the OS -- delete and recreate root hubs, then restart

    also, you can try to see if you see if you have the problem in Safe Mode -- if you don't, go after Malware, Startup Programs, non-windows drivers, non windows services, malware....

  • Thanks for the reply, how do I check it outside of the OS.