BIOS flash issue


Laptop computer Forums (Audio, General Hardware, Video)

BIOS flash issue

This question has suggested answer(s)

A few days ago I flashed  to BIOS a10 on Vostro 3700. Since then battery charging is disabled. laptop will boot with battery removed. Swapped battery still no charge.

Unable to downgrade to A09. Unable to re-flash a10. need to either rollback or factory reset bios. Any assistance would be appreciated.

Not happy today.

All Replies
  • before you despair do the normal troubleshooting - just pretend you have never updated the BIOS......

    I assume that battery and power adapter are 100% Dell compatible

    > check if the BIOS detects the power adapter - press "F2" at powerup

    > if adapter is not detected it could be the power adapter itself,the power jack or mainboard/BIOS

  • Hi smartineau1,

    Welcome to community,

    Enter BIOS tap F2 at start up (Dell logo),check if AC adapter is getting detected normally.Under Main check AC Adapter Type,does it show unknown or 65 or 90 watt ?

    Try to restore BIOS to default settings.Press F9 to set up defaults and than press F10 to save and exit.

    Thank You

    Dell | Social Media Outreach | Global Social Media & Community

  • Yes OEM adapter & Battery plus a generic replacement battery (neither will charge).

    @ f2 - AC Adapter type = 65w, so it appears to be recognized.

  • post f9 reset, upon reboot a message saying the 65w adapter is wrong. but it was the OEM adapter with the machine. I'm puzzled

  • is f9 in setup intended to simply reset to default settings or rollback to factory BIOS a01? post f9 BIOS remains a10 & not reverted.

  • F9 in set up will just restore the default settings in BIOS.It does not revert or change the BIOS to previous version.

    The replacement battery is that 9 cell or 6 cell?

    Dell | Social Media Outreach | Global Social Media & Community

  • Bought the replacement battery over a year ago, pretty sure it's a 9 cell. physically larger than the OEM and longer usage time too. I've removed the replacement & inserted the OEM battery, no change in function - not charging.  All was in fact functioning properly last week. Thought the left side around the power port felt too hot. the cooling fan would only spin up when there is a lot of heat, not just warm but hot to the touch. Did the obligatory trouble shooting a realized the BIOS was a01. Flashed to a10. yesterday battery power was low, plugged in - not charging.

  • Hi smartineau1,

    I came across a solution which has worked on different system model,however you can try and see if it works on your system model.

    Try the steps below:

     Step 1: Disconnect AC adapter (charger)

     Step 2: Shutdown system

     Step3: Remove battery

     Step4:Connect AC adapter

     Step5: Turn on system (only with AC adapter plugged in),login to windows.

     Step6:Go to Control panel,Open Device Manager,Under the Batteries category, right-click all of the Microsoft ACPI

                 Compliant Control Method Battery listings, and select Uninstall (it’s ok if you only have 1).

     Step7:Shutdown system

     Step8:Disconnect AC adapter,reconnect the battery and plug in the AC adapter,turn on system normally.

    Let me know if this helps,

    Thank You

    Dell | Social Media Outreach | Global Social Media & Community

  • That did not correct the issue

  • smartineau1

    In one of your previous post you wrote the system says that the " 65W adapter is wrong" that indicates to me that the BIOS is able to communicate with the power adapter via control wire.If the message were "adapter unknown" it would be a different story.

    Anyway - it might be possible that the new BIOS version wants to see a 90W or 150W power adapter because the programmer of the BIOS inadvertently activated  the wrong settings.

    I know it's all speculation but such stuff happens - I would at least try a different adapter.

  • Hi smartineau1,

    Apart from trying a different adapter, if you have access to another system of the same model,try charging your battery on that system and put it back on your system and see if it starts charging normally.I see some users with similar problem tried that  and it worked (I cant explain how it would work but it has been tried and has worked).

    Thank You

    Dell | Social Media Outreach | Global Social Media & Community

  • I tried another adapter to no avail. I have no similar models to attempt a battery kick start. I do think is has to do with the BIOS flash. So my original question stands, how do I revert to a previous BIOS version, which are, in fact ,provided on the Dell driver support page.

  • Sorry, I missed an earlier post concerning the 90w adapter. I'll purchase one today that may work

  • You need to be careful with spending money.Whenever possible try to borrow parts from friends ,colleagues etc... first !

  • The new 90w adapter arrived about 4 hours ago. One battery charged, the other charging. It would seem that BIOS a10 requires a 90w adapter while a01 accepted the 65w adapter, as was suggested a few days ago. The final question is, why was the OEM adapter only 65w when it should have been 90w? I feel, somehow, violated.

    Thanks for the help, it is appreciated.