Line-ish interference on U2412M when laptop is plugged in to power

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Line-ish interference on U2412M when laptop is plugged in to power

This question is not answered

Hello!

I have a small issue. I have a laptop that is connected to my brand new U2412M over VGA. When my laptop is plugged in (grounded) I get quite a lot of interference (lines that flicker/vary), depending on the image I'm viewing.

I tried to get a photo of it, you can sort of see the pattern (it flickers though) if you look from a bit of a distance:

When the laptop is running on battery the problem is not present. I've read that plugging the laptop on another outlet might help, so I tried plugging my laptop in to another outlet(in the same room). It greatly reduces the interference but it is still present.

What I'm wondering about, I've got a HDMI to DVI-cable on the way (delivery got delayed), would using HDMI/DVI/DP fix the problem no matter what outlet I use? Is there anything else I should do? Is there something wrong with my monitor?

Thanks!

Ambroos

All Replies
  • It sounds like the laptop AC adapter is creating a ground loop which triggers the issue. Try plugging the laptop AC adapter into a surge protector.

    (Liaison for Desktops, Alienware, Monitors)
    #iwork4Dell
    Would you like to be a Dell Community Rockstar?
    Drivers
    Order Status

  • I tried it today with a surge protection thing I borrowed from my uncle, doesn't do anything at all...

  • Moving this to the laptop general hardware board to their thoughts.

    (Liaison for Desktops, Alienware, Monitors)
    #iwork4Dell
    Would you like to be a Dell Community Rockstar?
    Drivers
    Order Status

  • I've had a reply from someone on the Notebookreview forums, they say it's probably a 'ground loop', and there isn't much you can do about it. Fortunately, he said the problem would be fixed by using a HDMI/DVI cable. I'll just wait for that to arrive then!