Bluetooth mouse lag

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Bluetooth mouse lag

This question is answered

Could someone else confirm if they are having this issue as I am beginning to wonder if this is a design issue.

I have had problems with my Latitude E6520 which is paired with a Dell Bluetooth Black Travel Mouse - the lag on it at times is absolutely criminal - it can be 1 whole second behind, by which time you end up clicking the wrong item/link, etc.  It is driving me nuts!

Dell haven't been able to discover any issues, so sent an engineer to replace the Dell 375 Bluetooth Card.  The replacement card did not work at all so another engineer was sent to replace both the motherboard and bluetooth car.  This didn't work either, and it was left to me to work out that the bluetooth software needed to be completely uninstalled then reinstalled for the new bluetooth card to work.  I am now experiencing the same issue with the new mobo and bluetooth card, so the issue persists.

Perhaps it is a software issue?  This is why I would like to know if anyone else has experienced lag with their mouse on the E6520.

Thanks for any replies.

Verified Answer
  • Thanks for this - it was my issue...
    It's obvious when you read it here Huh?

All Replies
  • HoundofMeath

    I obviously got my posts mixed up on this one.  I apologize for that.

    Creating a new post at the bottom of the thread.

    TB

    (Liaison for Laptops, Mobile Devices)
    Look for me on Twitter and LinkedIn.
    #iwork4Dell
    Would you like to be a Dell Community Rockstar?

  • I just paired a Targus bluetooth mouse with a Samsung tablet PC--totally different hardware from yours. But my first impression was horror at the mouse pointer lag. The mouse pointer is jerky and delayed and not smooth at all.

    Checking the Internet I find many reports of similar problems with bluetooth mice on all sorts of hardware.

    My guess is that this is a generic problem with bluetooth and it's just not good for pointing devices. When browsing for wireless mice in the shops 95% of them are normal wireless (2.4 GHz) and only one or two are bluetooth. I can't help feeling there is a reason bluetooth mice are rare, especially since so much modern hardware has bluetooth built in. Why would you take up a USB port with a dongle if you didn't need to?

  • Here is a link for a basic troubleshooter on Bluetooth

    support.dell.com/.../document

    In this case it sounds like the mouse is fine and is able to pare with the system with no further issues.  The problem is in the curser lagging when using the travel mouse.

    You may have already tried this but I want to make sure.  If you use the Trackpad or and external USB mouse do you notice the same problem? If it is a possible software problem, then the same software could possibly interfering with all input devices.

    If Track pad or USB mouse works fine my next suggestion if possible will be to try other Bluetooth devices. To find out if it is only the mouse that is having problems or all Bluetooth devices.

    TB

    (Liaison for Laptops, Mobile Devices)
    Look for me on Twitter and LinkedIn.
    #iwork4Dell
    Would you like to be a Dell Community Rockstar?

  • I just got an E6420 running W7 32bit  4GB with built in WIFI/bluetooth radio...I have tested two Dell BT mice, one being a large older model and both show the same lag. 

    The mouse setup worked fine with my old D630 which had an inexpensive miniature BT dongle that uses Broadcom software

    As I am writing this post I finished disabling the onboard BT and using the BT dongle + software....It all works fine now.  I suspect there is a problem with the built-in Bluetooth hardware/drivers.

  • Thanks for the replies people.  

    GuillermoP62 - thanks for taking the time to give your experiences.

    I think Dell and Logitech (who manufacture this re-badged mouse) need to get together and come up with new firmware!  I have uninstalled the Logitech software from my laptop and this made no difference - lag is still there.  It has to be the drivers, no?

    DELL-Terry B - trackpad and external work fine.  Also, I have tried 3 different BT mice and issue persists with all of them.

  • Hello, I'm on a Dell E6520 and am experiencing the bluetooth lag on a keyboard! tested on other systems and do not have the problem. Something is up with Dell's bluetooth hardware or software.

  • Anyone have an update on this? The bluetooth issues on this laptop are very bad.

  • I also experience the same issues using a Logitech V470 travel mouse and Dell's own Bluetooth Mouse and Keyboard.  The laptop is a Latitude E6320 and the Bluetooth adapter a TrueMobile 375 module.  I did not have this issue on my previous E6400 laptop.

  • This problem can be resolved by purchasing a $2 mini usb bluetooth adapter off ebay. Don't ask me why a $2 adapter off ebay works flawlessly but dells business class does not!

  • Yeah, might have to go down that route scubadrew - just didn't want to use up one of my 3 USB ports is all.  I guess that's better than using a wired mouse which I can tell you doesn't feel very mobile!

    Would be nice if Dell could acknowledge that this is an issue.

  • I have this same issue with both an E6420 and E6430.  I have been going back with Dell as well with no luck.  The mouse worked fine on an older E5400 and it just refuses to work correctly on any newer models.  I have tried 3 different BT Travel Mice that Dell has sent me, but none worked.  We purchased a Microsoft Bluetooth mouse and that worked perfectly.  There has to be something wrong with the combination of the way the Ex4xx laptops are set up and the mouse itself.  I'll let you know if I get any more info from Dell.

  • I have purchased a Dell Travel Mouse D/PN: PU705; L/PN: 810-000866 and this is working with the internal truemobile 375 solution in place of my Logitech V470.

    I purchased this from ebay for 14.99 (new) rather than give Dell another 33 pounds direct given this issue is of their making (in my opinion). 

     I have also ordered a Logitech MX5500 keyboard and mouse for my office desk/dock configuration to see if that solves the issue with my existing full size Dell Keyboard/Mouse.  This situation is clearly a software/firmware issue.  Dell should be more concerned about this.

     

  • Interesting. I have a Dell (Logitech) BT 5 Btn Travel Mouse. Worked nearly all the time with my 6420, and my 6410 and 6400 before that. Main issue was intermittent refusal to pair, usually solved by un/reinstalling the BT stack.

    My new 6430 arrived this week. Hooked up the BT mouse, paired right away. "This is good", I thought - until I tried the mouse.

    Jerky, slow, with a mind of it's own about movement.

    I'm going to try un/reinstalling the stack with this new unit, but BT causes a lot of work for the convenience ...

  • Same here.  I've had my bluetooth mouse since 2007 (Microsoft Wireless Notebook Presenter Mouse 8000) and had about 4 different laptops during that time.  The mouse has worked flawlessly with all of them.  I have never had to use the USB bluetooth dongle that comes with it.  I've always used the built-in bluetooth.

    Yesterday I just got my 6430, paired the mouse with it and the lagging starts instantly.  This is definitely a firmware and/or drivers issue (at least) with this model.

    With technology, we all live/dive with bugs and issues as they arise.  No problem there.

    However Dell, it would be greatly appreciated if someone could at least acknowledge that there is truly a problem with your product.

    I'm not even pressing for an ETA on resolution...just a simple acknowledgement of the issue.

    Thanks!!

  • Which network card does your 6430 have? Mine is an Ultimate 6300 N. That card apparently has three internal antennas (other available cards have two or one) and I'm speculating that the card could be a source of the issue.

    I found an interesting thing - when the unit is in my docking station, lid closed, and wireless off, the BT mouse works correctly.

    I opened a ticket with Dell and will come back here and post if any resolution is found.