Disabling Dell touchpad on Inspiron N5110

Laptop

Laptop
Laptop computer Hardware and Software discussion

Disabling Dell touchpad on Inspiron N5110

This question has suggested answer(s)

Trying to disable overly sensitive touchpad.  Running a Microsoft wireless mouse through USB.  I can use hot keys and watch touchpad toggle on and be off in Control Panel but cursor continues to move under touchpad control.  Have uninstalled touchpad driver and touchpad still moves the cursor.  Tried downloading the Alps touchpad driver but install failed.  System has now installed a PS/2 mouse driver in addition to the wireless mouse driver.  And the touchpad still moves the cursor.  What else can I try?

All Replies
  • Hi,

    Welcome to the community

    What happened when you installed ALPS Driver? Was there an error message? Can you try installing quickset thru this link ; http://dell.to/HInYUY Then try using the hotkeys again. You can access Quick Launch Buttons to configure touchpad, (upper right part of the keyboard) Press the first button (the one with gears) and windows mobility will come out. Look for the option to enable/disable touchpad. If still nogo, try to view this link, it might help ;

    Hope this helps, let me know of the results, glad to help.

    Dell | Social Media Outreach | Global Social Media & Community

  • Elijah:

    Thanks for you reponse.  The Alps touchpad install aborted and I presume it is because this is a Dell touchpad?  At any rate, I did download the quickset driver array which succeeded in disabling the hot keys for the mouse but did not enable the touchpad disable function.  I have a piece of black foam rubber taped over the touchpad.  Works well but looks like  <ADMIN NOTE: Profanity removed as per TOU> on a new computer.

  • Hi,

    The Inspiron™ N5110 / 15R uses an ALPS® TouchPad which is Dell customized. Can you try to update your BIOS first then update touchpad driver ; BIOS http://dell.to/JOhx2m Alps ; http://dell.to/HKX1Sy  

    Dell | Social Media Outreach | Global Social Media & Community

  • I just had the same problem and this worked for me.

    Download and install the touchpad driver (R305170):

    www.dell.com/.../DriverFileFormats

  • Inspiron N5110

    Fn + F3

    Press and hold the <Fn>
    key, then press the <F3> key.

  • I have tried this however when I go to properties and driver I am unable to select disable.  Its visible but not highlighted so it can be clicked.  How do I change this or can i just uninstall?

  • Look at the previous post:

    Download and install the touchpad driver (R305170):

    www.dell.com/.../DriverFileFormats

  • I got tired of fighting it -- just uninstall the touchpad and use your USB optical mouse!!!

  • Yes! This worked for me! Thank you! Big Smile

  • Try holding the orange Fn key down and press F3. This should turn on the light on the touchpad indicating it is off!