[FIXED] Dell XPS 15 L502x [fan on, fan off, fan on, fan off...] on Windows 7 - General Hardware - Laptop - Dell Community

[FIXED] Dell XPS 15 L502x [fan on, fan off, fan on, fan off...] on Windows 7

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

[FIXED] Dell XPS 15 L502x [fan on, fan off, fan on, fan off...] on Windows 7

This question has been answered by JoshiKV

I recently bought a dell XPS L502x, I also had the same problem with the fan speeding up to full speed for a few seconds, then off again, then on again, then off again. I am using windows 7 home premium. This is only a issue on Windows, Ubuntu seems to work without any problems.

I have figured out a simple fix, seems to have worked so far and my fan just stays on at a slower constant speed. My CPU temps have stayed constant and within range.

1. Click the `charging` icon in your taskbar (By the clock) [The little power plug]

2. Click on `more power options`

3. Under the power setting you are using (Balanced in my case), click on `Change plan settings`.

4. On the change plan settings screen, click `Change advanced power settings`

5. Scroll down to `Processor Power Management` > `System Cooling Policy` (Expand them both to view the options).

6. Under `System Cooling Policy` > Change `On Battery` & `Plugged In` to `Passive`.

and... Tada!....The settings should take effect immediately, if they don't, a reboot should do it.

That's It! The constant fan ramping up and down will be fixed, and will just stay at a constant speed now!!

Hope this helps someone, cos it dam well annoyed me, I mean I bought a £750 laptop, Dell could have at least configured it properly to reduce wear and tear on the laptop.

Verified Answer
  • No answer required, it has already been posted. Unless you have a better solution, id love to hear it. Thanks!

  • I just signed in and post beucase I have the solution to this problem. After months, even installed Windows 8, the problem remained, until... do the following.

    With the computer off, blow on the ventilation slot, as hard as you can, with your own mouth.

    Yes, I'm not kidding. Blow many times, (and close your eyes and don't breath because a lot of dust will jump).

    Then, try.

    It will work like magic. At least for me it was the case.

    Jolo.

  • Thanks joloriquelme.


    What you suggested worked for me. I am sure this must be the root cause for all the people facing this issue. Everybody must try blowing air in to the ventilation inlets of the cooling fan. There is a small one just below the cooling fan. I found most of the holes were choked with dust. As soon as I blew air and cleaned it the 'on-off-on-off' cycle stopped. I also have applied the setting mentioned earlier but that did not work for me.

All Replies
  • No answer required, it has already been posted. Unless you have a better solution, id love to hear it. Thanks!

  • Do this have any adverse effect on performance? Will the fan still speed up when the processor is under heavy load? I'd like to try this but am worried that it may cause overheating?

  • My fan still speeds up when it gets hot (I was playing games a minute ago, and it was going at full blast), now im back in windows surfing and sending emails, the fan stays at a slow speed.

    So Yes, It seems that the fan will still speed up under heavy load,  (It just don't do it every 10 seconds like before).

  • Great!! Thanks!

  • Also, I just ran a Prime95 (Torture Test), which maxes out the processor, and the fan went full blast straight away, you can download prime95  by googling it, and try it yourself if your still worried, The fix works great and does not stress your Hardware in anyway, when it gets hot, your fan will kick it at full blast to cool down your processor!...

  • Cheers mate. Looks like "passive" is the best setting. Thanks once again.

  • Passive: This option will reduce the processor speed to reduce the temp. .. if after a while the temp. does not decreased, the fan will run.
    So this option is OK if you don't mind having the processor working at reduced performance ... But less fan noise

    Active: this options runs the fan to reduce the temp., if after a while the temp. does not decreased, then the processor will slow down to reduce the temps.
    This option is the one for you if you need your processor working at the highest performance all the time... but more Noise

  • Yes, I read that on the Microsoft site, I didnt see a huge difference on my PC in terms of speed, so worth the sacrifice (keeping the components that little bit cooler, might help extend the life of the laptop as well). But at least the fan is working as it should now!!

  • This solution does NOT work for me.  I have tried it, and the fan still constantly ramps up and down.  I have searched for weeks to try to solve this issue with no luck.  I've tried replacing drivers for both the nvidia and intel chipsets.   I have no special fan speed programs.  I have no hardware monitors that I am aware of.

  • I'm am taking your suggestion.  I just received my laptop 4 days ago and the fan seemed to be running constantly.  I don't know a whole lot about this tough but I have enough knowledge to know that it didn't seem right.  I made my power setting changed and I will see if that helps my problem.  Thank you for the clear instructions.

  • This hasn't worked for me. I've adjusted just about every power option, rebooted in between, and the fan literally goes up and down every 3-5 seconds... It's ridiculous. I've tried BIOS A09, A10 and A11 with no change. I tried the SpeedFan software and could never get it to recognize my laptop's fan (yes, I clicked the box that enables Dell support in the SpeedFan menu). There's no option to adjust fan speed in the BIOS. Some of the power options seemed to have helped for a while but eventually it starts up again w/o ever changing the power settings back. Also, it doesn't matter whether what I'm doing is using the Nvidia or the Intel graphics. Another thing, when I tried A11, the fan noise got better but that was only because it wasn't coming on at all and I got CPU temps up to 80C (and they're usually around 55C under normal web surfing/music listening load... I flashed back to A10 and the fan noise is back, but the CPU temps are also being kept low. This is ridiculous!!

    Surely someone else has this problem and has found a solution... help me out.

  • UPDATE: I actually just realized that I hadn't checked for new Nvidia drivers. I downloaded the new one and so far (the last 2 hours) the fan has been much more normalized... i.e., it comes on at what sounds like 50% and just stays there for a while and then goes down to about 5-10%. Then after a few minutes is slowly ramps back up to 50%... this is way better than the 0% then 100%, then repeat... hopefully this fixed it.

  • My laptop did the same thing but now i fixed it for sure.

    The application caused it to on/off was MSI Afterburner, after i stopped it everything was fine and perfectly quiet

    GPU-Z did the same as MSI Afterburner and maybe all kind of these oc/temperature monitoring softwares.

    Thats everything.. have a nice day ! :)

  • I am also facing same issue but recently i have changed the mother board , still the problem occurs.Does any body has solution for this?

  • Mr_Geek: Thanks for this fix! Much appreciated!  I never knew about the passive option in the power settings! Also like yourself, Dell should have configured the settings before they shipped out my laptop to me.

    The fan speed 'ramping' up and down has significantly reduced however like Blakjak220, when I'm surfing the net or just opening up some programs the fan speed increases but to only about 50% approx. Is this normal even though usage is still light when operating the laptop?

    Cheers