Auto Disable Synaptics Touchpad when USB Mouse is connected

Laptop

Laptop
Laptop computer Hardware and Software discussion

Auto Disable Synaptics Touchpad when USB Mouse is connected

This question is not answered

HI

Anyone any idea how to get the " Auto Disable Synaptics Touchpad when USB Mouse is connected" feature active again.  I found an old entry in a forum that referenced changing a setting in Registry to Hex 33 and implied that this would make the OPTION become visible in the Mouse settings in Control Panel.  But  it appeared to simply disable the touchpad ALL the time.So I assume Synaptics have changed things since this 'fix' was posted in 2009 I think. .

I have W7  XPS,  and Driver version 15.3.22.0 for Synaptics Touchpad. 

Cheers

K.

All Replies
  • Hi K,

    Welcome to the Community. Please add your system model/OS when posting on the Community. You should find that settings in control panel, mouse, touchpad settings. If you do not see it there, you may have to uninstall and reinstall the Touchpad drivers. To uninstall, click on start, right click on computer, click on properties, click on device manager, click on the symbol next to pointing devices, right click on Synaptics touchpad, and click on uninstall, click ok to confirm. Once its removed do not restart the computer, but log on to support.dell.com, click on home users, drivers and downloads, enter your service tag, and download the synaptics driver which will be under Input. After installation restart your computer, and then go back to start, control panel, mouse, click on the touchpad image ( it will take some time to appear ) there you should have an option to check disable touchpad when a USB mouse is connected.

    Thank you

    Royan

  • Thanks for the info..

    I cannot uninstall until I can get the driver from Dell and, bizarrely,  the online DELL system will NOT accept the TAG value. 

    Thisis a new LATOP,. I have a separate question with Cust Services. But unitl they recognise the TAG I cannot get at the correct driver. 

    I thought I added the model.  Sorry..      Laptop XPS 702X , W7.

    The settings required are definatley not in the Touch pad setitngs via Control panel.

    Cheers for reply.
    Kev.

  • HI agian....  reinstalled Synaptics driver.  No effect.  No option to disable when USB connected.  Sames as before.

  • So my conclusion is that this is NOT POSSIBLE.  THere appears to be no feature on any config or settings screen for the Synaptics Touchpad that will 'disable' the touchpad when USB mouse connected.  Unless someone can guide me to an option ?

  • As Dell-Royan already mentioned there should be an option to disable the touchpad when connecting an external mouse.Here is an example for an inspiron 1545

    at  0:30 you see the option at the bottom of the video

  • THanks

    Apppreciate the attempts to help. But the 'DELL TOUCHPAD'  shown in the vid is NOT what I have.  I have the Synaptics Touchpad  (Dell XPS 702X runnign W7).

    In the image below, I've marked where I understood (from other web forums) there 'could' be a line and checkbox to DISABLE the USB, but the image below is what I have to work with.  I have uninstalled and reinstalled.   No option appears.   however, I have found a 'Function Key' that allows me to toggle  'enable/disable' , so that will have to do for now.

     

  • Sorry.. for some reason the image wont post.  Tried IE and Firefox... edits fine my end.. appears to post.. but then shows as blank entry.  Apologies.  Unable ot upload image either.  

  • I just decided to mess up my system (inspiron 1545 with Alps touchpad) with the installation of  a synaptics  driver-

    wanted to see what options you have:

    It installed without any problems- external mouse and touchpad working still fine and - sadly to say:

    you were right there are no options to automatically disable the touchpad when connecting an external mouse.

    You might try installing the Alps touchpad driver(create a restore point before doing this and do it on your own risk-I have restore points and full backups to easily reverse any changes in case something goes wrong...)

    Synaptics touchpad (win7/64bit

    www.dell.com/.../DriverFileFormats

    Alps touchpad (win7/64bit inspiron 1545)

    www.dell.com/.../DriverFileFormats

  • Cheers for confirming

    I may well give that a try..  

    This page shows Synaptics used to have this feature.  

    www.sevenforums.com/.../149723-synaptics-touchpad-auto-disable-usb-mouse.html

    But clearly no more..  I tried the regedit change suggested on this, but made no difference at all....

  • I have exactly the same menu but without the red marked option - my inspiron touchpad is listed as "standard pointing device" so the synaptic driver is not fully compatible with my touchpad - but I should still see at least the (disabled)  option you are looking for.

    Furthermore: did you compare the driver versions?  v14.0.4 03Sep09 (the one with the option) to v15.1.15 23Sep10.

    It looks like they removed the option in the updated version.....

  • SOLVED SOLVED SOLVED!!!

    All - I've read through this and many forums and have found no solution. I figured it out on my own, so I am happy to share with you!

    This solution applies to those who do not have a touchpad disable button on an F key at the top of your keyboard and have the Synaptics driver that does not show the option to disable the touchpad when the external device is present. This also applies to those where the registry key update does not work (as it did not for me).

    Here's the solution.

    1. Go to the Dell website and get the latest driver for your touchpad. Install it.

    2. Once installed, go to c:\program files\synaptics\syntp in your windows explorer.

    3. Open the program called DellTpad.exe (there is also one called DellTouchpad.exe -- don't use this one)

    4. Once open, click Device Settings.

    5. And voila, the old checkbox is there at the bottom! Just click to make this active and it works like a charm.

  • Hi Spanther

    the above options which you have posted are which Synpatics driver version, i have tried even the registry fix but still does not work, the version i have installed is 15.2.6 dated 16dec2010.

    Please advice

  • THANK YOU SO MUCH!

  • THANK YOU very much for this great post.

    I was searching all over this morning for a method to achieve this exact same thing when i finally stumbled upon your post.   Worked like a charm.