E6410 w/ 16GB ram - General Hardware - Laptop - Dell Community

E6410 w/ 16GB ram


Laptop computer Forums (Audio, General Hardware, Video)

E6410 w/ 16GB ram

This question has been answered by Marcin Pluta
I have an E6410 latitude with 16GB (2x8GB) ram installed. On latest BIOS firmware (A11). Linux is rock solid...however, booting my Windows partition results in a blank, white screen right after the Win 7 splash screen starts to display...then it reboots. Anyone able to boot/run Win 7 with 16GB ram?
Verified Answer
  • Hi

    I can confirm that E6410 with i7-620M version of CPU will NOT WORK with 16GB of RAM (2x8GB or 1x16GB)

    and will not run with 64Bit operating system installed.

    Sham but it's still runs extremely well with 8GB + 500GB SSD.

All Replies
  • Same here. E6410 with 16GB (2x8GB) and BIOS A11 and the same behavior starting Win7.  The same memory works right on a E6420 and Win7.  Any advice?

  • Hi, maximum amount of physical memory supported depends on the edition of Windows7 system you use. Check out the limits for various editions here:


  • Same issue here with E6410. Memory limit is not the problem. I have Win 7 Pro 64bit.

  • Today I tried to install 8GB module and got just ON_FLASH_ON led error code. I was not able even to get into BIOS. Guys, I just wonder how did you manage to have 16GB installed on E6410. Could you provide some details or picture of you System Information screen in BIOS?

  • To confirm, you have indeed got 16GB of ram running successfully with Linux? Which distro and kernel? I'm holding off on purchasing 2 x 8GB sticks because there is no official support for more than 8GB.

  • I'm referring to the E6410 having a max of 8GB support. If it will support 16GB I'm off to buy the upgrade now. With several VMs running the extra memory would be excellent.

  • I bought two 8GB Kingston sticks for my E6410, but they are not working :(

    BIOS recognizes it (all 16GB of RAM) but loading of Winows or Linux result in bluescreen/restart :(

  • Please could you be more specific? What model of 8GB Kingston sticks you use? What revision of BIOS you use? Could you provide screenshot of BIOS screen documenting the E6410 recognized 16GB RAM? Did your configuration pass built-in memory test in BIOS?

  • Does the E6410 support 16GB of RAM with the latest bios (A11)?

  • I tried 8GB module "Corsair SO-DIMM 8GB DDR3 1333MHz CL10" with BIOS rev A11 and computer was not even able to get into BIOS.

  • I am using two Kingston KVR1333D3S9/8G sticks on A11 BIOS.

    Tried now dell diagnostics but it failed on memory test (reboot) :(

    I tried this sticks on some newer laptop (with 2nd generation i3 - i think it was i3-2330M) and it worked perfectly)

    and for me, system hangs usually after starting loading Windows/ same with linux.

    reboot also when i try to install clean system (windows 7/Windows 8 CP /Linux(ubuntu)

    attaching photos of bios and memory sticks below:

  • Darioosz, thanks for posting details. I feel like we are getting somewhere.

    I checked Intel specs for first generation core-i processor (namely i5 560M) and it says processor supports up to 8GB RAM. ( ark.intel.com/.../Intel-Core-i5-560M-Processor-(3M-Cache-2_66-GHz) ) . So it seems that 16GB is not supported by that particular processor.

    However, second generation core-i  processors may support up to 32GB RAM.

    iMav, guele02,JeanVEGA: What processor do you have in your e6410?

  • My CPU: INTEL CORE I5-560M (2.66)

    So I guess it's bad luck :/ time to upgrade?

    An update about my Linux successful boot. Yes it boots, yes it works, but after some time (usually under load) it just reboots without any message in logs.

    Tested with OpenSuse 11.4.

  • BIOSE6410.jpg

    This is mi BIOS screen.  And my processor is an i5 M540 2.53Ghz.

    It seems that I have a couple of Corsair 2x8Gb on sale...

  • the same as I , when I boot windows 7, the screen to white  a few seconds, and reboot.

    But in BIOS ,the ram is normal