inspiron 1545 right click not working and I'm clueless!

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

inspiron 1545 right click not working and I'm clueless!

This question is not answered

I have an inspiron 1545 that's about 2 years old.  Just recently the right touchpad button stopped working. At this point I am completely stumped as to whether the issue is a hardware or software problem. So far, I have:

re-seated the touchpad and button ribbons

deleted and replaced drivers

replaced palmrest and buttons

repaired windows 7 installation

reinstalled windows 7

After doing all of this, the right touchpad button still does not work and I don't know what else to do.  I ran diagnostics on the touchpad and clicking the right button go no response from either the old or new buttons; while both the old and new touchpads and left buttons performed normally each time. Are there any steps I've missed?  Also, this happed right after I installed and used AVG  PC tune up. Could that have caused the issue?

Any help will be appreciated.

JJ

All Replies
  • What happens when you use a USB mouse? Does the right-click work?

    my Dells:
    Precision M6300 - Windows 7 / Ubuntu 12.04
    Latitude D620 - XP Pro SP3
    Precision M6300 - Windows 7

  • Run Dell Diagnostics =>

    >Test System

    >Custom Test

    >Pointing Device

    >PS/2 mouse

    use the graphical interface to test each single touchpad button.

    If you don't have access to Dell Diagnostics (F12) after installing win7 use the bootable Dell "Driver and Utillty" CDrom

  • Yes, when I use a usb mouse the right click does work.

  • I did use dell diagnostics and the right button failed ( no reaction when pressed) when I tested both the old and new buttons. The left button and touchpad worked for both.

  • Dell Diagnostics is an OS independent diagnostic tool.If the touchpad fails the test then either the touchpad  or one of the chips on the mainboard is broken.You have already replaced the touchpad so it looks like the mainboard is the culprit.

    ====================

    Did the the palmrest come with a new cable attached to it or did you have to use the old cable?In the latter case replace the old cable - if possible.Also make sure that the connector on the mainboard is not damaged or "dirty"

    The USB port and the "touchpad port" are using different hardware/chips that might explain why an external mouse works fine.

    ====================

    Also run the extended test if you haven't done that already

  • The palmrest came with a new cable attached and the connector does not appear to be either damaged or dirty.  Also, I ran the extended test and everything passed.

  • Dell Diagnostics is a nice program to test hardware but unfortunately it is not a "wonder tool".In some cases it won't be able to detect faulty parts like broken wires to a simple switch,connector etc. (it depends on the circuitry of course).

    To my mind there is something wrong with the mainboard.In a list ditch attempt I would try putting some gentle pressure on the mainboard connector or moving the cable while pressing the button at the same time - it might be just a simple loose connection(almost invisible to the naked eye)-bad soldering whatsoever.

  • Thanks so much for your help!  I am exhausted with this computer right now  so it'll be a day or so before I open it up again, but I will try what you suggested.

  • A possible 5-minute software solution - looks complicated but is dead simple !

    1.download the  program autohotkey.exe (Version 1.0.48.05) and install it

      http://www.autohotkey.com/

    >On the desktop click the right mouse button(use external USB mouse) ,click "New" and then

     "AutoHotkey Script"

    >name the new file "mouse.ahk"

    >right click on the new file

    >click "Edit Script"

    >at the very end insert the following line  => "APPSKEY::rbutton" (without quotation marks)

    >save the file

    APPSKEY stands for Application key.This is the key between the right "Ctrl" and the left "Arrow"-key

    The code "APPSKEY::rbutton" makes the the APPKEY behave like the right mouse or touchpad button.

    Double click the file "mouse.ahk" - and test if you can use the APPSKEY as a right mouse key replacement.

    After double clicking you'll see a new green icon in the system tray - you can use it to exit the script.

    >I have the same laptop as you and it works on my machine.

    >If it works it is also possible to use a different key - in case you need the APPSKEY

    >Moving the script into the "start up" folder will automatically run the script-so you don't have to run it manually.

    As I wrote earlier I think that the mainboard is in trouble and without technical experience it is almost impossible to even fix a loose wiring.If autohotkey works stick to it......

  • Thanks for the suggestion but that key already pulls the context menus. I have been using the key, I was just checking to see if there was a solution for the mouse button problem.

  • BRILLIANT!!!!!  Simple and 100% effective.  I'm already thinking of other scripts I can create