Inspiron 1501 BIOS gone bad

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

Inspiron 1501 BIOS gone bad

This question is not answered

Recently ran the bios flash update from Dell on a laptop. Have done it many times with no incident  This time however, after I restarted the system to load the new BIOS. Power light came on the DVD drive made noise like it was being recognized then nothing. The Internet has a lot of suggestions and the British say the bios chip is replaceable. Is there a BIOS recovery process like a cd or usb thumb drive based program.The system worked fine until this happened and now I have to make good on this or be out a lot of money replacing the unit for the customer

All Replies
  • I am sorry to read this happening.  Do you remember what version of the BIOS was on the system before flashing, and what version of the bios you where trying to flash to?

    The latest version of the BIOS is version A16 and it wa released Dec of 2007, and may be found from the following link

    www.dell.com/.../DriverFileFormats

    I suggest troubleshooting the system first though just to make sure there isn’t another cause then the Bios flash.

    1. Check that the system has a power light.

    2. If the system has no power light, ensure it is plugged into AC power. Remove the battery.

    3. An incorrectly seated memory module may cause a no-POST situation and not display an LED error code. If the system has power but nothing else happens, reseat the memory modules in the unit.

    4. If the system has power but is not performing a POST, check if the keyboard status lights flash to indicate a successful POST.  Press the caps lock or num lock key and see if the corresponding LEDs come on. If they do it indicates that the system is turning on, there is just no video.  Plug an external monitor and power up the system and see if you get an image on the external monitor.  Otherwise if the LED s doesn’t light, continue troubleshooting.

    5. With the power off and the system unplugged, remove all easy accessible devices (ac adapter, battery, the device in the media bay, the hard drive, system memory, the modem, and the wireless card) from the system and reconnect the AC adapter to the system and try again.

    Basically the idea here is determine if this is a power issue or not.  If the system is still getting power then the idea is to isolate the system board as close as possible to verify if the problem is the system board or something else.   Often enough it could be some other device that may be shorting the system out, that may be causing the issue and may have stopped the BIOS update from completing.  Reseating the device may correct the problem and get the system up and working again.

    If you verify that the system board is inoperable shoot me a private message with the service tag and your contact info and I will research any possible service options.

     

    TB

    (Liaison for Laptops, Mobile Devices)
    Look for me on Twitter and LinkedIn.
    #iwork4Dell
    Would you like to be a Dell Community Rockstar?

  • ALL WAS TRIED AND DID NOT CAUSE ANY DIFFERENT BEHAVIOUR.. THE FACT THAT IT WAS WORKING FINE SINCE BOUGHT UP AND TILL THE TIME I FLASHED THE BIOS KIND OF GIVES IT AWAY.

  • ps.  YOU INDIAN TECH SUPPORT SAID THEY HAVE NO RECORD OF THIS EVER HAPPENING BEFORE. THE INTERNET DISAGREES A SIMPLE SEARCH ON GOOGLE REVEALS IT IS RATHER COMMON RELATIVELY SPEAKING.