battery plugged in but not charging,battery not detected

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

battery plugged in but not charging,battery not detected

This question has suggested answer(s)

please tell me which battery is supposed to be use for dell inspiron 15R  n5010-4346 laptop. tell me the model number of battery because i am getting a message when laptop starts." the model number for primary battery could not be determined. this will prevent any battery present from charging. please insert a dell battery for best system operation". i want to check is it the right battery inserted in this laptop?

All Replies
  • Batteries Die.  Once they do they are not repairable.

    Report Unresolved Customer Service Issues here
    I do not work for Dell. I too am a user.
    The forum is primarily user to user, with Dell employees moderating.

  • Had similar issue, but it wasn't a BIOS, dead battery or adapter issue.

    I must have fat-fingered the Function + F3 key. Not sure the purpose of that key. 

    I hit the Function + F2, and the laptop keyboard indicator light turned on and the battery charged as expected.

  • testing reply function.

    This worked.

  • I have the same problem, but I am sure that my battery is not dead!! My problem caused by hp charger when my friend plug it in my Dell Studio 1557 Laptop! since then my laptop stopped charging the battery, instead, it says no battery is detected! I cannot flash the Bios for the battery in empty. Any body can help me?

  • Hey I have a Dell M4400

    I had the same issues and it turned out to be a combination of things:

    initially I would get an error at boot up telling me I had the wrong power supply and in windows it would say  "plugged in, not charging".

    I looked on a few forums and figured it could be the centre pin thing so:

    I checked using a friends power supply and same error so i dumbly assumed it couldnt be that.

    then since i am a bit handy with electronics, and thinking it was in the PC i pulled my laptop apart and checked the circuit from the DC Jack centre Pin back to the mainboard socket.  with a multimetre, this can be done without pulling the MB out, just remove the backplate to find the DC in connector remove that, stick a sewing needle in the centre pin of theDC jack on back of PC then check to find that there is zero resistance across one (and only one) of the terminations on other end of cable, on mine this checked out fine.

    put the PC back together, thaught maybe it is the MBO power circuit, if so i would throw pc in bin and buy another rather than replacing, so I got hold of a cheap docking station and threw the PC on that to short cut some of the power circuit on the MBO, but still same problem.

    Ok so I thaught if its not the circuit it must be software, so i opened up the bios utility, everything looked ok, AC adapter detected and battery detected, i was out of ideas so i figured stuff it, ill flash the BIOS. BiOS was ver A22 flashed now to A27, this was also tricky because my battery was flat and the bios wont let you flash with a flat battery so to do this i had to force a reflash, to do this i made a usb flash drive startup disk and drop the M4400A27.exe bios flash on the root, boot up using the flashdrive and run the flash program, half way through the reflash the little battery light went solid and the battery began to charge for about a minute or so but then the flash program ended the pc rebooted and the same error came up this time caught by the A27 version bios check. i opened windows and the error had changed it now read "battery not detected." 

    Confused and again out of good ideas i ran the bios utility again and checked out the details in there, strangely now the bios would not recognise the AC adapter but said the battery was fine, hmm, (funny how the BIOS and windows always seem to contridict each other, not alot of help are those software developers sometimes...)

    I suddenly had a thaught: If the BIOS is now clean install it should be working properly and telling me good info, and perhaps it is not recognising my adapter bbecause of lead damage, maybe it can't draw enough current to recognise the output?? Also my friends Adapter was from a latitude and was not as high rating as mine so maybe same same, couldnt get enough power...  So i wipped out my adapter lead and carefully cut the end apart, sure enough almost every wire was connected but now only by a few strands of wire so I completely stripped it back (there are 3 wires) Pos, Neg and centre signal wire. I reterminated all wires put it back together somewhat crude looking now but fully functional and robust once again, plugged in to PC and wulla all works perfectly.

    So moral of the story:

    1. Check condition of your adapter lead and socket first, dont just grab another friends adapter unless its identical because the PC needs a certain adapter power rating or it wont charge. Check that the lead termination is healthy and that the centre signal pin is straight and functional, run a multimetre on it and check you are getting the right output and that there is resistance between all 3 inner, outer and centre pin.
    2. step 1 failing then flash your BIOS, it could be a BIOS error, or at the very least later BIOS might help you diagnose the error better.
    3. 1 & 2 failing, grab a docking station and throw your PCon that, if it charges then it is likely to be your DC jack
    4. failing 1,2 & 3 if you are out of warranty then it looks like your laptop is now a desktop because your MBO will likely be stuffed, I wouldnt worry about buying new adapters or MBO because the cost v's what the PC is worth will be not worth it and the cheap chinese adapters suck (I know this from other prior experience)

    In my case I believe it was primarily my lead but that my old BIOS A22 was dodgy too i reckon because it was recognising the adapter but still not letting it charge which is just plain weird.  Outcome for me of all this is my lead is fixed and i now have a cool docking station that makes life easy and keeps my chord from getting knocked around in the future.

    Now its no longer destined for the BIN, I think this PC is going to get Windows 7 X64 to properly take advantage of the CPU inside, no idea why they are still pushing 32bit O/S at us in new laptops??  I will install a new bigger HDD and for not much coin I will get a bit more life out of this old banger..

    Good luck hope you fix your problems.

  • i have a problem in my laptop of dell  inspiron about battery. when i start my laptop i get a message that the battery is not detected. what to do?please help

  • Hi,

    I have the same problem, so would you please help me if you found a solution.

    Thanks

  • In my case it turned out to be the lead, the plug is very poor quality, there is 3 wires, Pos, Neg & a signal in the centre.  the signal wire is very light and so breaks off easily, once that is broke the computer doesnt recognise the power supply and hence your error.

    This is fortunately very easy to test and fix if in fact it is the cause:

    1. Remove power lead from power and PC.

    2. Take a screw driver and split the plastic cover apart at its seem revealing the cables and terminations.

    3. Inspect terminations if they all look ok and are not shorted against one another then it might not be the problem, check this using a multimetre and do a resistance test (that is turn the multimetre knob to the ohm symbol and touch the two probes together the dial should change and show zero or some very small number, if this happens your meter is working, now this is tricky part, with one probe touch the centre pin in the end enduring you dont make contact with the inner wall, with the other touch the solder joint on the back of the centre signal wire, the meter should again change to low resistance, now go back a little way up the centre lead (a centre metre or so) and drive the probe point into the centre wire until it makes contact with the conductor inside, again you should get zero or very low resistance.

    4. if you get very low or zero resistance then the problem is likely to be in the PC not in the plug, otherwise if you get high resistance i.e. dial on meter doesnt changevkeep investigating the continuity of the centre lead and if broken locate the break and repair using a small tip soldering iron.

  • I too am getting frustrated with this, I re-installed Microsoft ACPI compliant control method battery.

    That worked but only for 1/2 an hour or so. When I unplug the power supply I shut down