New Dell XPS 14z (L412Z) Wireless Card Issues

Laptop

Laptop
Laptop computer Hardware and Software discussion

New Dell XPS 14z (L412Z) Wireless Card Issues

This question has suggested answer(s)

Hi all,

I've waited and purchase the XPS 14z as soon as it came out. To my disappointment I have struggled with wireless connectivity since. I found comments about a similar problem with the XPS 15z. but not much about the 14z (beside a couple of post in the Review section of the Dell website).

From the same location, my four+ year old XPS M1210 has consistently 3 bars of better signal than the 14z. The same happens at work beside my Vostro 1720.

Furthermore the 14z connection is unstable and drop off randomly, effectively making it impossible to use for internet unless I sit close to my router (which is not in by my home desk).

Dell sent out techinicians twice. The first time to replace the wifi card, the second time to replace the wifi (again a 6230) and the antenna (which involves taking the all system apart and replace the screen at the same time).

Now Dell is going to replace the system with a new one, but by the sound of things, it's going to be just the same.

Is there any official source where Dell aknowlodges that there is a problem with their choice of hardware/software configuration; and that they are going to do something about it?

Are there known solutions out there already?

Regards to all

All Replies
  • I just received my XPS 14z a couple days ago and I am having the EXACT same problems with WiFi connectivity. I have tested other laptops in the house using wifi and they are running just fine, so it is not the internet connection, the modem or the wireless router. The problem must be traced back to the laptop. I spent a ton of money buying this laptop and I am extremely disappointed in the wireless issues i have already experienced. Not happy Dell.

  • I assume you raised the problem with Dell. If not, please do so to let them know something is going on. I am keeping an eye on the XPS 15z forum and it looks like that model is having a similar problem too. A bad BIOS release is looking like a possible cause. Still, it's unbelievable that Dell doesn't officially aknowledge the problem and is addressing the matter like if it was a random hardware fault. My replacement laptop is due to arrive in a couple of weeks. I hope it makes a difference...

  • Just want to mention that downloading the following solved the problem for me last night. Per the advice of Terry from Dell's technical team, he state "If you have not already done so please make sure that you have the most up to date driver."

    www.dell.com/.../DriverFileFormats

  • Furthermore, I received my replacement system today but unfortunately i have the same problem. This product has obviously some design issues and it's incredible that Dell is still selling it without coming clean and give some official updates on what they are doing about it.

  • I also have XPS 14z and have exactly the same problem. Connection with Intel 6230 is extremely slow... My old laptop connects at 150Mbps, the 14z at 20Mbps or less. Dell Tech Support could not help because my laptop was too new, the Service Tag was not registered... They recommended to do a clean Windows 7 install, I did on both laptops, tried both Intel and Dell website drivers, no joy.... Please Dell help!!

  • Fompe

    Here is my post on the other  thread

    If you have not already done so please make sure that you have the most up to date driver.  

    www.dell.com/.../DriverFileFormats

    www.dell.com/.../DriverFileFormats

    Please make sure that both the WIFI and Bluetooth drivers are installed. .

    If you continue to have problems with the new driver this may be an issue with PSP incompatibility with your router.  I suggest contacting your router manufacturer and see if they have any new updates.  Here is a link from Intel with more info regarding PSP mode.

    www.intel.com/.../cs-006205.htm

    Symptom(s):

    The following symptoms may be seen if a Wi-Fi access point (AP) or broadband Wi-Fi router does not properly support the Power Save Polling (PSP) feature:

    Intermittent loss of Wi-Fi connection

    Inability to initiate a Wi-Fi connection

    Poor Wi-Fi connection data performance

    These symptoms may be more pronounced when on battery power.

    Cause:

    PSP mode is a feature that provides extended battery life for notebook computers. It requires coordination between the AP or router and the Wi-Fi adapter. Intel has discovered that some APs or routers may not implement the feature correctly or completely.

    Solution:

    Contact the AP or router vendor for updated software or firmware that corrects the problem, or for a working around put the adapter in C A M mode.

    Put the wireless adapter into Continuously Aware Mode using the following steps.

    Click Start > Settings > Control Panel.

    Double-click Network Connections.

    Right-click the wireless connection and click Properties.

    Click Configure.

    Click the Advanced tab.

    Select the Power Management setting, uncheck Default / Auto and move the slider to Highest / Maximum Performance. Note: If the slider is already at Highest / Maximum Performance, move the slider to another setting and then back to Highest / Maximum Performance.

    If this doesn't help out please feel free to shoot me a private message with the service tag of the notebook, and your contact information.  

    TB

  • I really should do more than just cut and paste.  Sorry about that.

    Here is the link to the latest Intel Centrino 6230 wifi card.  I do suggest that all of you that are still having problems give it a try.

    www.dell.com/.../DriverDetails

    TB

  • Hi Terry, the link you gave works however when I click download it says 'File not found', both via the direct download link as via the Dell download manager.

  • Hi Terry, your link now works, I installed the drivers (Intel 14.3.0.6, 27-10-2011) but still the same problem. I am really disappointed working still on my old laptop now...

  • I just wanted to post that the latest drivers for the Intel Centrino 6230 has been released and may be found from the following links.

    www.dell.com/.../DriverFileFormats

    www.dell.com/.../DriverFileFormats

    These drivers are version v14.3.0.6, A02 but are designed specifically for the XPS 14z

    Those of you still having problems, please remember to download the driver and safe to the desktop, do not run it.  Then go in programs and features and uninstall the current drivers, and restart the system.  Decline any request from Windows to install a driver and then run the downloaded driver.

    Put the wireless adapter into Continuously Aware Mode using the following steps.

    Click Start > Settings > Control Panel.

    Double-click Network Connections.

    Right-click the wireless connection and click Properties.

    Click Configure.

    Click the Advanced tab.

    Select the Power Management setting, uncheck Default / Auto and move the slider to Highest / Maximum Performance. Note: If the slider is already at Highest / Maximum Performance, move the slider to another setting and then back to Highest / Maximum Performance.

    If connections speeds is not improved, try disabling bluetooth,  and see if there is a difference between 5 gz networks and 2.4 gz networks and post back here.

    Thanks

    TB

  • The instructions you have given do not apply to win7 (which is what the XPS 14z uses) I think.

  • I copied it directly from Intel's link

    www.intel.com/.../cs-006205.htm

    You are right Tugela01 they was using Window XP.

    For Windows 7

    Control Panel

    Networks and Sharing.

    Click on the connection

    Click properties

    Click Configure

    Click Advanced

    Click on Transmit Power under Property

    Set the value to the highest, usually five.

    Click the Power Management tab

    Make sure that "Allow the computer to turn off the device to save power.

    Click Ok.

    Also you can change the setting using Proset

    From the Intel PROSet/Wireless WiFi Connection Utility:

    Click Advanced > Adapter Settings > Advanced tab.

    Select Power Management, uncheck Default / Auto, and move the slider to Highest / Maximum Performance.

    Please let me know if this helps.

    TB

  • Installed the new drivers in a clean Windows 7 64bit install does not solve the issue. It's not a driver issue but a design flaw.

  • Hi there, same thing here. Not sure what to do. Seems they put a new driver out and call it an issue with the N-Card?

    Fügen Sie dies zu Ihrer Downloadliste hinzu.

    Dell Centrino Advanced-N 6230

    Veröffentlichungstermin: 03.01.2012

    Version: A02v14.3.0.6

    Fehlerkorrekturen und Verbesserungen

    Fix the N mode connection issue on

    I had a technician out here too. Same as with you. Any new ideas?

    Thanks.

  • Terry, you said " Make sure that "Allow the computer to turn off the device to save power. "  

    Is the boxed supposed to be checked or unchecked?

    thanks