Dell Inspiron 1545 is unable to detect any USB device connected to it - General Hardware - Laptop - Dell Community

Dell Inspiron 1545 is unable to detect any USB device connected to it


Laptop computer Forums (Audio, General Hardware, Video)

Dell Inspiron 1545 is unable to detect any USB device connected to it

This question is not answered


Since yesterday my Dell Inspiron 1545 laptop is unable to detect any USB device connected to it. I tried connecting the device to all available ports of laptop but none of them is working. I tried to update the drivers but in troubleshoot window its showing "No plugin found ..drivers are not loaded" and for any USB device connected to it, its showing "Unknown USB device".When I went into its detail its showing that "digital signature is not present". I tried all the ways like install, uninstall, reboot. But its not even able to install/update the drivers. All my USB devices were getting detected and were working fine till 5th Nov.11 before this problem started on 6th Nov.11 and I changed nothing in laptop also no damage been caused to it.  Need urgent help.

All Replies
  • Try safe mode (f8 before WIndows loads). If you can't get even a mouse recognized in safe mode, chances are the USB controller has failed - in which case you'll need to replace the system board.

  • 1  Restore the system to before the fault happened.

    2  Try this Microsoft Fixit - Hardware devices are not working or are not detected in Windows

    3  Check for malware & see the advice by SpiritX in How to remove spyware from the computer [in the MS Answers forum]

    best of luck,


  • After plugging in a new Nook Color e-book reader, I had the same problem with my Dell Inspiron 1545 (Windows 7 64-bit Home edition). All 3 USB ports did not work and Windows 7 gave error messages that the device was not recognized. No USB device (mouse, keyboard, etc) would work on the 3 USB ports.

    I tried reloading drivers, re-booting, deleting the USB settings from the Device Manager (Windows 7). I even ran a System Restore. Nothing worked.

    I was ready to replace the laptop. Then I saw a recommendation on a Microsoft message board and it worked. Here's what I did.

    -Power down the laptop.

    -Unplug the power adapter cord from the laptop.

    -Remove the main laptop battery.

    -Wait for about 15 minutes. 

    -Re-install the main laptop battery.

    -Plug power adapter cord back into the laptop.

    -Re-boot the laptop.

    -Try using a USB mouse. Windows may re-install the mouse drivers. Allow it to.

    After this procedure, the USB ports seem to be working fine.

  • Just tried this and it worked - THANK YOU!

  • tried the above "remove battery and power for a few minutes" fix on my wife's 1545 to restore USB function worked - For about a week then needed repeatedk... any ideas?


  • In the case of my 1545 the condition was caused by hooking the Nook e-reader to the USB port. The Nook draws a lot of power to recharge and it may have been too much for my laptop.

     My other USB devices (mouse, external keyboard, camera, etc) don't cause any trouble. I just don't plug in the Nook to the laptop anymore, I plug it into a desktop computer. By doing this the problem has not happened again. My USB ports have been working fine.

    This USB problem is probably being caused by just one of the USB external devices you connect to the laptop. You may have to find which USB external device is causing the problem and refrain from plugging it into the laptop. Otherwise the USB problem may keep happening.