E6420 - Bios A07 - Diagnostic false positive - Lcd Cable

Laptop

Laptop
Laptop computer Forums (Audio, General Hardware, Video)

E6420 - Bios A07 - Diagnostic false positive - Lcd Cable

This question is answered

Hi everyone!

 

I found a weird bug with the A07 bios update on the E6420 (i5-2520m). The disgnostics utility report "Lcd Error 2000-0415". When I revert back to A06, the problem disapear.

 

Anyone can repeat this error? I had open a case to replace my lcd cable and I will contact Dell to cancel the cable replacement. But if no one can repeat the problem, maybe the cable is really damaged and the A07 bios is better detecting it.

I have no problem using the computer.

 

Thanks.


Windows Server Administrators for the City of Montreal
Dell E6420/I5 2520M/nVidia Optimus/6gb Ram/250gb Hdd/USB 3.0 Module

Verified Answer
  • There's a long and a short version of this... From what I understand, Dell implemented a change in the hardware that allowed for the cable test to work which they've released on newer versions of the systems and enabled in the BIOS.  For systems with the old cables it will always generate a false positive.  It's not an error in the BIOS, it's just that test isn't supported by the hardware you have.

    --
    Terry W.

    “Those who dream by day are cognizant of many things that escape those who dream only at night.” - Edgar Allan Poe

  • I know that I'm right... I can also tell you definatively that unless someone makes an exception to policy, Dell will not replace the cable because it generates a false positive.  The test on the cable didn't exist for the revision of cable that you have and as such there's no hardware failure.. no hardware failure means no hardware replacement.  Upgrade the BIOS away, I'm not sure why you're worried about a false positive.  If the cable that it's testing failed, you'll have no video anyway..

    --
    Terry W.

    “Those who dream by day are cognizant of many things that escape those who dream only at night.” - Edgar Allan Poe

  • The issue with thinking Dell will ever fix it is this.. The test is a new test designed for the new cable.  It didn't exist before.  It goes out and seeks information from the cable that the old one doesn't know about (I don't even think it's got the bit to detect/reply) and when it doesn't tell the system hey I'm here it fails because that's what the failing part would do.  Without making the test pointless, there's no fix.. 

    It's not a problem unless you make it one really, you just have to be aware it's a false positive and move on when you get that error.

    --
    Terry W.

    “Those who dream by day are cognizant of many things that escape those who dream only at night.” - Edgar Allan Poe

  • Bios A17 solved the hw problem

All Replies
  • hello,

    i have the same problem as well. since upgrading bios i get the 2000-0415 error. Also though when i plug the power adaptor in, the machine comes on and then turns off. 

    weird indeed. 

  • Thanks for your confirmation.

    But on my side, I don't have the "power-on then power-off" problem you are speaking about.

    I reverted to A06 and I called Dell to let them now. They will fill a bug report (At least, I hope so!)

    Thanks!


    Windows Server Administrators for the City of Montreal
    Dell E6420/I5 2520M/nVidia Optimus/6gb Ram/250gb Hdd/USB 3.0 Module

  • Anyone else can confirm?


    Windows Server Administrators for the City of Montreal
    Dell E6420/I5 2520M/nVidia Optimus/6gb Ram/250gb Hdd/USB 3.0 Module

  • I have tried the A07 bios update on a E6520. Same problem.


    Windows Server Administrators for the City of Montreal
    Dell E6420/I5 2520M/nVidia Optimus/6gb Ram/250gb Hdd/USB 3.0 Module

  • We have seen this same problem on an e6420 as well.

  • I have seen this same problem on an e6420, too

  • i currently have the same problem with the dell e6420 2720QM

  • I have the same problem with BIOS A07. The same error! Full HD screen. E6520!

  • After upgrading to A07 on my E6420 i7-2720 the CPU frequency is allways by 100%. I'm back to A05 and everything works fine.

  • I only get the 2000-0415 error after upgrading to A07. FHD E6520.

  • I have a Dell Latitude E6520 and since upgrading from BIOS A06 to A07 I have this problem too:

     

    2000-0415 , Value 278: Check LCD Cable.

     

    There is absolutely nothing wrong with my LCD cable or HD screen of my laptop.

  • By the way, this morning I've upgraded to bios A08, and the problem with the LCD cable is still there.

  • I also have the same problem after upgrading to A07 with my Latitude E6420. I am getting the error "Error Code 2000-0415 Validation 44515 Msg: Cables - Check the following cables: LCD Cable".

    I am sure I didn't get this error before upgrading to A07 from A06. Also I didn't change the cable or open the laptop.

    This morning I saw Dell released A08 and I thought they would have fixed it. But I am still getting the same error. Hope Dell would soon release firmware to fix this issue.

  • I have a Latitude E5520, i5 with 8gb ram and 250gb  crucial SSD.  Everything works like a charm, but when I updated the bios from A2 to A3, yes:

    * the same LCD cable error 2000-0415 come up!  Its a false positive, because when I rolled back to A2 the error in Dell Diagnostics goes away, and I get a green checkmark for everything.  (Remember, Dell Diagnostics is in the Bios Rom under F12 when you first boot up).  Dell really need to fix this annoying bug an release a new bios revision for the Latitude E series.

  • Updated BIOS from A7 to A8 just now, but the problem does not go away.  I called Dell and was told " just ignore the error"
    What kind of technical reply!!!!!!!!!!  Shame!!!!!!!!!!