Cypress Trackpad "tap-to-click" shut off.........

Laptop

Laptop
Laptop computer Hardware and Software discussion

Cypress Trackpad "tap-to-click" shut off.........

This question is not answered

Dell techs have called several times and are attempting to work through this problem.  I appreciate their attention to the situation, but it has been very annoying.  Every time I put the XPS15Z to sleep, I have to go to trackpad properties and shut the tap-to-click off.  It will not stay off.  I think they have a solution for this, but are not sure it will work consistently.  Presently I have 3 Dell laptops.  The one with the Synaptics software for the trackpad work the best.  Hope we hear from them soon and can give everyone a solution to these trackpad problems. 

All Replies
  • ProfJim

    Dell techs have called several times and are attempting to work through this problem.  I appreciate their attention to the situation, but it has been very annoying.  Every time I put the XPS15Z to sleep, I have to go to trackpad properties and shut the tap-to-click off.  It will not stay off.  I think they have a solution for this, but are not sure it will work consistently.  Presently I have 3 Dell laptops.  The one with the Synaptics software for the trackpad work the best.  Hope we hear from them soon and can give everyone a solution to these trackpad problems. 

     

    I am having the exact same problem.  Everytim i hibernate/sleep the computer the trackpad is restored to full functionality.  I am just trying to turn off the double tap to click function.  Was never a problem with my old insipiron

  • I also have the same problem

  • Same thing here. Really annoying, I despise tap to click. Why even give us buttons? Anyways, can we at least get a registry entry to edit? When I disable things, I expect them to stay disabled until I say so.

  • agreed

  • Any update on this issue? Been a number of weeks. It's really starting to tick me off and I am ready to call it quits.  Anyone heard from Dell on this? Or maybe Dell can update us???

  • Hi Everyone. I am happy to announce that I have created a solution for this problem and it does work on my own laptop, however, it is a very unorthodox solution and requires you to get involved with the Windows Registry. You must have local administrator access on the laptop to do this.

    1. Open the Registry Editor.
    2. Browse to HKEY_CURRENT_USER\Software\Cypress TrackPad Driver\TrackPad Settings.
    3. Right-click TrackPad Settings and click Export.
    4. In the Export window
    1. Save the file to C:\Temp.
    2. Save the file with the name TrackPadSettings and with the extension .reg.
    3. In the Export Range, verify the value in the Selected Branch textbox is HKEY_CURRENT_USER\Software\Cypress TrackPad Driver\TrackPad Settings.
    4. Click Save.
    5. Close the Registry Editor.
    • Open C:\Temp\TrackPadSettings.reg with NotePad.
    • Find the line that reads "TapToClick"=dword:00000001 and change it to read "TapToClick"=dword:00000000. (This is what will disable the trackpad tap-to-click).
    • Save and close C:\Temp\TrackPadSettings.reg.
    • Next, we will create a batch script that will run the reg file and update the trackpad settings to disable tap to click. This will be done in "silent" mode.
      1. Open NotePad.
      2. Add the following two lines to the empty file:
                       @echo off
                       regedit /s "C:\Program Files\Cypress\TrackPad\TrackPadSettings.reg"        
      3. Save the file to C:\Temp and name the file TrackPadSettings.bat.             
      4. Close Notepad.
    • Run Windows Explorer as Administrator and move TrackPadSettings.reg and TrackPadSettings.bad from C:\Temp to C:\Program Files\Cypress\TrackPad.
    • Open the Task Scheduler and create a new scheduled task with at least the following parameters:
    1. The file that will be run is C:\Program Files\Cypress\TrackPad\TrackPadSettings.bat.
    2. The task will run with the highest privileges, since this is required to modify the registry which is what we are doing.
    3. Configure the task to run as often as you like.

    I'm not sure what else I can add to this. I hope it works for all of you. Feedback is appreciated! Thanks!

  • typo: TrackPadSettings.bad should read TrackPadSettings.bat, right?

  • oh and thanks, it has worked for me so far,

  • Hi Margot.deMan,

    Sorry for the typo. You're right. . . it should say TrackPadSettings.bat and not TrackPadSettings.bad.

    ravis649

  • I did everything to the letter, but, when I run the .bat, nothing seems to happen.  Still have unexpected cursor jumps and windows opening all over the place.

  • Same problem, but on the XPS13.  

    Am not techie enough to attempt the fix below.  

    Would prefer that Cypress and Dell solved it so the trackpad worked, within these PC's, as it should.

  • I agree. I tried the fix and it did not work

  • I am having the same problems. Tap to click turns itself off and the mouse frequently freezes for a few seconds at a time.

    Latest driver installed.

    Cypress TouchPad Driver
    Version: A00-00        699687
    OEM Name:
    OEM Version: 2.3.6.34
    Computers: XPS Notebook: XPS L321X
    OS: Windows 7 32-bit - Professional
    Created: 5/18/2012

    Has Dell released a fix?

  • Do you all have windows 8? IIf so, what worked for me was going to "change PC settings" and changing the "sync settings" option