D620 won't power on.

Laptop

Laptop
Laptop computer Hardware and Software discussion

D620 won't power on.

This question is not answered

I'm working on a Latitude D620 that doesn't power on. I have checked the AC adapter with a meter and it is putting out 19.63 VDC. There are no lights on the battery LEDs so I'm assuming that it has no power.  I used a very small screw driver to check the DC jack and it seems to have a solid attachment.  There are no LEDs lighting up on the right side monitor hinge.  I read on another forum to try the wireless switch and see if it lights up to confirm power getting to the mainboard. The Wifi light does not come on. I'm just wondering if there are any things I can try before I start taking the unit apart.  As always any help is greatly appreciated.

Jayme

All Replies
  • Does the LED on the adapter come on?

    If it doesn't, the adapter is toast.  If it does, does it stay on when you plug in the notebook end, or go out?  If it goes out, the mainboard is bad.

  • ejn63,

    Thank you for the speedy reply. I just checked and the power light on the AC adapter does come on and it stays on when the unit is plugged into the laptop.  I had also read in another forum that it may be a bad keyboard. if that is the case would the LEDs on the right monitor screen light up or not when the AC adapter is plugged in?

    Jayme

  • I have broken this unit down to the system board. I would like to test it to see if the DC charging circuit is functioning. Can anyone tell me which pins to test on the back side of the board to make sure power is getting to the board. There are five pins on the DC jack. Also if someones knows where to test the board to see if the DC charging circuit is working I would also appreciate that information. From what I've read on other forums this could be either a bad system board or a bad power switch on the keyboard.  The keyboard seems to be sealed up pretty tight, so I don't see a way to test it.

    Jayme

  • Hello, sounds like you either have a bad battery, bad adapter + cord, or need to clear your motherboard for charges. I've worked on over 20 D600 and D620's and they seem to either work or don't. I have only had one bad apple out of the bunch and I got it down to a bad motherboard. Apparently the motherboards on these can go dead easily that is from months of searching 5 years worth of post  through forums.

    If you do not know how to clear the motherboard charge, plug up all cords and battery. Hold power button down for 30 seconds. Unplug battery, unplug cable + adapter from wall and each other (smell to make sure it isn't giving off burnt smell and inspect for physical burns or cuts), hold power button down for 30 seconds to 2min. Plug up power cord only to the system and power on - if no power, hold power button down still for 30 seconds to 2 min try again. If still no power plug up battery and again 30 seconds to 2 min. Let go of power button and press normally, if no power still comes on you sir have a bad motherboard.

    This is very similar to clearing firmware in routers and other devices, and clearing the CMOS, and releasing a charge held up in the motherboard. I hate laptops for this one reason they don't have a realiable way to get rid of a stray charge like you could with a desktop.

  • krisleslie,

     Thank you for your reply and your suggestions. As I mentioned in my original post I've checked the AC power adapter and it is working fine and putting out 19.6 VDC.  The battery has no charge, but that as you mentioned could be due to a bad motherboard.  Right now I have the unit torn down to it's components and I've asked if anyone knows where to test on the board to see if the DC charging circuit is functioning.  If I don't receive a reply in a day or so I'll reassemble the unit and try your suggestions. The help is appreciated.

    Oh and by the way it's I'm not a sir. :-)

    Jayme