Laptop computer Forums (Audio, General Hardware, Video)

Problems connection a DELL Inspiron N7110 to a wireless network

This question has been answered by

I have a new Dell Inspiron N7110 laptop.

It runs windows 7 x64 professional.

It has a Intel Centrino Wireless 1030 wireless adapter.

So far everything worked just fine. I could connect to several wireless networks so far.

However, when I tried to connect to a wireless network secured with a WPA2 (altough I am 100% sure I inserted the right password) it refused. It would only say "windows cannot connect to the network". I used the troubleshooting function and still nothing, the problem could not be detected.

The wireless signal was generated by a Huawei HG655b router and several other laptops had NO problems connection to the network and getting internet access. 

I made sure to: have the latest updated driver for my hardware components, there are no problems in device manager, the firewall and antivirus software were disabled, the wireless network hand't reached it's maximum number of devices, I am inserting the right password.

Even funnier, if I insert a wrong password a "wrong password" error appears but if I insert the right one it says "windows cannot connect to the network".

If you want more information I will happily give it.

If someone has any advice on how to fix the problem. I am 100% sure it;s not the router's fault since multiple laptops could connect to the network easily.

All Replies
  • Does the router have mac address filtering enabled. If so you will need to put in your mac address into the router.


    Own: Dell Chromebook 11, Alienware M11xR2


    Forum Member since 2004

    "If your issue was resolved, please click  Yes ".


  • I don't think so. I mean there were 2 other laptops in the room that connected to the router / network FOR THE FIRST TIME, just like mine, and they had NO PROBLEM connecting. So the router did have have MAC address filtering.

    Don't mean to be so blunt, but since 3 other laptops could connect to the router while mine could not, I don't think it's a problem with the router / network configurations.

    Might be a compatibility problem or something

  • Try disabling mac address filtering.

    Try disabling security and see if it will connect first.


    Own: Dell Chromebook 11, Alienware M11xR2


    Forum Member since 2004

    "If your issue was resolved, please click  Yes ".


  • MrDestiny80

    I believe that a new driver will be released for the Centrino Wireless N 1030 shortly, so I suggest looking out for that.  

    This may be a PSP incompatibility.  Here is a link to some info from Intel

    PSP mode is a feature that provides extended battery life for notebook computers. It requires coordination between the AP or router and the Wi-Fi adapter. Intel has discovered that some APs or routers may not implement the feature correctly or completely.

    Use Intel® PROSet/Wireless WiFi Connection Utility to Set CAM

    Click Advanced > Adapter Settings > Advanced tab.

    Select Power Management and uncheck Default / Auto and move the slider to Highest / Maximum Performance

    Then see if this has any effect on setting up a WPA2 connection.


    Liaison for Laptops, Mobile Devices
    Social Media Support
    Would you like to be a Dell Community Rockstar?

  • This actually worked.

    Also, I had to go to "Manage Wireless Connections" and click "Advanced Properties" and tick to accept some security norms.

    Either way it seems to work just fine now.

    Thanks for your help everyone