Vostro 3750 laptop, how to turn OFF the touchpad?

Laptop

Laptop
Laptop computer Hardware and Software discussion

Vostro 3750 laptop, how to turn OFF the touchpad?

This question has suggested answer(s)

I run Ubuntu 11.04 on this new laptop, but I cannot figure out how to turn off the irritating touchpad which screws up my typing constantly. 

There appears to be an icon on the F3 key that shows the touchpad with an "X" on it, suggesting that this key can turn it off.  When I press the Fn and F3 keys I get a temporary on-screen alert type of message consisting of a touchpad icon with a red "X" on it, theoretically confirming that the touchpad has been turned off.

HOWEVER ...

The touchpad never turns off when I do this, and the "touchpad off" indicator light between the touchpad and the keyboard never comes on either.  By the way, there is no touchpad control in the "System > Preferences" admin area -- not in the "Mouse" area and not anywhere else.

So how do I turn off this blasted touchpad ???

All Replies
  • Hi Kengrome,

    Welcome to the Community. I guess your talking about your touchpad. Trackstick is button in the middle of the keyboard used as trackstick. I think its an issue with your touchpad drivers. I dont know how it works on Ubuntu, but on Windows which I am aware off, uninstalling the existing touchpad drivers, reinstalling a new copy of it fixes this issue. I did some research and came up with this link if this is helpful.

    help.ubuntu.com/.../SynapticsTouchpad

    help.ubuntu.com/.../ShortcutKey

    Hope this helps.

    Thank you

    Royan

  • Hi Royan, thanks for noting my faulty terminology, I have changed "trackpad" to "touchpad" in my original post.

    Yes this is definitely a "known issue" with Vostro laptops and also with XPS laptops.  After I created this thread yesterday I was finally told by Dell that they have an Ubuntu tech support division,  I called them and the tech support guy immediately said this is a known issue with no apparent solution.  He said Vostro and XPS laptops both use the same touchpad, its driver has never worked right, the latest version of this driver makes things even worse and he knows of no way to fix this problem on Ubuntu.

    I just ran "cat /proc/bus/input/devices" as suggested in the first link you gave me, and the result contains this:

    I: Bus=0011 Vendor=0002 Product=0005 Version=7326

    N: Name="ImPS/2 ALPS GlidePoint"

    P: Phys=isa0060/serio1/input0

    S: Sysfs=/devices/platform/i8042/serio1/input/input9

    U: Uniq=

    H: Handlers=mouse1 event9

    B: PROP=0

    B: EV=7

    B: KEY=70000 0 0 0 0

    B: REL=103

    ... so perhaps I'll be able to figure out how to disable this touchpad yet.  

    Nevertheless the solution posted on those two web pages is time consuming and technically complex for the average computer user.  I'm a programmer but I'm not sure it's going to work for me either since the instructions apply to a much older version of Ubuntu than the one I'm using.  All I can do is try, hope for the best, and see what happens.

    If I fail to get this touchpad turned off via software I'm just going to return the computer and buy one from a different manufacturer.  I never had any problem turning off the touchpad on my two year old Toshiba laptop.  I did it so long ago that I don't even remember how I did it, but I probably just switched it off in the BIOS.  Yet this is impossible in Dell's BIOS because it doesn't even offer touchpad control ... :(

  • Surprisingly, turning off the touchpad was much easier than expected.  I simply ran this linux command first:

    # xinput list

    Then I looked in the results for "GlidePoint" which indicates that the touchpad is assigned to id=14.  This info allowed me to turn off the touchpad via this command:

    # xinput set-prop 14 "Device Enabled" 0

    Now I can create a script that runs this command at startup, then the touchpad will be "off" all the time.  Ideally I will also be able to write a script that lets me turn it on and off as needed via the keyboard.

    Thank you Royan for posting a link to this page which helped me to successfully turn off the touchpad in Ubuntu 11.04:

    help.ubuntu.com/.../SynapticsTouchpad

  • Wish this was a solution that regular non-advanced users could apply. So frustrating.

  • The simple and more elegant solution is to install a patch to have the touchpad seen as such, not as a mouse. Read here how to do it.

    Install the *.deb, restart and go to System settings> Mouse and Touchpad > [click the new] Touchpad tab > tick the "Disable touchpad while typing".

    On the other hand, on my V3750 with ubuntu 11.10,  Fn+F3 turns the  touchpad On/Off out of the box no problems.

  • cipm

    The simple and more elegant solution is to install a patch to have the touchpad seen as such, not as a mouse. Read here how to do it.

    Install the *.deb, restart and go to System settings> Mouse and Touchpad > [click the new] Touchpad tab > tick the "Disable touchpad while typing".

    On the other hand, on my V3750 with ubuntu 11.10,  Fn+F3 turns the  touchpad On/Off out of the box no problems.

    This works great on the Dell Latitude E5410 on Linux Mint 12 as well by the way, and the direct link to the driver is:
    http://people.canonical.com/~sforshee/alps-touchpad/psmouse-alps-0.6/psmouse-alps-dkms_0.6_all.deb

    To install:

    sudo dpkg -i psmouse-alps-dkms_0.6_all.deb

    I hate the touchpad PERIOD!  I come from a Toshiba background that used the ACCUPOINT STICK as it is technically referred to.  I'm not sure who gave it another name, but this is the original, official name for the mouse in the middle of the keyboard that I much prefer over the touchpad.  In fact, Dell sent my laptop to me originally with only a touchpad, and being a laptop technician for a number of years in a Toshiba Premier Service Center, I do know a thing or two about stripping a laptop down the base pan and putting it back together in record times.  I had to order the special keyboard AND palmrest and put it in myself.  
    The touchpad does indeed become unresponsive when I am typing using the system settings.  Where this is a complete solution now, is that after loading the driver, it splits the touchpad out of the equation, and I can write a script to disable the touchpad entirely now!  Previously the touchpad and Accupoint stick were tied together,  After loading the driver, simply do an:
    xinput list
    Which gives you:
    ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ DualPoint Stick id=11 [slave pointer (2)]
    ⎜ ↳ AlpsPS/2 ALPS DualPoint TouchPad id=12 [slave pointer (2)]
    
    
    
    
    And you can now disable the touchpad with:
    xinput set-prop 12 "Device Enabled" 0
    
    
  • Also, if you feel comfortable with a screwdriver, you can always try and unplug the touchpad altogether if it's separate from the Accupoint on your system and if this is something you want to do, but I prefer software.