Dell Inspiron 2200 :The Device in the system modular bay cannot be identified - General Hardware - Laptop - Dell Community

Dell Inspiron 2200 :The Device in the system modular bay cannot be identified


Laptop computer Forums (Audio, General Hardware, Video)

Dell Inspiron 2200 :The Device in the system modular bay cannot be identified

This question is not answered

Hi Dell Techs

I am using ´╗┐´╗┐Dell Inspiron 2200 for past 5 Yrs with no major trouble, except minor issues. the power plug pin was damaged so i got a new charger that woks that had same 19v voltage but slightly different Amperes (3.42A but origional charger had 3.14A). so problem starts from this point onwards

the first time i stated the PC after connecting new charge everything works fine, I used PC for two hours, then after restart i got error at BIOS

"The Device in the system modular bay cannot be identified. It may not be completely inserted or may have some other problem. Please read and complete the following steps in order:

1) Press the device completely and firmly into the bay.
2) Power off the system.
3) Press the power button to retry detecting the device.

Press ESC to ignore error and continue."

i just ignore the messeg and go to BIOS Setup and look for Had Drive, it says None fo Piimary HDD and CD ROM is visible.

I am stuck with it, Plz help.


Plzzzzz Help you guys

Many Thanks

All Replies
  • On this model, that error usually means the hard drive has failed.  Remove and reinstall the drive.  Then check again - if the drive doesn't show up, it's toast - you'll need a new, 2.5" 9.5 mm or slimmer EIDE drive, 120 G or smaller.

    If the drive does show up, press f12, boot to the diagnostics and run an extended test.

  • Hi ejn63 . Thanx for reply.

    i had tried to reinstall the drive, still not working, infact the drive is not corrupt, i connect it to another PC as slave drive and that worked fine, also i had run it from Ubuntu Live OS on same Laptop and that works too, but the BIOS on board are not recognizing the Hard Drive and CD-ROM.

    using f12 diagnostics test is not tesing the drives

    what could be the problem??



  • If you're sure the drive is OK -- and it may still not be, even if you can read it in another system - then it's the mainboard that's bad.

  • hmmm, i have to surrender now

    main boad issue ....

    well thanx fo assistance


  • Hello Dell Tech Guys

    i had tried to solve The Hard drive problem for my Inspiron 2200. i had run the Dell Diagnostics test, every test was passed successfully except hard drive. i had also tied to update flash BIOS program using  Bootable USB MS DOS disk.


    but the Bios update install gives an error on red dialog blue background.

    "BIOS update cannot run under protected environment

    ROM update not performed

    press any key to exit"

    BTW after diagnostics test once had drive and CD-ROM was shown in Bios Setup, but on reset it was gone.

    Note: system date and time also reset on each every system start. i guess CMOS coin cell battery need a replace

    any help



  • For all those that stumble upon  this page and are experiencing this problem with Inspiron2200,

    in other words, your drive failed and you installed another drive, (probably larger size and different brand name) and now your BIOS does not recognize it under devices (most likely when new drive inserted you can't see the  CD-ROM either).

    on the new drive, look on the label and  see what it say about having jumpers MASTER / SLAVE / CABLE SELECT.

    find a miniature jumper (smaller than what CD-ROM has) and jump the CABLE SELECT setting. If you can not find a jumper that size, improvise,  I am guessing a speaker wire pierced by 2 pins would work too, but these methods are not advised, you can break pins. I used a jumper.

    my new drive is a Seagate. the 4 pins that are separate from the main rows of pins are the mode-select pins. Jump the bottom 2 pins (bottom being the side without the big label, the same side with the circuit card showing or the screw holes), reinstall drive and check in BIOS it is  recognized under devices.

    This method worked for me. XP installing now.

    Also, my BIOS version is A07, I have updated from A03 when I was troubleshooting this. I do not know if the BIOS version affects this  resolution.

    Good Luck to all.

  • Assalamu 'alaikum

    I have same problem. But just remove a CD/DVD ROM, and then reboot.

    My laptop was normal again..

  • Yes its is working... when i removed my laptop dvd drive.... the message gone... thanks yana suryana Smile