n5110 USB 3.0 doesn't work - General Hardware - Laptop - Dell Community

n5110 USB 3.0 doesn't work


Laptop computer Forums (Audio, General Hardware, Video)

n5110 USB 3.0 doesn't work

This question has suggested answer(s)

Dear Experts,
I bought a Dell Inspiron n5110 but it USB 3.0 is not working for me when i put the mouse or flash-drive in, do i suppose to install a driver to get this work or any other assistance you guy can do for me? Any link for a driver? because i was trying to find but didn't help. Pleasee HELP.

Thanks a lot in advance!

All Replies
  • Quisar

    Does the USB 2.0 ports work correctly?  Is it only the USB 3.0 ports that are having problems? If it is just the USB 3.0 ports here are links for drivers for your notebook and USB 3.0.



    Please let me know if they help.


    Specialize in Laptops, Mobile Devices

  • Thanks Terry!

    Can you please help me with the LAN/Ethernet Driver as well? i can't find it anywhere. Please Help!, i will really appreciate. Thanks in advance :)

  • i installed RealTec Ethernet Controller (R292450) but it doesn't work :(

  • Look for the model of wireless adapter that was ordered on your system on the following link and download the corresponding driver.


    Shoot me a private message with the service tag of the system if you don't know what wireless adapter shipped with your system.


    Specialize in Laptops, Mobile Devices

  • Hi Terry!

    I have a N5110 and installing the Renesas USB 3.0 Host Contrller driver 2.0.32 won't solve my problem:

    External HDD case (USB 3.0 - SATA converter). When copying from this external HDD to the N5110 HDD the process stops many times and won't copy all files. Many files are unreadable.

    It seems that it connects/disconnets periodically.

    USB 2.0 works fine.

    Please help!


  • qaisar

    I am sorry, you did say Ethernet driver.   The only driver that I know is the R292450 driver located at the following link.


    When you tried to install the driver what happened?  You may need to uninstall the driver first before reinstalling.  Look for Realtek driver showing up in programs and features (add / remove programs) in control panel. Select it and click uninstall. Once the driver is removed try reinstalling the downloaded driver.

    There are no link lights on this model.  For further troubleshooting just verify that your network cables and hardware (modems and routers) work with other systems. Make sure that the problem is with the notebook before going any further than installing the driver.

    If you have verified that your networking hardware is functional and works fine with other systems (if you are swapping out systems to a cable modem, before to reset the cable modem first). Reinstalling the driver did not help. Then the problem will either be a problem with Windows and running PC restore should help.  Or that the I/O board may need to be replaced.


    Specialize in Laptops, Mobile Devices

  • Download the Renesas driver from downloadcenter.intel.com/Detail_Desc.aspx.

    The driver installs the "USB 3.0 Host Controller Utility". Go to this app (from Start >...) and disable the energy managing functions.

  • Thanks Terry, I mentioned in my other post that it started working today and the RealTek driver is the correct one. it's working properly on the network. Thanks a lot for you kind help. I really appreciate it :)

  • Good day to you sir!

    I also have the same problem... I tried both links for drivers... however the problem is... it can only read usb 3.0 devices... it seems like it is not backward compatible...

    Hoping for your reply.. Thanks

  • the usb 2.0 ports work normally both with usb 2.0 device and the usb 3.0 devce.

    the usb 3.0 ports   also works with usb 2.0 device.

    but not with  usb 3.0..


    i tried the renesas driver updates..actually most of them v1.0.20 ,v2.0.32,v2.0.40,v2.1.27..

    but the usb 3.0 port doesn respond to a usb 3.0 device

  • I'm in an almost identical situation. It is very, very frustrating. I would appreciate any help on this.

    I have Dell Inspiron n5110 laptop. After the first OS install, I have downloaded drivers from the Dell's official page. I installed them in the recommended order. I am 100% sure I have the correct drivers and also most recent/updated drivers.

    My laptop is a few months old. I had not a two consecutive days of USB 3.0 ports working properly.

    I have tried everything you can find on internet on this problem - the Wistron/NEC/Renesas USB 3.0 Host Controller driver problem - and the "This device cannot start. (Error 10)" message. I tried Dell drivers, NEC/Renesas drivers, reinstalling whole system several times, literally everything out there you can find and had absolutely no luck. 

    Even worse, not only that my USB 3.0 ports are not working as 3.0 ports but also are not working in backward compatible way, with the USB 2.0 devices. They are completely oblivious to any kind of connected hardware. External USB 3.0 hard drive will spin, and USB 2.0 mouse will light but none will be recognized by the OS. 

    Occasionally I would make them work but only for a shortest period of time, until the first reboot. Sometime, they will start to work if I remove the device in the Device Manager (Renesas USB 3.0 Host Controller and USB 3.0 Root Hub) and uninstall the driversin the Programs and Features, then reboot, then reinstall the drivers from Dell page, then reboot again and boot into BIOS, toggle any USB parameter (e.g. Wake on USB or how do you call it) and then finally boot into OS. The system will then find the new hardware and will recognize the USB 3.0 driver. 

    If I start Dell QuickSet/Windows Mobility Center and for an example, change the function keys behavior, it will often immediately turn the USB 3.0 ports completely off, both for 3.0 and 2.0 devices. Also, shut down and reboot will also kill them every single time with no exception.

     I have only one working port, the standard USB 2.0 port on the left. For an example, I can boot into Linux live USB with it but the other two (USB 3.0 ports) are dead for the most of the time, even for USB 2.0 devices.

     I tried to access Dell chat support but it is not available for this product anymore, as I was informed. I'm not in the USA and I don't know to whom to talk anymore. 

    I would deeply appreciate solution or any other kind of help on this issue. Thank you in advance.

  • So, no one is answering to this… OK, let me share my experience.

    I spent last two days constantly reinstalling OS and the drivers. This really seem like a BIOS issue rather than drivers issue, as mentioned on an another XPS 15 topic


    I used Dell recommended order of installing the drivers:


    I would reboot the laptop after installation of each driver, even after those who didn't ask for restart as the part of the installation. After every reboot I would hook up my external USB 3.0 drive to the USB 3.0 port.

    Right after installing the USB 3.0 Host Controller driver the ports would work for the USB 3.0 devices (although not for the USB 2.0 devices). But as always they would stop working after one of the following reboots. Sometime it would be immediately after installing the next driver, sometimes it would be after installing the last one.

    What I noticed, though, is that occasionally I was able to make the OS to recognize the installed USB 3.0 Host Controller and Hub by Enabling/Disabling an USB parameter in BIOS. There was also no rule to this one either, some time USB Powershare did the trick, sometimes USB Wake Support and sometimes Restore Defaults option.

    This made me believe that there's something fishy going on in the BIOS. Perhaps it's the hardware issue, as mentioned on so many other topics but it reflects on the BIOS obviously. I hope there are engineers reading this and that they can provide any kind of explanation as I'm 100% certain that they too realize that the drivers story does no good anymore.

    Right now I still have only two USB ports working (2.0 and 2.0/E-SATA). Two USB 3.0 ports deliver power but are completely dead as far as OS is concerned.

    So, can someone please help me to at least use USB 3.0 as USB 2.0 ports?

    Thank you very much.

  • hey i hay N5110 i need the driver of dell stages

  • and also PCI and SM Bus Controller

  • 2 out of 3 USB ports not working - dell inspiron n5110 please help.......

    in device manager window, getting exclamation mark under "other devices" ------ "universal serial bus (USB) controller"